summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
-rw-r--r--foundationdb-server-bin.install17
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..094be8eb826e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = foundationdb-server-bin
+ pkgdesc = FoundationDB clients and library. FoundationDB is a scalable, fault-tolerant, ordered key-value store with full ACID transactions. This package contains client utilities and libraries.
+ pkgver = 5.1.7
+ pkgrel = 1
+ url = https://www.foundationdb.org
+ install = foundationdb-server-bin.install
+ arch = x86_64
+ license = Apache 2.0
+ options = !strip
+ options = !emptydirs
+ source_x86_64 = https://www.foundationdb.org/downloads/5.1.7/ubuntu/installers/foundationdb-server_5.1.7-1_amd64.deb
+ sha512sums_x86_64 = dc2203342fea472b3801fb3e82096eb000e48e6610fe6f14ba723cda0d6c2c1a21561b2125b837a5e72bb12770519fb39e6b38533d9d267803727da85bf2d147
+
+pkgname = foundationdb-server-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fbe07d50a3ae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Nick Hibberd
+pkgname=foundationdb-server-bin
+pkgver=5.1.7
+pkgrel=1
+pkgdesc="FoundationDB clients and library. FoundationDB is a scalable, fault-tolerant, ordered key-value store with full ACID transactions. This package contains client utilities and libraries."
+arch=('x86_64')
+url="https://www.foundationdb.org"
+license=('Apache 2.0')
+groups=('')
+depends=('')
+options=('!strip' '!emptydirs')
+install=${pkgname}.install
+source_x86_64=("https://www.foundationdb.org/downloads/${pkgver}/ubuntu/installers/foundationdb-server_${pkgver}-${pkgrel}_amd64.deb")
+sha512sums_x86_64=('dc2203342fea472b3801fb3e82096eb000e48e6610fe6f14ba723cda0d6c2c1a21561b2125b837a5e72bb12770519fb39e6b38533d9d267803727da85bf2d147')
+
+package(){
+
+ # Extract package data
+ tar xf data.tar.xz -C "${pkgdir}"
+
+}
diff --git a/foundationdb-server-bin.install b/foundationdb-server-bin.install
new file mode 100644
index 000000000000..4c8c3f3596d1
--- /dev/null
+++ b/foundationdb-server-bin.install
@@ -0,0 +1,17 @@
+post_install() {
+ if [ "$1" = configure ]; then
+ ldconfig
+
+ if [ "$2" = "" ]; then
+ getent group foundationdb >/dev/null || groupadd --system foundationdb
+ getent passwd foundationdb >/dev/null || useradd --system --disabled-login --gid foundationdb --no-create-home --home-dir /var/lib/foundationdb --gecos "FoundationDB" --shell /usr/bin/false foundationdb
+
+ chown foundationdb:foundationdb /etc/foundationdb
+ chmod 775 /etc/foundationdb
+ fi
+ fi
+}
+
+post_upgrade() {
+ post_install
+}