summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--fpocket.patch18
3 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 346055d01237..d1d79bae3861 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fpocket-git
pkgdesc = Fpocket is a very fast open source protein pocket detection algorithm based on Voronoi tessellation
- pkgver = r84.d9012c1
+ pkgver = r93.c530900
pkgrel = 1
url = https://github.com/Discngine/fpocket
arch = i686
@@ -14,7 +14,7 @@ pkgbase = fpocket-git
source = fpocket-git::git+https://github.com/Discngine/fpocket.git
source = fpocket.patch
sha1sums = SKIP
- sha1sums = 9e2ec2ad73e0951446d3521335fc90cda12ebf8b
+ sha1sums = b6a1d7dc414c0a66fca8eeb55cb6f432c589f3b8
pkgname = fpocket-git
diff --git a/PKGBUILD b/PKGBUILD
index 037ae4235b5a..c9fe5e04376e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
pkgname=fpocket-git
-pkgver=r84.d9012c1
+pkgver=r93.c530900
pkgrel=1
pkgdesc="Fpocket is a very fast open source protein pocket detection algorithm based on Voronoi tessellation"
arch=('i686' 'x86_64')
@@ -11,7 +11,7 @@ makedepends=('git' 'patch' 'gcc')
source=("$pkgname::git+https://github.com/Discngine/fpocket.git"
"fpocket.patch")
sha1sums=('SKIP'
- '9e2ec2ad73e0951446d3521335fc90cda12ebf8b')
+ 'b6a1d7dc414c0a66fca8eeb55cb6f432c589f3b8')
pkgver() {
cd "${pkgname}"
diff --git a/fpocket.patch b/fpocket.patch
index 980b5abd041b..5ad2dabc1e97 100644
--- a/fpocket.patch
+++ b/fpocket.patch
@@ -1,16 +1,16 @@
---- makefile 2019-03-29 00:31:30.876920063 +0300
-+++ makefile.new 2019-03-29 00:29:17.804365698 +0300
-@@ -34,11 +34,11 @@
+--- makefile 2019-09-02 19:31:17.384033567 +0300
++++ makefile.new 2019-09-02 19:35:01.201051582 +0300
+@@ -42,11 +42,11 @@
CDEBUG = -DMNO_MEM_DEBUG
CWARN = -Wall -Wextra -Wwrite-strings -Wstrict-prototypes
--CFLAGS = $(CWARN) $(COS) $(CDEBUG) -O2 -g -pg -std=c99 -I$(PLUGINDIR)/include -I$(PLUGINDIR)/$(ARCH)/molfile #$(CGSL)
-+CFLAGS = $(CWARN) $(COS) $(CDEBUG) -O2 -g -pg -std=c99 -I$(PLUGINDIR)/include -I/usr/include/vmd-molfile-plugins/ #$(CGSL)
+-CFLAGS = $(CWARN) $(COS) $(CDEBUG) -O2 -g -pg -std=c99 -I$(PLUGINDIR)/include -I$(PLUGINDIR)/$(ARCH)/molfile
++CFLAGS = $(CWARN) $(COS) $(CDEBUG) -O2 -g -pg -std=c99 -I$(PLUGINDIR)/include -I/usr/include/vmd-molfile-plugins
QCFLAGS = -O -g -pg -ansi
LGSL = -L$(PATH_GSL)lib -lgsl -lgslcblas
--LFLAGS = -lm -L$(PLUGINDIR)/$(ARCH)/molfile $(PLUGINDIR)/$(ARCH)/molfile/libmolfile_plugin.a -lnetcdf -lstdc++
-+LFLAGS = -lm -L/usr/lib/vmd-molfile-plugins /usr/lib/vmd-molfile-plugins/libmolfile_plugin.a -lnetcdf -lstdc++
+-LFLAGS = -lm -L$(PLUGINDIR)/$(ARCH)/molfile $(PLUGINDIR)/$(ARCH)/molfile/libmolfile_plugin.a -lstdc++
++LFLAGS = -lm -L/usr/lib/vmd-molfile-plugins /usr/lib/vmd-molfile-plugins/libmolfile_plugin.a -lstdc++
+ NETCDFFLAGS = -lnetcdf
+
#
- #------------------------------------------------------------
- # BINARIES OBJECTS