summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD23
-rw-r--r--fpocket.patch28
3 files changed, 28 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f680b722c9f2..346055d01237 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fpocket-git
pkgdesc = Fpocket is a very fast open source protein pocket detection algorithm based on Voronoi tessellation
- pkgver = 3.1.2
+ pkgver = r84.d9012c1
pkgrel = 1
url = https://github.com/Discngine/fpocket
arch = i686
@@ -8,10 +8,13 @@ pkgbase = fpocket-git
license = MIT
makedepends = git
makedepends = patch
- source = git+https://github.com/Discngine/fpocket.git
+ makedepends = gcc
+ depends = netcdf
+ depends = vmd-molfile-plugins
+ source = fpocket-git::git+https://github.com/Discngine/fpocket.git
source = fpocket.patch
sha1sums = SKIP
- sha1sums = 376060e821c23483effa2befb6e090d81dcc4d5e
+ sha1sums = 9e2ec2ad73e0951446d3521335fc90cda12ebf8b
pkgname = fpocket-git
diff --git a/PKGBUILD b/PKGBUILD
index eefda00d2b1e..037ae4235b5a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,36 @@
# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
pkgname=fpocket-git
-pkgver=3.1.2
+pkgver=r84.d9012c1
pkgrel=1
pkgdesc="Fpocket is a very fast open source protein pocket detection algorithm based on Voronoi tessellation"
arch=('i686' 'x86_64')
license=('MIT')
url="https://github.com/Discngine/fpocket"
-makedepends=('git' 'patch')
-source=("git+https://github.com/Discngine/fpocket.git"
+depends=('netcdf' 'vmd-molfile-plugins')
+makedepends=('git' 'patch' 'gcc')
+source=("$pkgname::git+https://github.com/Discngine/fpocket.git"
"fpocket.patch")
sha1sums=('SKIP'
- '376060e821c23483effa2befb6e090d81dcc4d5e')
+ '9e2ec2ad73e0951446d3521335fc90cda12ebf8b')
+
+pkgver() {
+ cd "${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
prepare() {
- cd ${srcdir}/fpocket
+ cd ${pkgname}
patch -Np0 -i "${srcdir}/fpocket.patch"
}
build() {
- cd ${srcdir}/fpocket
+ cd ${pkgname}
make
}
package() {
- mkdir -p ${pkgdir}/usr/bin
- mkdir -p ${pkgdir}/usr/share/man/man8
-
- cd ${srcdir}/fpocket
+ cd ${pkgname}
install -Dm755 bin/fpocket ${pkgdir}/usr/bin/fpocket
install -Dm755 bin/dpocket ${pkgdir}/usr/bin/dpocket
diff --git a/fpocket.patch b/fpocket.patch
index 14dc20324eda..980b5abd041b 100644
--- a/fpocket.patch
+++ b/fpocket.patch
@@ -1,26 +1,16 @@
---- makefile 2018-09-14 16:37:11.552447515 +0300
-+++ makefile 2018-09-14 16:35:07.558785168 +0300
-@@ -38,7 +38,7 @@
+--- makefile 2019-03-29 00:31:30.876920063 +0300
++++ makefile.new 2019-03-29 00:29:17.804365698 +0300
+@@ -34,11 +34,11 @@
+ CDEBUG = -DMNO_MEM_DEBUG
+ CWARN = -Wall -Wextra -Wwrite-strings -Wstrict-prototypes
+
+-CFLAGS = $(CWARN) $(COS) $(CDEBUG) -O2 -g -pg -std=c99 -I$(PLUGINDIR)/include -I$(PLUGINDIR)/$(ARCH)/molfile #$(CGSL)
++CFLAGS = $(CWARN) $(COS) $(CDEBUG) -O2 -g -pg -std=c99 -I$(PLUGINDIR)/include -I/usr/include/vmd-molfile-plugins/ #$(CGSL)
QCFLAGS = -O -g -pg -ansi
LGSL = -L$(PATH_GSL)lib -lgsl -lgslcblas
-LFLAGS = -lm -L$(PLUGINDIR)/$(ARCH)/molfile $(PLUGINDIR)/$(ARCH)/molfile/libmolfile_plugin.a -lnetcdf -lstdc++
-+LFLAGS = -lm -L$(PLUGINDIR)/$(ARCH)/molfile $(PLUGINDIR)/$(ARCH)/molfile/libmolfile_plugin.a -lstdc++
++LFLAGS = -lm -L/usr/lib/vmd-molfile-plugins /usr/lib/vmd-molfile-plugins/libmolfile_plugin.a -lnetcdf -lstdc++
#
#------------------------------------------------------------
# BINARIES OBJECTS
---- src/mdpocket.c 2018-09-14 16:37:31.845834900 +0300
-+++ src/mdpocket.c 2018-09-14 16:35:21.485488676 +0300
-@@ -92,10 +92,10 @@
- char pdb_code[350] = "";
-
-
-- if (!strncmp(par->traj_format, "net", 3)) {
-+/* if (!strncmp(par->traj_format, "net", 3)) {
- molfile_netcdfplugin_init();
- molfile_netcdfplugin_register(NULL, register_cb);
-- }
-+ }*/
- if (!strncmp(par->traj_format, "dcd", 3)) {
- molfile_dcdplugin_init();
- molfile_dcdplugin_register(NULL, register_cb);