summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD55
-rw-r--r--disable-systemd-protection.patch17
3 files changed, 95 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bf50ba372dec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = fprintd-vfs_proprietary
+ pkgdesc = D-Bus service to access fingerprint readers, modified for the vfs_proprietary plugin
+ pkgver = 0.8.1
+ pkgrel = 1
+ url = https://www.freedesktop.org/wiki/Software/fprint/fprintd
+ arch = x86_64
+ groups = fprint
+ license = GPL
+ makedepends = intltool
+ makedepends = gtk-doc
+ makedepends = gnome-common
+ makedepends = git
+ depends = libfprint-vfs_proprietary-git
+ depends = dbus-glib
+ depends = polkit
+ conflicts = fprintd
+ source = git+https://gitlab.freedesktop.org/libfprint/fprintd.git#commit=9e32cd525724f21eebf2336a06b13a39c6616ab0
+ source = disable-systemd-protection.patch
+ sha256sums = SKIP
+ sha256sums = 034ded26596473b418fdfcfeb0838fef131819025660d047d41cf343f8c35116
+
+pkgname = fprintd-vfs_proprietary
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..18e1d62846f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Nikolay Rysev <mad.f3ka@gmail.com>
+# Modified for vfs_proprietary by Daniel Kamil Kozar <dkk089@gmail.com>
+
+pkgname=fprintd-vfs_proprietary
+pkgname_=fprintd
+pkgver=0.8.1
+pkgrel=1
+pkgdesc="D-Bus service to access fingerprint readers, modified for the vfs_proprietary plugin"
+arch=(x86_64)
+url="https://www.freedesktop.org/wiki/Software/fprint/fprintd"
+license=(GPL)
+depends=(libfprint-vfs_proprietary-git dbus-glib polkit)
+conflicts=(fprintd)
+makedepends=(intltool gtk-doc gnome-common git)
+groups=(fprint)
+_commit=9e32cd525724f21eebf2336a06b13a39c6616ab0 # tags/V_0_8_1^0
+source=(
+ "git+https://gitlab.freedesktop.org/libfprint/fprintd.git#commit=$_commit"
+ 'disable-systemd-protection.patch'
+)
+sha256sums=(
+ 'SKIP'
+ '034ded26596473b418fdfcfeb0838fef131819025660d047d41cf343f8c35116'
+)
+
+pkgver() {
+ cd $pkgname_
+ git describe --tags | sed 's/^V_//;s/_/./g;s/-/+/g'
+}
+
+prepare() {
+ cd $pkgname_
+ patch -p1 -i "${srcdir}/disable-systemd-protection.patch"
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+ cd $pkgname_
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static \
+ --enable-gtk-doc
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ make
+}
+
+package() {
+ cd $pkgname_
+ make DESTDIR="$pkgdir" dbus_confdir=/usr/share/dbus-1/system.d install
+ install -d -m 700 "$pkgdir/var/lib/fprint"
+}
diff --git a/disable-systemd-protection.patch b/disable-systemd-protection.patch
new file mode 100644
index 000000000000..6d0bf820bfaa
--- /dev/null
+++ b/disable-systemd-protection.patch
@@ -0,0 +1,17 @@
+diff --git a/data/fprintd.service.in b/data/fprintd.service.in
+index 5f46810..a308ee3 100644
+--- a/data/fprintd.service.in
++++ b/data/fprintd.service.in
+@@ -8,12 +8,9 @@ BusName=net.reactivated.Fprint
+ ExecStart=@libexecdir@/fprintd
+
+ # Filesystem lockdown
+-ProtectSystem=strict
+ ProtectKernelTunables=true
+ ProtectControlGroups=true
+-ReadWritePaths=@localstatedir@/lib/fprint
+ ProtectHome=true
+-PrivateTmp=true
+
+ # Network
+ PrivateNetwork=true