summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD11
3 files changed, 14 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b074ca05a45..ad10d167e5b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = frangipanni-git
pkgdesc = Program to convert lines of text into a tree structure
- pkgver = 0.4.0.r4.gff97e40
- pkgrel = 1
+ pkgver = 0.5.0.r0.gf7c9a3e
+ pkgrel = 2
url = https://github.com/birchb1024/frangipanni
arch = x86_64
license = MIT
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..73de0d900192
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+!PKGBUILD
+!.SRCINFO
+!.gitignore
+*
diff --git a/PKGBUILD b/PKGBUILD
index b848fcfc53fd..8f4eba279e87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: lmartinez-mirror
pkgname=frangipanni-git
-pkgver=0.4.0.r4.gff97e40
-pkgrel=1
+pkgver=0.5.0.r0.gf7c9a3e
+pkgrel=2
pkgdesc="Program to convert lines of text into a tree structure"
arch=('x86_64')
url="https://github.com/birchb1024/frangipanni"
@@ -18,6 +18,11 @@ pkgver() {
git describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
}
+prepare() {
+ cd "$pkgname"
+ sed -i "s/none/$pkgver/" frangipanni.go
+}
+
build() {
export CGO_CPPFLAGS="${CPPFLAGS}"
export CGO_CFLAGS="${CFLAGS}"
@@ -26,7 +31,7 @@ build() {
export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
cd "$pkgname"
- go build
+ go build -o frangipanni frangipanni.go
}
package() {