summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 71d8c0c68ba4..4e0a7607303a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = freeblocks
pkgdesc = Tetris Attack-like puzzle game
pkgver = 0.5
- pkgrel = 1
+ pkgrel = 2
url = http://github.com/dorkster/freeblocks
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index b001fc2ba797..9a83aa81fe0b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: Christoph J. Thompson <thompsonc@protonmail.ch>
+# Maintainer: Christoph J. Thompson <thompsonc at protonmail dot ch>
pkgname=freeblocks
pkgver=0.5
-pkgrel=1
+pkgrel=2
pkgdesc="Tetris Attack-like puzzle game"
arch=('i686' 'x86_64')
url="http://github.com/dorkster/freeblocks"
@@ -14,7 +14,9 @@ sha256sums=(8da72ccf7bcba585fcd8b65943f590f51aff06286f3ed920a13c0c90fb392e06)
build() {
cd "${pkgname}-${pkgver}"
- cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ cmake \
+ -DCMAKE_C_FLAGS="${CFLAGS}" \
+ -DCMAKE_INSTALL_PREFIX=/usr .
make
}
@@ -22,4 +24,3 @@ package() {
cd "${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
}
-