summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
-rw-r--r--ringtools_imy_fix_tdma_durations.diff33
3 files changed, 6 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2be88a8aed0b..6e92256d7fa7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = freecalypso-tools
pkgdesc = FreeCalypso host tools package
- pkgver = r19
+ pkgver = r20
pkgrel = 1
url = https://www.freecalypso.org/hg/freecalypso-tools
arch = x86_64
@@ -8,9 +8,7 @@ pkgbase = freecalypso-tools
groups = freecalypso
license = custom
conflicts = freecalypso-tools-hg
- source = https://www.freecalypso.org/pub/GSM/FreeCalypso/fc-host-tools-r19.tar.bz2
- source = ringtools_imy_fix_tdma_durations.diff
- sha256sums = a095b309498f30a0bf018692792c84800c2f025ac583afc63a42945186e694fe
- sha256sums = 312e2b2c0720c076d3f0a43c12d29013645609303fa079da269c2784f743ea90
+ source = https://www.freecalypso.org/pub/GSM/FreeCalypso/fc-host-tools-r20.tar.bz2
+ sha256sums = 50185b4b21559581f13c5e840193bc43ccfadeabcd066879006a051883b38444
pkgname = freecalypso-tools
diff --git a/PKGBUILD b/PKGBUILD
index 282ff318369c..6e10bbad82cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Vadim Yanitskiy <fixeria@osmocom.org>
pkgname=freecalypso-tools
-pkgver=r19
+pkgver=r20
pkgrel=1
pkgdesc="FreeCalypso host tools package"
arch=('x86_64' 'i686')
@@ -10,16 +10,8 @@ license=('custom')
groups=('freecalypso')
conflicts=("${pkgname}-hg")
_tarname=fc-host-tools-${pkgver}
-source=("https://www.freecalypso.org/pub/GSM/FreeCalypso/${_tarname}.tar.bz2"
- 'ringtools_imy_fix_tdma_durations.diff')
-sha256sums=('a095b309498f30a0bf018692792c84800c2f025ac583afc63a42945186e694fe'
- '312e2b2c0720c076d3f0a43c12d29013645609303fa079da269c2784f743ea90')
-
-prepare() {
- cd "${_tarname}"
- # https://www.freecalypso.org/hg/freecalypso-tools/rev/a96cb97b66a2
- patch -p1 < "${srcdir}/ringtools_imy_fix_tdma_durations.diff"
-}
+source=("https://www.freecalypso.org/pub/GSM/FreeCalypso/${_tarname}.tar.bz2")
+sha256sums=('50185b4b21559581f13c5e840193bc43ccfadeabcd066879006a051883b38444')
build() {
cd "${_tarname}"
diff --git a/ringtools_imy_fix_tdma_durations.diff b/ringtools_imy_fix_tdma_durations.diff
deleted file mode 100644
index 62049de835dd..000000000000
--- a/ringtools_imy_fix_tdma_durations.diff
+++ /dev/null
@@ -1,33 +0,0 @@
-# HG changeset patch
-# User Mychaela Falconia <falcon@freecalypso.org>
-# Date 1693510698 0
-# Thu Aug 31 19:38:18 2023 +0000
-# Node ID a96cb97b66a221425071357950bfeb616c1ec9c7
-# Parent b515a97e5dff252b24c41fecc139f8db19f6a637
-ringtools/imy: fix duplicate definition of tdma_durations[]
-
-The bug was reported by Vadim Yanitskiy <fixeria@osmocom.org>,
-although the present fix is slightly different from the contributed
-patch: because main.c doesn't need this tdma_durations[] array
-at all, let's simply remove the reference to this array from main.c
-rather than turn it into an extern.
-
-I no longer remember my original thought flow that resulted (by mistake)
-in tdma_durations[] being multiply defined in main.c and durations.c.
-My intent might have been to define all globals in main.c and have
-the reference in durations.c be an extern - and I missed that extern -
-but without clear memory, I have no certainty. In any case, having
-this data array defined in the same module that fills it (durations.c)
-is sensible, so let's make it the new way.
-
-diff -r b515a97e5dff -r a96cb97b66a2 ringtools/imy/main.c
---- a/ringtools/imy/main.c Mon Aug 28 03:52:53 2023 +0000
-+++ b/ringtools/imy/main.c Thu Aug 31 19:38:18 2023 +0000
-@@ -9,7 +9,6 @@
- char *imy_filename;
- char melody_str_buf[MELODY_BUF_SIZE];
- unsigned beats_per_min = 120;
--unsigned tdma_durations[6][4];
- FILE *outF;
-
- main(argc, argv)