summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD17
-rw-r--r--cmakelists.patch21
-rw-r--r--libmath.patch13
4 files changed, 33 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 206f55665d6c..13e3fc548346 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = freegish-git
pkgdesc = Free version of gish, a physics platformer
- pkgver = 1.60.181.f53d915
+ pkgver = 1.60.219.0ab2e82
pkgrel = 1
url = http://github.com/freegish/freegish
install = freegish.install
@@ -16,12 +16,11 @@ pkgbase = freegish-git
depends = libgl
provides = freegish
conflicts = freegish
- source = git://github.com/freegish/freegish
+ source = git+https://github.com/freegish/freegish
source = freegish.desktop
- source = libmath.patch
+ source = cmakelists.patch
md5sums = SKIP
md5sums = 45a57af69e7e6becdac80ed85d87f871
- md5sums = 92f82b888c2f3766af4e17684f84f04e
+ md5sums = ff6e826443f1c6ef3a9813bd7a09f88a
pkgname = freegish-git
-
diff --git a/PKGBUILD b/PKGBUILD
index b54becda506d..7b75e78908c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
-# Maintainer: Cravix < dr dot neemous at gmail dot com >
+# Maintainer: Jose Riha <jose1711 gmail com>
+# Contributor: Cravix < dr dot neemous at gmail dot com >
# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
-# Contributor: Jose Riha <jose1711 gmail com>
pkgname=freegish-git
_pkgname=freegish
-pkgver=1.60.181.f53d915
+pkgver=1.60.219.0ab2e82
pkgrel=1
pkgdesc="Free version of gish, a physics platformer"
arch=('x86_64' 'i686')
@@ -14,15 +14,15 @@ depends=('sdl' 'openal' 'libvorbis' 'libpng' 'libgl')
makedepends=('git' 'cmake')
provides=('freegish')
conflicts=('freegish')
-install='freegish.install'
+install=freegish.install
-source=("git://github.com/${_pkgname}/${_pkgname}"
+source=("git+https://github.com/${_pkgname}/${_pkgname}"
'freegish.desktop'
- 'libmath.patch')
+ 'cmakelists.patch')
md5sums=('SKIP'
'45a57af69e7e6becdac80ed85d87f871'
- '92f82b888c2f3766af4e17684f84f04e')
+ 'ff6e826443f1c6ef3a9813bd7a09f88a')
pkgver() {
cd "$srcdir/$_pkgname"
@@ -32,8 +32,7 @@ pkgver() {
prepare() {
cd "$srcdir/$_pkgname"
- # libmath fix...
- patch -p1 < ../libmath.patch
+ patch -p2 < $srcdir/cmakelists.patch
}
build() {
diff --git a/cmakelists.patch b/cmakelists.patch
new file mode 100644
index 000000000000..3bf16019aa80
--- /dev/null
+++ b/cmakelists.patch
@@ -0,0 +1,21 @@
+diff '--color=auto' -aur src.orig/freegish/CMakeLists.txt src/freegish/CMakeLists.txt
+--- src.orig/freegish/CMakeLists.txt 2022-10-25 00:07:33.614427084 +0200
++++ src/freegish/CMakeLists.txt 2022-10-25 00:07:49.107912260 +0200
+@@ -14,7 +14,7 @@
+ # Uncomment this to hardcode the data path. On the command line, you
+ # would actually give -DDATAPATH='"/usr/share/games/gish"' or similar
+ # but CMake does the extra quoting for us.
+-#add_definitions(-DDATAPATH="/usr/share/games/gish")
++add_definitions(-DDATAPATH="/usr/share/freegish")
+
+ if(MSVC)
+ find_package(Ogg CONFIG REQUIRED)
+@@ -25,7 +25,7 @@
+ find_package(OpenGL REQUIRED)
+
+ else()
+- find_package(SDL2 REQUIRED sdl2)
++ find_package(SDL2 REQUIRED)
+ find_package(OpenAL REQUIRED)
+ find_package(OpenGL REQUIRED)
+ find_package(Vorbis REQUIRED)
diff --git a/libmath.patch b/libmath.patch
deleted file mode 100644
index e39e724faa85..000000000000
--- a/libmath.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- old/CMakeLists.txt 2013-08-28 09:15:50.793738412 +0000
-+++ new/CMakeLists.txt 2013-08-28 09:18:35.696178392 +0000
-@@ -8,8 +8,9 @@
- # Uncomment this to hardcode the data path. On the command line, you
- # would actually give -DDATAPATH='"/usr/share/games/gish"' or similar
- # but CMake does the extra quoting for us.
--#add_definitions(-DDATAPATH="/usr/share/games/gish")
-+add_definitions(-DDATAPATH="/usr/share/freegish")
-
-+find_library(M_LIB m)
- find_package(SDL REQUIRED)
- find_package(OpenAL REQUIRED)
- find_package(OpenGL REQUIRED)