summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD72
-rwxr-xr-xfreeoffice-planmaker3
-rw-r--r--freeoffice-planmaker.desktop79
-rwxr-xr-xfreeoffice-presentations3
-rw-r--r--freeoffice-presentations.desktop78
-rwxr-xr-xfreeoffice-textmaker3
-rw-r--r--freeoffice-textmaker.desktop78
-rw-r--r--freeoffice.install19
9 files changed, 368 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..94193359eccb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = freeoffice
+ pkgdesc = A complete, reliable, lightning-fast and Microsoft Office-compatible office suite with a word processor, spreadsheet, and presentation graphics software.
+ pkgver = 698
+ pkgrel = 1
+ url = http://www.freeoffice.com/
+ install = freeoffice.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = gcc-libs
+ depends = libxmu
+ depends = libxrender
+ depends = xdg-utils
+ depends = shared-mime-info
+ depends = gtk-update-icon-cache
+ depends = desktop-file-utils
+ source = http://www.softmaker.net/down/softmaker-freeoffice-698.tgz
+ source = freeoffice-textmaker
+ source = freeoffice-planmaker
+ source = freeoffice-presentations
+ source = freeoffice-textmaker.desktop
+ source = freeoffice-planmaker.desktop
+ source = freeoffice-presentations.desktop
+ sha256sums = 1f907af341449570f9c60f42d85b427078bd960b75dc5044fa60d09d2b098519
+ sha256sums = 0437328f3fddf93e18ad3df270971802c2e0fcaf3f030588c1301767a968da69
+ sha256sums = c90e2575c71f03f0b627e4f6c70f437b9c40e5878bf9f553a4244b4a1f6dbd3c
+ sha256sums = e6bc7608e58f44b55654c5d1fc93d442a400de638e2cbc6d5a3b3a8fbceaa0e4
+ sha256sums = 1554213ee9058a6594e2b92e47891ad58e593a4ea7d678c755cd32e263f43da8
+ sha256sums = 518913a4e3edb1f38dec65b865cf0687d5a4a5a1ecaa7fb5d653d5516a4d2ff8
+ sha256sums = 2b305734e63c5fba12def3c6ddfa79ef711f1c857fe68250b0d03d56df2bd980
+
+pkgname = freeoffice
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cefb1e09ad19
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,72 @@
+# Maintainer: Muflone http://www.muflone.com/contacts/english/
+
+pkgname=freeoffice
+pkgver=698
+pkgrel=1
+pkgdesc="A complete, reliable, lightning-fast and Microsoft Office-compatible office suite with a word processor, spreadsheet, and presentation graphics software."
+arch=(i686 x86_64)
+url="http://www.freeoffice.com/"
+license=(custom)
+depends=('gcc-libs' 'libxmu' 'libxrender' 'xdg-utils' 'shared-mime-info' 'gtk-update-icon-cache' 'desktop-file-utils')
+if [ "$CARCH" = 'x86_64' ]
+then
+ depends[0]='lib32-gcc-libs'
+ depends[1]='lib32-libxmu'
+ depends[2]='lib32-libxrender'
+fi
+install=${pkgname}.install
+source=("http://www.softmaker.net/down/softmaker-${pkgname}-${pkgver}.tgz"
+ "${pkgname}-textmaker"
+ "${pkgname}-planmaker"
+ "${pkgname}-presentations"
+ "${pkgname}-textmaker.desktop"
+ "${pkgname}-planmaker.desktop"
+ "${pkgname}-presentations.desktop")
+sha256sums=('1f907af341449570f9c60f42d85b427078bd960b75dc5044fa60d09d2b098519'
+ '0437328f3fddf93e18ad3df270971802c2e0fcaf3f030588c1301767a968da69'
+ 'c90e2575c71f03f0b627e4f6c70f437b9c40e5878bf9f553a4244b4a1f6dbd3c'
+ 'e6bc7608e58f44b55654c5d1fc93d442a400de638e2cbc6d5a3b3a8fbceaa0e4'
+ '1554213ee9058a6594e2b92e47891ad58e593a4ea7d678c755cd32e263f43da8'
+ '518913a4e3edb1f38dec65b865cf0687d5a4a5a1ecaa7fb5d653d5516a4d2ff8'
+ '2b305734e63c5fba12def3c6ddfa79ef711f1c857fe68250b0d03d56df2bd980')
+
+build() {
+ [ -d "${pkgname}" ] && rm -rf "${pkgname}"
+ mkdir "${pkgname}"
+ tar xz -f freeoffice.tgz -C "${pkgname}"
+}
+
+package() {
+ msg2 "Installing package files..."
+ install -d "${pkgdir}/usr/lib"
+ cp -r "${srcdir}/${pkgname}" "${pkgdir}/usr/lib"
+ msg2 "Installing license file..."
+ install -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ ln -s "/usr/lib/${pkgname}/license.txt" "${pkgdir}/usr/share/licenses/${pkgname}/license.txt"
+ msg2 "Installing program executables..."
+ install -d "${pkgdir}/usr/bin"
+ install -m 755 -t "${pkgdir}/usr/bin" "${srcdir}/${pkgname}-planmaker"
+ install -m 755 -t "${pkgdir}/usr/bin" "${srcdir}/${pkgname}-textmaker"
+ install -m 755 -t "${pkgdir}/usr/bin" "${srcdir}/${pkgname}-presentations"
+ msg2 "Installing icons..."
+ for size in 16 32 48
+ do
+ install -d "${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps"
+ ln -s "/usr/lib/${pkgname}/icons/pml_${size}.png" "${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps/${pkgname}-planmaker.png"
+ ln -s "/usr/lib/${pkgname}/icons/prl_${size}.png" "${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps/${pkgname}-presentations.png"
+ ln -s "/usr/lib/${pkgname}/icons/tml_${size}.png" "${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps/${pkgname}-textmaker.png"
+
+ install -d "${pkgdir}/usr/share/icons/hicolor/${size}x${size}/mimetypes"
+ ln -s "/usr/lib/${pkgname}/icons/pmd_${size}.png" "${pkgdir}/usr/share/icons/hicolor/${size}x${size}/mimetypes/application-x-pmd.png"
+ ln -s "/usr/lib/${pkgname}/icons/prd_${size}.png" "${pkgdir}/usr/share/icons/hicolor/${size}x${size}/mimetypes/application-x-prd.png"
+ ln -s "/usr/lib/${pkgname}/icons/tmd_${size}.png" "${pkgdir}/usr/share/icons/hicolor/${size}x${size}/mimetypes/application-x-tmd.png"
+ done
+ msg2 "Installing desktop files..."
+ install -d "${pkgdir}/usr/share/applications"
+ install -m 755 -t "${pkgdir}/usr/share/applications" "${pkgname}-textmaker.desktop"
+ install -m 755 -t "${pkgdir}/usr/share/applications" "${pkgname}-planmaker.desktop"
+ install -m 755 -t "${pkgdir}/usr/share/applications" "${pkgname}-presentations.desktop"
+ msg2 "Installing mime file..."
+ install -d "${pkgdir}/usr/share/mime/packages"
+ install -m 644 -t "${pkgdir}/usr/share/mime/packages" "${srcdir}/${pkgname}/mime/softmaker-freeoffice.xml"
+}
diff --git a/freeoffice-planmaker b/freeoffice-planmaker
new file mode 100755
index 000000000000..bf19b7236377
--- /dev/null
+++ b/freeoffice-planmaker
@@ -0,0 +1,3 @@
+#!/bin/sh
+# A script to run PlanMaker.
+/usr/lib/freeoffice/planmaker "$@"
diff --git a/freeoffice-planmaker.desktop b/freeoffice-planmaker.desktop
new file mode 100644
index 000000000000..726ae695ec40
--- /dev/null
+++ b/freeoffice-planmaker.desktop
@@ -0,0 +1,79 @@
+[Desktop Entry]
+Version=1.0
+Encoding=UTF-8
+Type=Application
+GenericName=Spreadsheet
+GenericName[am]=ሠንጠረዥ አስሊ
+GenericName[ar]=جدول
+GenericName[az]=Hesab Cədvəli
+GenericName[bg]=Електронна таблица
+GenericName[bn]=স্প্রেডশিট
+GenericName[bs]=Spreadsheet
+GenericName[ca]=Full de càlcul
+GenericName[cs]=Tabulkový kalkulátor
+GenericName[da]=Regneark
+GenericName[de]=Tabellenkalkulation
+GenericName[dz]=ཤོག་ཁྲམ།
+GenericName[el]=Λογιστικό φύλλο
+GenericName[en_CA]=Spreadsheet
+GenericName[en_GB]=Spreadsheet
+GenericName[en_ZA]=Spreadsheet
+GenericName[es]=Hoja de cálculo
+GenericName[et]=Arvutustabel
+GenericName[eu]=Kalkulu-orria
+GenericName[fi]=Taulukkolaskenta
+GenericName[fil]=Spreadsheet
+GenericName[fr]=Tableur
+GenericName[ga]=Scarbhileog
+GenericName[gl]=Folla de cálculo
+GenericName[gu]=સ્પ્રેડશીટ
+GenericName[he]=גיליון עבודה
+GenericName[hr]=Proračunska tablica
+GenericName[hu]=Táblázatkezelő
+GenericName[is]=Töflureiknir
+GenericName[it]=Foglio di calcolo
+GenericName[ja]=スプレッドシート
+GenericName[ka]=ელცხრილი
+GenericName[ko]=스프레드시트
+GenericName[ku]=Tabloya Hesêb
+GenericName[mk]=Табели
+GenericName[ms]=Hamparan
+GenericName[nb]=Regneark
+GenericName[ne]=स्प्रेडसिट
+GenericName[nl]=Rekenblad
+GenericName[nr]=Spredtjhiti
+GenericName[nso]=Letlakala la go ala tsebišo
+GenericName[oc]=Fuelha de calcul
+GenericName[pa]=ਸਾਰਣੀ
+GenericName[pl]=Arkusz kalkulacyjny
+GenericName[pt]=Folha de Cálculo
+GenericName[pt_BR]=Planilha Eletrônica
+GenericName[ru]=Электронная таблица
+GenericName[rw]=Urupapurorusesuye
+GenericName[sk]=Tabuľka
+GenericName[sq]=Fleta elektronike
+GenericName[sr]=Табеле
+GenericName[sr@Latn]=Tabele
+GenericName[st]=Leqephe la ho ala boitsebiso
+GenericName[sv]=Kalkylark
+GenericName[th]=ตารางคำนวน
+GenericName[tl]=Spreadsheet
+GenericName[tr]=Hesap Çizelgesi
+GenericName[ts]=Xipredxiti
+GenericName[uk]=Електронні таблиці
+GenericName[vi]=Bảng tính
+GenericName[wa]=Tåvleu
+GenericName[xh]=Icwecwe leeseli
+GenericName[zh_CN]=电子表格
+GenericName[zh_TW]=試算表
+GenericName[zu]=Ispredshit
+Comment=PlanMaker lets you create all kinds of spreadsheets -- from simple ones to the most complex ones. Includes a high-caliber charting module.
+Comment[de]=Mit PlanMaker können Sie alle Arten von Arbeitsblättern erstellen -- von ganz einfachen bis zu den komplexesten. Inklusive eines leistungsstarken Diagrammmoduls.
+Terminal=false
+Categories=Application;Office;Spreadsheet
+MimeType=application/x-pmd;application/x-pmv;application/excel;application/x-excel;application/x-ms-excel;application/x-msexcel;application/x-sylk;application/x-xls;application/xls;application/vnd.ms-excel;application/vnd.stardivision.calc;application/vnd.openxmlformats-officedocument.spreadsheetml.sheet;application/vnd.ms-excel.sheet.macroenabled.12;application/vnd.openxmlformats-officedocument.spreadsheetml.template;application/vnd.ms-excel.template.macroenabled.12;
+Name=FreeOffice PlanMaker
+Icon=freeoffice-planmaker
+TryExec=freeoffice-planmaker
+Exec=freeoffice-planmaker %F
+
diff --git a/freeoffice-presentations b/freeoffice-presentations
new file mode 100755
index 000000000000..da587d300d03
--- /dev/null
+++ b/freeoffice-presentations
@@ -0,0 +1,3 @@
+#!/bin/sh
+# A script to run SoftMaker Presentations.
+/usr/lib/freeoffice/presentations "$@"
diff --git a/freeoffice-presentations.desktop b/freeoffice-presentations.desktop
new file mode 100644
index 000000000000..2a13d36df0c9
--- /dev/null
+++ b/freeoffice-presentations.desktop
@@ -0,0 +1,78 @@
+[Desktop Entry]
+Version=1.0
+Encoding=UTF-8
+Type=Application
+GenericName=Presentation
+GenericName[am]=ትዕይንት
+GenericName[az]=Təqdimat
+GenericName[bg]=Презентация
+GenericName[bn]=প্রেজেন্টেশন
+GenericName[bs]=Prezentacija
+GenericName[ca]=Presentació
+GenericName[cs]=Prezentace
+GenericName[da]=Præsentation
+GenericName[de]=Präsentation
+GenericName[dz]=གསལ་སྟོན།
+GenericName[el]=Παρουσίαση
+GenericName[en_CA]=Presentation
+GenericName[en_GB]=Presentation
+GenericName[en_ZA]=Presentation
+GenericName[es]=Presentación
+GenericName[et]=Esitlus
+GenericName[eu]=Aurkezpena
+GenericName[fi]=Esitys
+GenericName[fil]=Pagtatanghal
+GenericName[fr]=Présentation
+GenericName[ga]=Toirbeathas
+GenericName[gl]=Presentación
+GenericName[gu]=રજૂઆત
+GenericName[he]=מצגות
+GenericName[hr]=Prezentacija
+GenericName[hu]=Bemutatókészítő
+GenericName[is]=Impress framsetning
+GenericName[it]=Presentazione
+GenericName[ja]=プレゼンテーション
+GenericName[ka]=პრეზენტაცია
+GenericName[ko]=프리젠테이션
+GenericName[ku]=Pêşkêşî
+GenericName[mk]=Презентација
+GenericName[ms]=Persembahan
+GenericName[nb]=Presentasjon
+GenericName[ne]=प्रस्तुति
+GenericName[nl]=Presentatie
+GenericName[nr]=Phrizentheyitjhini
+GenericName[nso]=Tlhagišo
+GenericName[oc]=Presentacion
+GenericName[pa]=ਪੇਸ਼ਕਾਰੀ
+GenericName[pl]=Prezentacja
+GenericName[pt]=Apresentação
+GenericName[pt_BR]=Apresentação
+GenericName[ru]=Презентация
+GenericName[rw]=Iyerekana
+GenericName[sk]=Prezentácia
+GenericName[sq]=Prezantime
+GenericName[sr]=Презентација
+GenericName[sr@Latn]=Prezentacija
+GenericName[st]=Nehelano
+GenericName[sv]=Presentation
+GenericName[th]=งานนำเสนอ
+GenericName[tl]=Pagtatanghal
+GenericName[tr]=Sunum
+GenericName[ts]=Nkombiso
+GenericName[uk]=Презентації
+GenericName[vi]=Trình diễn
+GenericName[wa]=Prezintåcion
+GenericName[xh]=Umboniso wenkcazelo
+GenericName[zh_CN]=演示文稿
+GenericName[zh_TW]=簡報
+GenericName[zu]=Iprezenteyshin
+Comment=The SoftMaker Presentations software lets you design any kind of presentation - even including special effects, animations, and transitions.
+Comment[de]=SoftMaker Presentations lässt Sie beliebige Präsentationen gestalten - mit Effekten, Animationen und Transitionen.
+Terminal=false
+Categories=Application;Office;Presentation
+MimeType=application/x-prd;application/x-prv;application/x-prs;application/ppt;application/mspowerpoint;application/vnd.ms-powerpoint;application/vnd.openxmlformats-officedocument.presentationml.presentation;application/vnd.ms-powerpoint.presentation.macroenabled.12;application/vnd.openxmlformats-officedocument.presentationml.template;application/vnd.ms-powerpoint.template.macroenabled.12;application/vnd.ms-powerpoint.slideshow.macroEnabled.12;application/vnd.openxmlformats-officedocument.presentationml.slideshow;
+Name=FreeOffice Presentations
+Icon=freeoffice-presentations
+TryExec=freeoffice-presentations
+Exec=freeoffice-presentations %F
+
diff --git a/freeoffice-textmaker b/freeoffice-textmaker
new file mode 100755
index 000000000000..0a0a61ff0526
--- /dev/null
+++ b/freeoffice-textmaker
@@ -0,0 +1,3 @@
+#!/bin/sh
+# A script to run TextMaker.
+/usr/lib/freeoffice/textmaker "$@"
diff --git a/freeoffice-textmaker.desktop b/freeoffice-textmaker.desktop
new file mode 100644
index 000000000000..a333471d6da3
--- /dev/null
+++ b/freeoffice-textmaker.desktop
@@ -0,0 +1,78 @@
+[Desktop Entry]
+Version=1.0
+Encoding=UTF-8
+Type=Application
+GenericName=Word Processor
+GenericName[am]=ጽሁፍ አቀናጅ
+GenericName[ar]=معالج نصوص
+GenericName[az]=Kəlmə İşlədici
+GenericName[bg]=Текстообработка
+GenericName[bn]=ওয়ার্ড প্রসেসর
+GenericName[bs]=Word Processor
+GenericName[ca]=Processador de textos
+GenericName[cs]=Textový procesor
+GenericName[da]=Tekstbehandler
+GenericName[de]=Textverarbeitung
+GenericName[dz]=ཡིག་སྦྱོར་པ།
+GenericName[el]=Επεξεργαστής κειμένου
+GenericName[en_CA]=Word Processor
+GenericName[en_GB]=Word Processor
+GenericName[en_ZA]=Word Processor
+GenericName[es]=Procesador de textos
+GenericName[et]=Kirjutaja
+GenericName[eu]=Testu-prozesadorea
+GenericName[fi]=Tekstinkäsittely
+GenericName[fil]=Tagaproseso ng Salita
+GenericName[fr]=Traitement de texte
+GenericName[ga]=Próiseálaithe Focal
+GenericName[gl]=Procesador de textos
+GenericName[gu]=વર્ડ પ્રોસેસર
+GenericName[he]=מעבד תמלילים
+GenericName[hr]=Obrada teksta
+GenericName[hu]=Szövegszerkesztő
+GenericName[is]=Ritvinnsla
+GenericName[it]=Word processor
+GenericName[ja]=ワープロ
+GenericName[ka]=ტექსტის რედაქტორი
+GenericName[ko]=워드 프로세서
+GenericName[ku]=Bernameya nivîsandinê
+GenericName[mk]=Процесор за текст
+GenericName[ms]=Pemproses Perkataan
+GenericName[nb]=Tekstbehandling
+GenericName[ne]=शब्द प्रशोधक
+GenericName[nl]=Tekstverwerker
+GenericName[nr]=Isenzi Mitlolo
+GenericName[nso]=Sehlami sa Lentšu
+GenericName[oc]=Tractament de tèxt
+GenericName[pa]=ਸ਼ਬਦਕਾਰ
+GenericName[pl]=Edytor tekstu
+GenericName[pt]=Processador de Texto
+GenericName[pt_BR]=Editor de texto
+GenericName[ru]=Редактор текстов
+GenericName[sk]=Textový editor
+GenericName[sq]=Procesues teksti
+GenericName[sr]=Обрада текста
+GenericName[sr@Latn]=Obrada teksta
+GenericName[st]=Word Processor
+GenericName[sv]=Ordbehandlare
+GenericName[th]=พิมพ์งาน
+GenericName[tl]=Tagaproseso ng Salita
+GenericName[tr]=Kelime İşlemci
+GenericName[ts]=Xitirhisi xa marito
+GenericName[uk]=Текстовий процесор
+GenericName[vi]=Bộ xử lý từ
+GenericName[wa]=Aspougneu d' tecse
+GenericName[xh]=Inkqubo Yokuqhuba Amagama
+GenericName[zh_CN]=文字处理
+GenericName[zh_TW]=文書處理器
+GenericName[zu]=Umshini Ohlela Amagama
+Comment=The TextMaker word processor lets you work on any type of document.
+Comment[de]=Die Textverarbeitung TextMaker ermöglicht es Ihnen, beliebige Arten von Dokumenten zu erstellen und zu bearbeiten.
+Terminal=false
+Categories=Application;Office;WordProcessor
+MimeType=application/x-tmd;application/x-tmv;application/msword;application/vnd.ms-word;application/x-doc;text/rtf;application/rtf;application/rtf;application/vnd.oasis.opendocument.text;application/vnd.oasis.opendocument.text-template;application/vnd.stardivision.writer;application/vnd.sun.xml.writer;application/vnd.sun.xml.writer.template;application/vnd.openxmlformats-officedocument.wordprocessingml.document;application/vnd.ms-word.document.macroenabled.12;application/vnd.openxmlformats-officedocument.wordprocessingml.template;application/vnd.ms-word.template.macroenabled.12;application/x-pocket-word;
+Name=FreeOffice TextMaker
+Icon=freeoffice-textmaker
+TryExec=freeoffice-textmaker
+Exec=freeoffice-textmaker %F
+
diff --git a/freeoffice.install b/freeoffice.install
new file mode 100644
index 000000000000..a799cc67c442
--- /dev/null
+++ b/freeoffice.install
@@ -0,0 +1,19 @@
+do_update() {
+ update-mime-database /usr/share/mime > /dev/null
+ gtk-update-icon-cache -f -q /usr/share/icons/hicolor/
+ update-desktop-database -q
+}
+
+post_install() {
+ do_update
+ echo 'To obtain a valid free serial number please visit'
+ echo 'http://www.freeoffice.com/en/download'
+}
+
+post_upgrade() {
+ do_update
+}
+
+post_remove() {
+ do_update
+}