summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--0001-Enable-table-validation-modules.patch7
-rw-r--r--0001-psaux-Correctly-handle-Flex-features-52846.patch38
-rw-r--r--0002-Enable-infinality-subpixel-hinting.patch (renamed from 0003-Enable-infinality-subpixel-hinting.patch)15
-rw-r--r--0003-Enable-long-PCF-family-names.patch (renamed from 0004-Enable-long-PCF-family-names.patch)13
-rw-r--r--PKGBUILD30
6 files changed, 90 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64c79c986751..f1c8e05a49a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = freetype2-cleartype
pkgdesc = Font rasterization library with ClearType patch
- pkgver = 2.8.1
+ pkgver = 2.9
pkgrel = 1
url = https://www.freetype.org/
- arch = i686
arch = x86_64
license = GPL
makedepends = libx11
@@ -15,19 +14,21 @@ pkgbase = freetype2-cleartype
provides = freetype2
provides = libfreetype.so
conflicts = freetype2
- source = https://download-mirror.savannah.gnu.org/releases/freetype/freetype-2.8.1.tar.bz2
- source = https://download-mirror.savannah.gnu.org/releases/freetype/freetype-2.8.1.tar.bz2.sig
+ source = https://download-mirror.savannah.gnu.org/releases/freetype/freetype-2.9.tar.bz2
+ source = https://download-mirror.savannah.gnu.org/releases/freetype/freetype-2.9.tar.bz2.sig
source = 0001-Enable-table-validation-modules.patch
- source = 0003-Enable-infinality-subpixel-hinting.patch
- source = 0004-Enable-long-PCF-family-names.patch
+ source = 0002-Enable-infinality-subpixel-hinting.patch
+ source = 0003-Enable-long-PCF-family-names.patch
+ source = 0001-psaux-Correctly-handle-Flex-features-52846.patch
source = 0007-cleartype.patch
source = freetype2.sh
validpgpkeys = 58E0C111E39F5408C5D3EC76C1A60EACE707FDA5
- md5sums = bf0a210b6fe781228fa0e4a80691a521
+ md5sums = 513c403c110016fdc7e537216a642b1d
md5sums = SKIP
- md5sums = 6e7911925d68acd7758ab61db380ee7b
- md5sums = a24cb1f7b3439e656f8c53f677cdb2f0
- md5sums = ae5ceb3e8f0d8bbce0c8fa21cc2ef458
+ md5sums = a1f96fd4abc2574b04c2599fb1c71293
+ md5sums = 47e916030eec65a17d87641595cc1ae8
+ md5sums = b97d9d0b86f9edb961ee97f771016ba5
+ md5sums = 0292b4dbbefbfc5404390e4879b88de2
md5sums = 9df123ffc4fd56e6345abb2707efd84e
md5sums = fef731289a0f86933ff2d0b3615c3de0
diff --git a/0001-Enable-table-validation-modules.patch b/0001-Enable-table-validation-modules.patch
index 5508d421e0c6..5fd339ff056f 100644
--- a/0001-Enable-table-validation-modules.patch
+++ b/0001-Enable-table-validation-modules.patch
@@ -1,4 +1,5 @@
-From 17dd2751813c3c8b37dac474cc5024473eb9bece Mon Sep 17 00:00:00 2001
+From c7a6a2312313a971089fb592deb8c476be4dca0f Mon Sep 17 00:00:00 2001
+Message-Id: <c7a6a2312313a971089fb592deb8c476be4dca0f.1513462508.git.jan.steffens@gmail.com>
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
Date: Tue, 23 Jun 2015 08:40:29 +0200
Subject: [PATCH 1/4] Enable table validation modules
@@ -8,7 +9,7 @@ Subject: [PATCH 1/4] Enable table validation modules
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/modules.cfg b/modules.cfg
-index 517111efeb642459..64b2a34d510ce8f7 100644
+index 56a2340e56d187aa..3a028329187275df 100644
--- a/modules.cfg
+++ b/modules.cfg
@@ -120,30 +120,30 @@ AUX_MODULES += cache
@@ -45,5 +46,5 @@ index 517111efeb642459..64b2a34d510ce8f7 100644
# Auxiliary PostScript driver component to share common code.
#
--
-2.13.0
+2.15.1
diff --git a/0001-psaux-Correctly-handle-Flex-features-52846.patch b/0001-psaux-Correctly-handle-Flex-features-52846.patch
new file mode 100644
index 000000000000..44630fbdcf1f
--- /dev/null
+++ b/0001-psaux-Correctly-handle-Flex-features-52846.patch
@@ -0,0 +1,38 @@
+From cc2f3cdecff5a351e7e8961b9f2e389ab740231a Mon Sep 17 00:00:00 2001
+From: Ewald Hew <ewaldhew@gmail.com>
+Date: Wed, 10 Jan 2018 13:24:56 +0800
+Subject: [PATCH] [psaux] Correctly handle Flex features (#52846).
+
+* src/psaux/psintrp.c (cf2_interpT2CharString) <cf2_cmdVMOVETO,
+cf2_cmdHMOVETO>: Do not move if doing Flex.
+---
+ src/psaux/psintrp.c | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/src/psaux/psintrp.c b/src/psaux/psintrp.c
+index 5c0ee78..da5a8da 100644
+--- a/src/psaux/psintrp.c
++++ b/src/psaux/psintrp.c
+@@ -852,7 +852,8 @@
+
+ curY = ADD_INT32( curY, cf2_stack_popFixed( opStack ) );
+
+- cf2_glyphpath_moveTo( &glyphPath, curX, curY );
++ if ( !decoder->flex_state )
++ cf2_glyphpath_moveTo( &glyphPath, curX, curY );
+
+ break;
+
+@@ -2674,7 +2675,8 @@
+
+ curX = ADD_INT32( curX, cf2_stack_popFixed( opStack ) );
+
+- cf2_glyphpath_moveTo( &glyphPath, curX, curY );
++ if ( !decoder->flex_state )
++ cf2_glyphpath_moveTo( &glyphPath, curX, curY );
+
+ break;
+
+--
+2.16.1
+
diff --git a/0003-Enable-infinality-subpixel-hinting.patch b/0002-Enable-infinality-subpixel-hinting.patch
index b8f74de22e97..5f4391504bf8 100644
--- a/0003-Enable-infinality-subpixel-hinting.patch
+++ b/0002-Enable-infinality-subpixel-hinting.patch
@@ -1,18 +1,21 @@
-From 239cd8209c8d15a641d4548d386aeae4853b7d23 Mon Sep 17 00:00:00 2001
+From 438b8c65e900d4c28db9eeb2a45e5998048eb471 Mon Sep 17 00:00:00 2001
+Message-Id: <438b8c65e900d4c28db9eeb2a45e5998048eb471.1513462508.git.jan.steffens@gmail.com>
+In-Reply-To: <c7a6a2312313a971089fb592deb8c476be4dca0f.1513462508.git.jan.steffens@gmail.com>
+References: <c7a6a2312313a971089fb592deb8c476be4dca0f.1513462508.git.jan.steffens@gmail.com>
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
Date: Mon, 29 Aug 2016 08:43:10 +0200
-Subject: [PATCH 3/4] Enable infinality subpixel hinting
+Subject: [PATCH 2/4] Enable infinality subpixel hinting
---
include/freetype/config/ftoption.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/include/freetype/config/ftoption.h b/include/freetype/config/ftoption.h
-index 1126716626b570df..ebb44acdbbef9a47 100644
+index 06f3d50bb02fb5ac..e6f9720df9b5d004 100644
--- a/include/freetype/config/ftoption.h
+++ b/include/freetype/config/ftoption.h
-@@ -684,8 +684,8 @@ FT_BEGIN_HEADER
- /* [1] http://www.microsoft.com/typography/cleartype/truetypecleartype.aspx */
+@@ -654,8 +654,8 @@ FT_BEGIN_HEADER
+ /* [1] https://www.microsoft.com/typography/cleartype/truetypecleartype.aspx */
/* */
/* #define TT_CONFIG_OPTION_SUBPIXEL_HINTING 1 */
-#define TT_CONFIG_OPTION_SUBPIXEL_HINTING 2
@@ -23,5 +26,5 @@ index 1126716626b570df..ebb44acdbbef9a47 100644
/*************************************************************************/
--
-2.13.0
+2.15.1
diff --git a/0004-Enable-long-PCF-family-names.patch b/0003-Enable-long-PCF-family-names.patch
index 675423a7c472..be202c1f0902 100644
--- a/0004-Enable-long-PCF-family-names.patch
+++ b/0003-Enable-long-PCF-family-names.patch
@@ -1,17 +1,20 @@
-From 62da6a0f7f5cb77859a793863c386c452411e2a6 Mon Sep 17 00:00:00 2001
+From 7e262bff01573c67432f8b8fd879bf858e1611b3 Mon Sep 17 00:00:00 2001
+Message-Id: <7e262bff01573c67432f8b8fd879bf858e1611b3.1513462508.git.jan.steffens@gmail.com>
+In-Reply-To: <c7a6a2312313a971089fb592deb8c476be4dca0f.1513462508.git.jan.steffens@gmail.com>
+References: <c7a6a2312313a971089fb592deb8c476be4dca0f.1513462508.git.jan.steffens@gmail.com>
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
Date: Sun, 14 May 2017 18:09:31 +0200
-Subject: [PATCH 4/4] Enable long PCF family names
+Subject: [PATCH 3/4] Enable long PCF family names
---
include/freetype/config/ftoption.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/include/freetype/config/ftoption.h b/include/freetype/config/ftoption.h
-index ebb44acdbbef9a47..0b39b417162707e4 100644
+index e6f9720df9b5d004..832c9c3cd200f91a 100644
--- a/include/freetype/config/ftoption.h
+++ b/include/freetype/config/ftoption.h
-@@ -865,7 +865,7 @@ FT_BEGIN_HEADER
+@@ -845,7 +845,7 @@ FT_BEGIN_HEADER
/* If this option is activated, it can be controlled with the */
/* `no-long-family-names' property of the pcf driver module. */
/* */
@@ -21,5 +24,5 @@ index ebb44acdbbef9a47..0b39b417162707e4 100644
/*************************************************************************/
--
-2.13.0
+2.15.1
diff --git a/PKGBUILD b/PKGBUILD
index 57347ca3d36f..5f4592f626c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,10 +8,10 @@
# Contributor: freedom
pkgname=freetype2-cleartype
-pkgver=2.8.1
+pkgver=2.9
pkgrel=1
pkgdesc="Font rasterization library with ClearType patch"
-arch=('i686' 'x86_64')
+arch=(x86_64)
license=('GPL')
url="https://www.freetype.org/"
# adding harfbuzz for improved OpenType features auto-hinting
@@ -22,16 +22,18 @@ conflicts=('freetype2')
provides=('freetype2' 'libfreetype.so')
source=(https://download-mirror.savannah.gnu.org/releases/freetype/freetype-${pkgver}.tar.bz2{,.sig}
0001-Enable-table-validation-modules.patch
- 0003-Enable-infinality-subpixel-hinting.patch
- 0004-Enable-long-PCF-family-names.patch
+ 0002-Enable-infinality-subpixel-hinting.patch
+ 0003-Enable-long-PCF-family-names.patch
+ 0001-psaux-Correctly-handle-Flex-features-52846.patch
0007-cleartype.patch
freetype2.sh
)
-md5sums=('bf0a210b6fe781228fa0e4a80691a521'
+md5sums=('513c403c110016fdc7e537216a642b1d'
'SKIP'
- '6e7911925d68acd7758ab61db380ee7b'
- 'a24cb1f7b3439e656f8c53f677cdb2f0'
- 'ae5ceb3e8f0d8bbce0c8fa21cc2ef458'
+ 'a1f96fd4abc2574b04c2599fb1c71293'
+ '47e916030eec65a17d87641595cc1ae8'
+ 'b97d9d0b86f9edb961ee97f771016ba5'
+ '0292b4dbbefbfc5404390e4879b88de2'
'9df123ffc4fd56e6345abb2707efd84e'
'fef731289a0f86933ff2d0b3615c3de0')
validpgpkeys=('58E0C111E39F5408C5D3EC76C1A60EACE707FDA5')
@@ -43,10 +45,14 @@ prepare() {
patch -Np1 -i ../0001-Enable-table-validation-modules.patch
- patch -Np1 -i ../0003-Enable-infinality-subpixel-hinting.patch
- patch -Np1 -i ../0004-Enable-long-PCF-family-names.patch
+ patch -Np1 -i ../0002-Enable-infinality-subpixel-hinting.patch
+ patch -Np1 -i ../0003-Enable-long-PCF-family-names.patch
patch -Np0 -i ../0007-cleartype.patch
+ # Freetype 2.9 regression: bad rendering for some Type 1 fonts
+ # https://savannah.nongnu.org/bugs/?52846
+ patch -Np1 -i ../0001-psaux-Correctly-handle-Flex-features-52846.patch
+
}
build() {
@@ -55,6 +61,10 @@ build() {
make
}
+check() {
+ cd freetype2
+ make -k check
+}
package() {
install=freetype2.install