summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD50
-rw-r--r--freetype-2.5.5-bytecode.patch12
-rw-r--r--freetype-2.5.5-enable-spr.patch12
-rw-r--r--freetype-2.5.5-enable-valid.patch21
-rw-r--r--freetype-2.5.5-memcpy-fix.patch15
-rw-r--r--freetype-2.5.5-subpixel-disable-quantization.patch20
7 files changed, 157 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a25eb88411df
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = freetype2-cleartype
+ pkgdesc = TrueType font rendering library with ClearType patch
+ pkgver = 2.5.5
+ pkgrel = 1
+ url = http://freetype.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = zlib
+ provides = freetype2=2.5.5
+ conflicts = freetype2
+ options = !libtool
+ source = http://downloads.sourceforge.net/sourceforge/freetype/freetype-2.5.5.tar.bz2
+ source = freetype-2.5.5-subpixel-disable-quantization.patch
+ source = freetype-2.5.5-bytecode.patch
+ source = freetype-2.5.5-enable-spr.patch
+ source = freetype-2.5.5-enable-valid.patch
+ source = freetype-2.5.5-memcpy-fix.patch
+ md5sums = 2a7a314927011d5030903179cf183be0
+ md5sums = f76c05235aaa646b3fe224fcbf2b6ed7
+ md5sums = f08498a4b121cd74dc94506a5bc989b9
+ md5sums = a597c6b931bb830d9b3a995f0f327adb
+ md5sums = 0cb479622259cc6d94abf58c8704787f
+ md5sums = 9faed89411e6103213189652c8e57381
+
+pkgname = freetype2-cleartype
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7a6aa0da011c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: frames <markkuehn at outlook dot com>
+# Contributor: Estevao Valadao <estevao@archlinux-br.org>
+# Contributor: Tetsumaki <http://goo.gl/YMBdA>
+# Contributor: Dave Reisner <d@falconindy.com>
+# Contributor: Lee.MaRS <leemars@gmail.com>
+# Contributor: freedom
+
+pkgname=freetype2-cleartype
+pkgver=2.5.5
+pkgrel=1
+pkgdesc="TrueType font rendering library with ClearType patch"
+arch=('i686' 'x86_64')
+license=('GPL')
+url="http://freetype.sourceforge.net/"
+depends=('zlib')
+conflicts=('freetype2')
+provides=("freetype2=$pkgver")
+options=('!libtool')
+source=("http://downloads.sourceforge.net/sourceforge/freetype/freetype-${pkgver}.tar.bz2"
+ freetype-2.5.5-subpixel-disable-quantization.patch
+ freetype-2.5.5-bytecode.patch
+ freetype-2.5.5-enable-spr.patch
+ freetype-2.5.5-enable-valid.patch
+ freetype-2.5.5-memcpy-fix.patch)
+md5sums=('2a7a314927011d5030903179cf183be0'
+ 'f76c05235aaa646b3fe224fcbf2b6ed7'
+ 'f08498a4b121cd74dc94506a5bc989b9'
+ 'a597c6b931bb830d9b3a995f0f327adb'
+ '0cb479622259cc6d94abf58c8704787f'
+ '9faed89411e6103213189652c8e57381')
+
+prepare() {
+ cd "freetype-$pkgver"
+
+ for p in $(find "$srcdir" -maxdepth 1 -name '*.patch'); do
+ msg2 "Applying $p"
+ patch -Np1 -i "$p"
+ done
+}
+
+build() {
+ cd "freetype-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "freetype-$pkgver"
+ make DESTDIR="$pkgdir" install
+}
diff --git a/freetype-2.5.5-bytecode.patch b/freetype-2.5.5-bytecode.patch
new file mode 100644
index 000000000000..a87291b3a22d
--- /dev/null
+++ b/freetype-2.5.5-bytecode.patch
@@ -0,0 +1,12 @@
+diff -Naur freetype-2.5.5/include/freetype/config/ftoption.h freetype-2.5.5.new/include/freetype/config/ftoption.h
+--- freetype-2.5.5/include/config/ftoption.h 2014-11-19 16:38:59.000000000 -0500
++++ freetype-2.5.5.new/include/config/ftoption.h 2015-04-21 18:17:47.083082649 -0400
+@@ -686,7 +686,7 @@
+ /* http://www.microsoft.com/typography/otspec/glyf.htm */
+ /* http://fonts.apple.com/TTRefMan/RM06/Chap6glyf.html */
+ /* */
+-#undef TT_CONFIG_OPTION_COMPONENT_OFFSET_SCALED
++#define TT_CONFIG_OPTION_COMPONENT_OFFSET_SCALED
+
+
+ /*************************************************************************/
diff --git a/freetype-2.5.5-enable-spr.patch b/freetype-2.5.5-enable-spr.patch
new file mode 100644
index 000000000000..fdaa1d5cada3
--- /dev/null
+++ b/freetype-2.5.5-enable-spr.patch
@@ -0,0 +1,12 @@
+diff -Naur freetype-2.5.5/include/freetype/config/ftoption.h freetype-2.5.5.new/include/freetype/config/ftoption.h
+--- freetype-2.5.5/include/config/ftoption.h 2014-11-19 16:38:59.000000000 -0500
++++ freetype-2.5.5.new/include/config/ftoption.h 2015-04-21 18:12:39.477079011 -0400
+@@ -92,7 +92,7 @@
+ /* This is done to allow FreeType clients to run unmodified, forcing */
+ /* them to display normal gray-level anti-aliased glyphs. */
+ /* */
+-/* #define FT_CONFIG_OPTION_SUBPIXEL_RENDERING */
++#define FT_CONFIG_OPTION_SUBPIXEL_RENDERING */
+
+
+ /*************************************************************************/
diff --git a/freetype-2.5.5-enable-valid.patch b/freetype-2.5.5-enable-valid.patch
new file mode 100644
index 000000000000..49b416b3157e
--- /dev/null
+++ b/freetype-2.5.5-enable-valid.patch
@@ -0,0 +1,21 @@
+diff -Naur freetype-2.5.5/modules.cfg freetype-2.5.5.new/modules.cfg
+--- freetype-2.5.5/modules.cfg 2014-04-20 12:18:50.000000000 -0400
++++ freetype-2.5.5.new/modules.cfg 2015-04-21 18:24:07.648087149 -0400
+@@ -110,7 +110,7 @@
+ AUX_MODULES += cache
+
+ # TrueType GX/AAT table validation. Needs ftgxval.c below.
+-# AUX_MODULES += gxvalid
++AUX_MODULES += gxvalid
+
+ # Support for streams compressed with gzip (files with suffix .gz).
+ #
+@@ -129,7 +129,7 @@
+
+ # OpenType table validation. Needs ftotval.c below.
+ #
+-# AUX_MODULES += otvalid
++AUX_MODULES += otvalid
+
+ # Auxiliary PostScript driver component to share common code.
+ #
diff --git a/freetype-2.5.5-memcpy-fix.patch b/freetype-2.5.5-memcpy-fix.patch
new file mode 100644
index 000000000000..7ee202b602b6
--- /dev/null
+++ b/freetype-2.5.5-memcpy-fix.patch
@@ -0,0 +1,15 @@
+diff -Naur freetype-2.5.5/src/psaux/psobjs.c freetype-2.5.5.new/src/psaux/psobjs.c
+--- freetype-2.5.5/src/psaux/psobjs.c 2014-11-25 02:48:48.000000000 -0500
++++ freetype-2.5.5.new/src/psaux/psobjs.c 2015-04-21 18:31:03.106092062 -0400
+@@ -182,6 +182,11 @@
+ return FT_THROW( Invalid_Argument );
+ }
+
++ if ( length < 0 ) {
++ FT_ERROR(( "ps_table_add: invalid length\n" ));
++ return PSaux_Err_Invalid_Argument;
++ }
++
+ /* grow the base block if needed */
+ if ( table->cursor + length > table->capacity )
+ {
diff --git a/freetype-2.5.5-subpixel-disable-quantization.patch b/freetype-2.5.5-subpixel-disable-quantization.patch
new file mode 100644
index 000000000000..54cdbb451aca
--- /dev/null
+++ b/freetype-2.5.5-subpixel-disable-quantization.patch
@@ -0,0 +1,20 @@
+diff -Naur freetype-2.5.5/src/autofit/aflatin.c freetype-2.5.5.new/src/autofit/aflatin.c
+--- freetype-2.5.5/src/autofit/aflatin.c 2014-11-19 16:37:26.000000000 -0500
++++ freetype-2.5.5.new/src/autofit/aflatin.c 2015-04-21 18:35:03.311094903 -0400
+@@ -1973,14 +1973,14 @@
+ * We snap the width of vertical stems for the monochrome and
+ * horizontal LCD rendering targets only.
+ */
+- if ( mode == FT_RENDER_MODE_MONO || mode == FT_RENDER_MODE_LCD )
++ if ( mode == FT_RENDER_MODE_MONO )
+ other_flags |= AF_LATIN_HINTS_HORZ_SNAP;
+
+ /*
+ * We snap the width of horizontal stems for the monochrome and
+ * vertical LCD rendering targets only.
+ */
+- if ( mode == FT_RENDER_MODE_MONO || mode == FT_RENDER_MODE_LCD_V )
++ if ( mode == FT_RENDER_MODE_MONO )
+ other_flags |= AF_LATIN_HINTS_VERT_SNAP;
+
+ /*