summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD26
2 files changed, 27 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8a81b98787d5..61b3e1354fe1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,25 @@
-# Generated by mksrcinfo v8
-# Sat Dec 29 13:41:46 UTC 2018
pkgbase = frescobaldi
pkgdesc = A LilyPond sheet music text editor.
- pkgver = 3.0.0
- pkgrel = 3
+ pkgver = 3.1.3
+ pkgrel = 2
url = http://www.frescobaldi.org/
arch = any
license = GPL
depends = hyphen
depends = poppler
- depends = python>=3.2
+ depends = python>=3.3
depends = python-ly>=0.9.5
depends = python-poppler-qt5
- depends = python-pyqt5>=5.4
- depends = python-sip
- depends = qt5-base>=5.4
- depends = qt5-svg>=5.4
- depends = qt5-webkit>=5.4
+ depends = python-pyqt5>=5.9
+ depends = python-pyqt5-webengine>=5.9
+ depends = python-pyqt5-sip>=5.9
+ depends = qt5-base>=5.9
+ depends = qt5-svg>=5.9
+ depends = qt5-webkit>=5.9
depends = hicolor-icon-theme
depends = tango-icon-theme
optdepends = lilypond: Music engraving (recommended)
+ optdepends = python-portmidi: MIDI playback (default engine)
optdepends = python-pygame: MIDI playback (alternate engine)
optdepends = portmidi: MIDI playback (fallback engine)
optdepends = hyphen-de: German hyphenation rules
@@ -30,8 +30,9 @@ pkgbase = frescobaldi
optdepends = hyphen-it: Italian hyphenation rules
optdepends = hyphen-nl: Dutch hyphenation rules
optdepends = hyphen-ro: Romanian hyphenation rules
- source = https://github.com/wbsoft/frescobaldi/releases/download/v3.0.0/frescobaldi-3.0.0.tar.gz
- md5sums = dacc4cc23e4de5acef163001d18dfa8c
+ optdepends = python-pycups: Printing to a local CUPS server
+ source = https://github.com/frescobaldi/frescobaldi/releases/download/v3.1.3/frescobaldi-3.1.3.tar.gz
+ sha256sums = 9c7f5036f367691454753f1db06ea02c33501c1e4f24bfb47485103911f3e9c1
pkgname = frescobaldi
diff --git a/PKGBUILD b/PKGBUILD
index 3cbb41bb263e..7f1983c6727f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# Maintainer: Raphaƫl Doursenaud <rdoursenaud@free.fr>
pkgname=frescobaldi
-pkgver=3.0.0
-pkgrel=3
+pkgver=3.1.3
+pkgrel=2
pkgdesc="A LilyPond sheet music text editor."
arch=('any')
url="http://www.frescobaldi.org/"
@@ -13,21 +13,22 @@ license=('GPL')
depends=(
'hyphen'
'poppler'
- 'python>=3.2'
+ 'python>=3.3'
'python-ly>=0.9.5'
'python-poppler-qt5'
- 'python-pyqt5>=5.4'
- 'python-sip'
- 'qt5-base>=5.4'
- 'qt5-svg>=5.4'
- 'qt5-webkit>=5.4'
+ 'python-pyqt5>=5.9'
+ 'python-pyqt5-webengine>=5.9'
+ 'python-pyqt5-sip>=5.9'
+ 'qt5-base>=5.9'
+ 'qt5-svg>=5.9'
+ 'qt5-webkit>=5.9'
'hicolor-icon-theme'
'tango-icon-theme'
)
optdepends=(
'lilypond: Music engraving (recommended)'
-# python-portmidi is currently a python2 package
-# 'python-portmidi: MIDI playback (default engine)'
+# FIXME: python-portmidi is currently not in the AUR
+ 'python-portmidi: MIDI playback (default engine)'
'python-pygame: MIDI playback (alternate engine)'
'portmidi: MIDI playback (fallback engine)'
'hyphen-de: German hyphenation rules'
@@ -38,9 +39,10 @@ optdepends=(
'hyphen-it: Italian hyphenation rules'
'hyphen-nl: Dutch hyphenation rules'
'hyphen-ro: Romanian hyphenation rules'
+ 'python-pycups: Printing to a local CUPS server'
)
-source=(https://github.com/wbsoft/${pkgname}/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz)
-md5sums=('dacc4cc23e4de5acef163001d18dfa8c')
+source=(https://github.com/frescobaldi/${pkgname}/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz)
+sha256sums=('9c7f5036f367691454753f1db06ea02c33501c1e4f24bfb47485103911f3e9c1')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"