summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD18
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d74da69cebae..10ca99ad2900 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = freshplayerplugin-git
pkgdesc = PPAPI-host NPAPI-plugin adapter.
- pkgver = 0.3.6.r2.gf550545
+ pkgver = 0.3.11.r4.g0f46d4a
pkgrel = 1
url = https://github.com/i-rinat/freshplayerplugin
arch = i686
@@ -15,7 +15,6 @@ pkgbase = freshplayerplugin-git
depends = libevent
depends = libgl
depends = v4l-utils
- depends = ffmpeg
depends = icu
depends = libxrandr
depends = libxcursor
@@ -25,4 +24,3 @@ pkgbase = freshplayerplugin-git
sha1sums = SKIP
pkgname = freshplayerplugin-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 9d48c3a6b423..332e2c767662 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,13 +7,13 @@
# Contributor: zman0900 <zman0900@gmail.com>
pkgname=freshplayerplugin-git
-pkgver=0.3.6.r2.gf550545
+pkgver=0.3.11.r4.g0f46d4a
pkgrel=1
pkgdesc='PPAPI-host NPAPI-plugin adapter.'
arch=('i686' 'x86_64')
url='https://github.com/i-rinat/freshplayerplugin'
license=('MIT')
-depends=('pango' 'alsa-lib' 'freetype2' 'libevent' 'libgl' 'v4l-utils' 'ffmpeg' 'icu' 'libxrandr' 'libxcursor' 'pepper-flash')
+depends=('pango' 'alsa-lib' 'freetype2' 'libevent' 'libgl' 'v4l-utils' 'icu' 'libxrandr' 'libxcursor' 'pepper-flash')
makedepends=('cmake' 'ragel' 'git')
conflicts=('freshplayerplugin')
source=("${pkgname}::git+${url}")
@@ -24,16 +24,20 @@ pkgver() {
git describe --tags | sed -e 's:v::' -e 's:-:.r:' -e 's:-:.:g'
}
+prepare() {
+ mkdir -p ${pkgname}/build
+}
+
build() {
- cd "$pkgname"
- cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr
+ cd ${pkgname}/build
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DWITH_HWDEC=OFF ..
make
}
package() {
- cd "$pkgname"
+ cd ${pkgname}/build
make DESTDIR="${pkgdir}" install
- install -Dm644 data/freshwrapper.conf.example "${pkgdir}/usr/share/${pkgname}/freshwrapper.conf.example"
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 ../data/freshwrapper.conf.example "${pkgdir}/usr/share/${pkgname}/freshwrapper.conf.example"
+ install -Dm644 ../LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}