summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD32
-rw-r--r--freshplayerplugin-git.install11
3 files changed, 21 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad0d645965f2..e98ff3ff9eda 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Fri Mar 11 08:51:11 UTC 2016
pkgbase = freshplayerplugin-git
pkgdesc = PPAPI-host NPAPI-plugin adapter.
- pkgver = v0.3.4.r21.g7ba5f2d
+ pkgver = 0.3.5.r21.g4776eeb
pkgrel = 1
url = https://github.com/i-rinat/freshplayerplugin
install = freshplayerplugin-git.install
@@ -16,10 +14,11 @@ pkgbase = freshplayerplugin-git
depends = alsa-lib
depends = freetype2
depends = libevent
- depends = gtk3
+ depends = gtk2
depends = libgl
depends = v4l-utils
depends = ffmpeg
+ depends = icu
optdepends = chromium-pepper-flash: for the necessary Pepper plugin
optdepends = chromium-pepper-flash-standalone: for the necessary Pepper plugin
optdepends = google-chrome: for the necessary Pepper plugin
@@ -27,9 +26,7 @@ pkgbase = freshplayerplugin-git
optdepends = google-chrome-dev: for the necessary Pepper plugin
conflicts = freshplayerplugin
source = freshplayerplugin-git::git+https://github.com/i-rinat/freshplayerplugin
- source = freshplayerplugin-git.install
sha1sums = SKIP
- sha1sums = 331a3b3877249eaf1c3db917bde1dea6c4d374ab
pkgname = freshplayerplugin-git
diff --git a/PKGBUILD b/PKGBUILD
index 291eb7b4310c..906354459f73 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Jack L. Frost <fbt@fleshless.org>
+# Maintainer: WorMzy Tykashi <wormzy.tykashi@gmail.com>
+# Contributor: Jack L. Frost <fbt@fleshless.org>
# Contributor: Corelli <corelli AT sent DOT com>
# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
# Contributor: intelfx <intelfx100 [at] gmail [dot] com>
@@ -6,17 +7,18 @@
# Contributor: zman0900 <zman0900@gmail.com>
pkgname=freshplayerplugin-git
-pkgver=v0.3.4.r21.g7ba5f2d
+pkgver=0.3.5.r21.g4776eeb
pkgrel=1
pkgdesc='PPAPI-host NPAPI-plugin adapter.'
-arch=( 'i686' 'x86_64' )
+arch=('i686' 'x86_64')
url='https://github.com/i-rinat/freshplayerplugin'
-license=( 'MIT' )
-depends=( 'pango' 'alsa-lib' 'freetype2' 'libevent' 'gtk3' 'libgl' 'v4l-utils' 'ffmpeg' )
-makedepends=( 'cmake' 'ragel' 'git' )
-conflicts=( 'freshplayerplugin' )
-source=( "${pkgname}::git+${url}" "${pkgname}.install" )
+license=('MIT')
+depends=('pango' 'alsa-lib' 'freetype2' 'libevent' 'gtk2' 'libgl' 'v4l-utils' 'ffmpeg' 'icu')
+makedepends=('cmake' 'ragel' 'git')
+conflicts=('freshplayerplugin')
+source=("${pkgname}::git+${url}")
install="${pkgname}.install"
+sha1sums=('SKIP')
optdepends=(
'chromium-pepper-flash: for the necessary Pepper plugin'
@@ -28,29 +30,19 @@ optdepends=(
pkgver() {
cd "$pkgname"
-
- if git_version=$( git describe --long --tags 2>/dev/null ); then
- IFS='-' read last_tag tag_rev commit <<< "$git_version"
- printf '%s.r%s.%s' "$last_tag" "$tag_rev" "$commit"
- else
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- fi
+ git describe --tags | sed -e 's:v::' -e 's:-:.r:' -e 's:-:.:g'
}
build() {
cd "$pkgname"
- cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DWITH_GTK=3
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr
make
}
package() {
cd "$pkgname"
-
make DESTDIR="${pkgdir}" install
install -Dm644 data/freshwrapper.conf.example "${pkgdir}/usr/share/${pkgname}/freshwrapper.conf.example"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-
-sha1sums=('SKIP'
- '331a3b3877249eaf1c3db917bde1dea6c4d374ab')
diff --git a/freshplayerplugin-git.install b/freshplayerplugin-git.install
index 9d52af027457..7b9da821bda1 100644
--- a/freshplayerplugin-git.install
+++ b/freshplayerplugin-git.install
@@ -1,7 +1,8 @@
post_install() {
- while read; do printf '%s\n' "$REPLY"; done <<- EOF
- Warning! This package requires the pepper flash plugin
- that is available in one of the packages in the optdepends
- array! It will not work without one of those!
- EOF
+ /usr/bin/printf -- \
+" ------------------------------------------------------------
+ Warning! This package requires the pepper flash plugin
+ that is available in one of the packages in the optdepends
+ array! It will not work without one of those!
+ ------------------------------------------------------------"
}