summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD49
-rw-r--r--frogatto-git.desktop11
-rw-r--r--frogatto-git.sh3
4 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..45d13cb4a767
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = frogatto-git
+ pkgdesc = An action-adventure game, starring a certain quixotic frog.
+ pkgver = 1.2.4474.g4185880
+ pkgrel = 2
+ epoch = 1
+ url = http://www.frogatto.com/
+ arch = any
+ license = custom
+ makedepends = git
+ depends = anura-git
+ source = git+https://github.com/frogatto/frogatto.git
+ source = frogatto-git.sh
+ source = frogatto-git.desktop
+ md5sums = SKIP
+ md5sums = c3faef878e21beccf0e4f7b26b4eb1f6
+ md5sums = 935c3d8662a92b9bc775da36cf1ef059
+
+pkgname = frogatto-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28b1a2167548
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Yaohan Chen <yaohan.chen@gmail.com>
+pkgname=frogatto-git
+pkgver=1.2.4474.g4185880
+# The versioning scheme changed from date-based to git tag based on 2013-05-27
+epoch=1
+pkgrel=2
+pkgdesc="An action-adventure game, starring a certain quixotic frog."
+arch=(any)
+url="http://www.frogatto.com/"
+license=('custom')
+depends=(anura-git)
+makedepends=('git')
+source=(git+https://github.com/frogatto/frogatto.git
+ frogatto-git.sh
+ frogatto-git.desktop)
+md5sums=(SKIP
+ c3faef878e21beccf0e4f7b26b4eb1f6
+ 935c3d8662a92b9bc775da36cf1ef059)
+
+_gitname=frogatto
+
+pkgver() {
+ cd $_gitname
+ if _tag=$(git describe 2>/dev/null)
+ then
+ # Use the tag of the last commit
+ echo $_tag | sed 's|-|.|g'
+ else
+ # The project currently has no tags yet
+ echo 0.0.$(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+ fi
+}
+
+package() {
+ install -DT -m755 frogatto-git.sh $pkgdir/usr/bin/$pkgname
+ install -D -m644 frogatto-git.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+
+ cd $_gitname
+ # the LICENSE file is currently missing in the repository
+ # install -D -m644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+
+ _installdir=$pkgdir/usr/share/anura-git/modules/frogatto
+ install -DT -m644 module.cfg $_installdir/module.cfg
+ install -DT -m644 master-config.cfg $_installdir/master-config.cfg
+ rm -rf music/Unused sounds/unused images/os/mac
+ cp -r data images locale music sounds $_installdir
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/frogatto-git.desktop b/frogatto-git.desktop
new file mode 100644
index 000000000000..93e2888352d7
--- /dev/null
+++ b/frogatto-git.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Frogatto (development build)
+GenericName=Old-school 2D platformer
+Comment=Old-school 2D platformer
+Exec=/usr/bin/frogatto-git
+Terminal=false
+MultipleArgs=false
+Type=Application
+Icon=/usr/share/anura-git/modules/frogatto/images/window-icon.png
+Categories=Game;ArcadeGame
diff --git a/frogatto-git.sh b/frogatto-git.sh
new file mode 100644
index 000000000000..7a0f124bd985
--- /dev/null
+++ b/frogatto-git.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+anura-git --module=frogatto --config-path=~/.frogatto-git $*
+