summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
-rw-r--r--frr_7.3_Archlinux.patch (renamed from frr_7.2_Archlinux.patch)53
3 files changed, 38 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 40c00920463c..229ae44c2270 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = frr
pkgdesc = FRRouting (quagga fork) supports BGP4, OSPFv2, OSPFv3, ISIS, RIP, RIPng, PIM, LDP, BFD, VRRP, NHRP and EIGRP.
- pkgver = 7.2.1
- pkgrel = 2
+ pkgver = 7.3
+ pkgrel = 1
url = https://frrouting.org/
arch = x86_64
license = GPL2
@@ -33,15 +33,15 @@ pkgbase = frr
backup = etc/frr/frr.conf
backup = etc/frr/daemons.conf
backup = etc/frr/vtysh.conf
- source = https://github.com/FRRouting/frr/archive/frr-7.2.1.tar.gz
+ source = https://github.com/FRRouting/frr/archive/frr-7.3.tar.gz
source = frr.sysusers
source = frr.tmpfiles
- source = frr_7.2_Archlinux.patch
+ source = frr_7.3_Archlinux.patch
source = frr-init-functions
- sha256sums = 40fea6ff007453e27761a0372cde51fd8279f89984dff009092eebe2a7b29be3
+ sha256sums = c209ed66a0331221649b8c21dc8c6704ce1696e2017ef4d48f8c2ac6b1fa01b7
sha256sums = 9371cc0522d13621c623b5da77719052bdebdceb7ffdbdc06fc32a2f07118e7e
sha256sums = 6f8dd86ef9c600763faead3052908531e8dc8ef67058e6f7f8da01bf0fe4eb89
- sha256sums = 36ac07e04b54bb2c4228bf4b380c133c134962ff5f39bc84c03972bc93b1261d
+ sha256sums = 71017b61fac82ff69f9ed8fe4a74c8380c2206d209c60a64e16ba31dd5735049
sha256sums = e6e2592a8b0b18f7f173186fb4ebf23e642b3d912179f0bb36251962ca64cd7a
pkgname = frr
diff --git a/PKGBUILD b/PKGBUILD
index 6ab0c2a49c52..853aba4c7abd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Evgeny Cherkashin <eugeneai@irnok.net>
pkgname='frr'
-pkgver='7.2.1'
-pkgrel='2'
+pkgver='7.3'
+pkgrel='1'
pkgdesc='FRRouting (quagga fork) supports BGP4, OSPFv2, OSPFv3, ISIS, RIP, RIPng, PIM, LDP, BFD, VRRP, NHRP and EIGRP.'
arch=('x86_64')
url="https://frrouting.org/"
@@ -22,17 +22,17 @@ backup=("etc/${pkgname}/${pkgname}.conf"
source=("https://github.com/FRRouting/${pkgname}/archive/${pkgname}-${pkgver}.tar.gz"
"${pkgname}.sysusers"
"${pkgname}.tmpfiles"
- "${pkgname}_7.2_Archlinux.patch"
+ "${pkgname}_${pkgver}_Archlinux.patch"
"frr-init-functions")
-sha256sums=('40fea6ff007453e27761a0372cde51fd8279f89984dff009092eebe2a7b29be3'
+sha256sums=('c209ed66a0331221649b8c21dc8c6704ce1696e2017ef4d48f8c2ac6b1fa01b7'
'9371cc0522d13621c623b5da77719052bdebdceb7ffdbdc06fc32a2f07118e7e'
'6f8dd86ef9c600763faead3052908531e8dc8ef67058e6f7f8da01bf0fe4eb89'
- '36ac07e04b54bb2c4228bf4b380c133c134962ff5f39bc84c03972bc93b1261d'
+ '71017b61fac82ff69f9ed8fe4a74c8380c2206d209c60a64e16ba31dd5735049'
'e6e2592a8b0b18f7f173186fb4ebf23e642b3d912179f0bb36251962ca64cd7a')
prepare() {
cd "${srcdir}/${pkgname}-${pkgname}-${pkgver}"
- patch -p1 -i "${srcdir}/${pkgname}_7.2_Archlinux.patch"
+ patch -p1 -i "${srcdir}/${pkgname}_${pkgver}_Archlinux.patch"
autoreconf -fvi
./configure \
diff --git a/frr_7.2_Archlinux.patch b/frr_7.3_Archlinux.patch
index 98bf70b76657..7cb24873c241 100644
--- a/frr_7.2_Archlinux.patch
+++ b/frr_7.3_Archlinux.patch
@@ -1,6 +1,6 @@
-diff -Naupr frr-frr-7.2_orig/ospf6d/ospf6_abr.c frr-frr-7.2/ospf6d/ospf6_abr.c
---- frr-frr-7.2_orig/ospf6d/ospf6_abr.c 2019-10-15 21:44:47.000000000 +0700
-+++ frr-frr-7.2/ospf6d/ospf6_abr.c 2019-10-31 14:08:43.189593701 +0700
+diff -Naupr frr-frr-7.3_orig/ospf6d/ospf6_abr.c frr-frr-7.3/ospf6d/ospf6_abr.c
+--- frr-frr-7.3_orig/ospf6d/ospf6_abr.c 2020-02-14 21:03:09.000000000 +0700
++++ frr-frr-7.3/ospf6d/ospf6_abr.c 2020-02-26 09:05:46.084754077 +0700
@@ -1209,8 +1209,8 @@ void ospf6_abr_examin_summary(struct osp
/* For Inter-Prefix route: Update RIB/FIB,
* For Inter-Router trigger summary update
@@ -12,9 +12,9 @@ diff -Naupr frr-frr-7.2_orig/ospf6d/ospf6_abr.c frr-frr-7.2/ospf6d/ospf6_abr.c
/* Delete new route */
ospf6_route_delete(route);
-diff -Naupr frr-frr-7.2_orig/tools/etc/frr/daemons frr-frr-7.2/tools/etc/frr/daemons
---- frr-frr-7.2_orig/tools/etc/frr/daemons 2019-10-15 21:44:47.000000000 +0700
-+++ frr-frr-7.2/tools/etc/frr/daemons 2019-10-31 14:25:39.747396103 +0700
+diff -Naupr frr-frr-7.3_orig/tools/etc/frr/daemons frr-frr-7.3/tools/etc/frr/daemons
+--- frr-frr-7.3_orig/tools/etc/frr/daemons 2020-02-14 21:03:09.000000000 +0700
++++ frr-frr-7.3/tools/etc/frr/daemons 2020-02-26 15:20:16.080215154 +0700
@@ -30,6 +30,8 @@ pbrd=no
bfdd=no
fabricd=no
@@ -24,7 +24,7 @@ diff -Naupr frr-frr-7.2_orig/tools/etc/frr/daemons frr-frr-7.2/tools/etc/frr/dae
#
# If this option is set the /etc/init.d/frr script automatically loads
-@@ -37,25 +39,24 @@ vrrpd=no
+@@ -37,24 +39,24 @@ vrrpd=no
# Check /etc/pam.d/frr if you intend to use "vtysh"!
#
vtysh_enable=yes
@@ -46,7 +46,6 @@ diff -Naupr frr-frr-7.2_orig/tools/etc/frr/daemons frr-frr-7.2/tools/etc/frr/dae
-bfdd_options=" -A 127.0.0.1"
-fabricd_options="-A 127.0.0.1"
-vrrpd_options=" -A 127.0.0.1"
--
+zebra_options=" -A 127.0.0.1 -s 90000000 -d -f /etc/frr/zebra.conf"
+bgpd_options=" -A 127.0.0.1 -d -f /etc/frr/bgpd.conf"
+ospfd_options=" -A 127.0.0.1 -d -f /etc/frr/ospfd.conf"
@@ -65,10 +64,10 @@ diff -Naupr frr-frr-7.2_orig/tools/etc/frr/daemons frr-frr-7.2/tools/etc/frr/dae
+bfdd_options=" -A 127.0.0.1 -d -f /etc/frr/bfdd.conf"
+fabricd_options="-A 127.0.0.1 -d -f /etc/frr/fabricd.conf"
+vrrpd_options=" -A 127.0.0.1 -d -f /etc/frr/vrrpd.conf"
+
+ # configuration profile
#
- # This is the maximum number of FD's that will be available.
- # Upon startup this is read by the control files and ulimit
-@@ -65,7 +66,8 @@ vrrpd_options=" -A 127.0.0.1"
+@@ -70,7 +72,8 @@ vrrpd_options=" -A 127.0.0.1"
#MAX_FDS=1024
# The list of daemons to watch is automatically generated by the init script.
@@ -78,10 +77,10 @@ diff -Naupr frr-frr-7.2_orig/tools/etc/frr/daemons frr-frr-7.2/tools/etc/frr/dae
# for debugging purposes, you can specify a "wrap" command to start instead
# of starting the daemon directly, e.g. to use valgrind on ospfd:
-diff -Naupr frr-frr-7.2_orig/tools/frrcommon.sh.in frr-frr-7.2/tools/frrcommon.sh.in
---- frr-frr-7.2_orig/tools/frrcommon.sh.in 2019-10-15 21:44:47.000000000 +0700
-+++ frr-frr-7.2/tools/frrcommon.sh.in 2019-10-31 14:09:10.276736253 +0700
-@@ -270,7 +270,7 @@ load_old_config() {
+diff -Naupr frr-frr-7.3_orig/tools/frrcommon.sh.in frr-frr-7.3/tools/frrcommon.sh.in
+--- frr-frr-7.3_orig/tools/frrcommon.sh.in 2020-02-14 21:03:09.000000000 +0700
++++ frr-frr-7.3/tools/frrcommon.sh.in 2020-02-26 09:05:46.084754077 +0700
+@@ -271,7 +271,7 @@ load_old_config() {
[ -s "$oldcfg" ] || return 0
grep -v '^[[:blank:]]*\(#\|$\)' "$oldcfg" > /dev/null || return 0
@@ -90,7 +89,7 @@ diff -Naupr frr-frr-7.2_orig/tools/frrcommon.sh.in frr-frr-7.2/tools/frrcommon.s
# save off settings from daemons for the OR below
for dmn in $DAEMONS; do eval "_new_$dmn=\${$dmn:-no}"; done
-@@ -281,8 +281,8 @@ load_old_config() {
+@@ -282,8 +282,8 @@ load_old_config() {
for dmn in $DAEMONS; do eval "test \$_new_$dmn != no && $dmn=\$_new_$dmn; unset _new_$dmn"; done
}
@@ -101,10 +100,10 @@ diff -Naupr frr-frr-7.2_orig/tools/frrcommon.sh.in frr-frr-7.2/tools/frrcommon.s
exit 1
}
. "$C_PATH/daemons"
-diff -Naupr frr-frr-7.2_orig/tools/frr.in frr-frr-7.2/tools/frr.in
---- frr-frr-7.2_orig/tools/frr.in 2019-10-15 21:44:47.000000000 +0700
-+++ frr-frr-7.2/tools/frr.in 2019-10-31 14:34:03.145967025 +0700
-@@ -26,7 +26,7 @@ FRR_VTY_GROUP="@enable_vty_group@" # frr
+diff -Naupr frr-frr-7.3_orig/tools/frr.in frr-frr-7.3/tools/frr.in
+--- frr-frr-7.3_orig/tools/frr.in 2020-02-14 21:03:09.000000000 +0700
++++ frr-frr-7.3/tools/frr.in 2020-02-26 09:05:46.084754077 +0700
+@@ -27,7 +27,7 @@ FRR_DEFAULT_PROFILE="@DFLT_NAME@" # trad
# See /usr/share/doc/frr/README.Debian.gz for further information.
# Keep zebra first and do not list watchfrr!
DAEMONS="zebra bgpd ripd ripngd ospfd ospf6d isisd babeld pimd ldpd nhrpd eigrpd sharpd pbrd staticd bfdd fabricd vrrpd"
@@ -113,7 +112,7 @@ diff -Naupr frr-frr-7.2_orig/tools/frr.in frr-frr-7.2/tools/frr.in
RELOAD_SCRIPT="$D_PATH/frr-reload.py"
if [ -e /lib/lsb/init-functions ]; then
-@@ -500,10 +500,9 @@ check_status()
+@@ -501,10 +501,9 @@ check_status()
#########################################################
# Config broken but script must exit silently.
@@ -125,18 +124,18 @@ diff -Naupr frr-frr-7.2_orig/tools/frr.in frr-frr-7.2/tools/frr.in
if [ -e "$C_PATH/daemons.conf" ]; then
. "$C_PATH/daemons.conf"
fi
-@@ -511,7 +510,7 @@ fi
- # Read configuration variable file if it is present
- [ -r /etc/default/frr ] && . /etc/default/frr
+@@ -524,7 +523,7 @@ if test -z "$frr_profile"; then
+ fi
+ test -n "$frr_profile" && frr_global_options="$frr_global_options -F $frr_profile"
-MAX_INSTANCES=${MAX_INSTANCES:=5}
+MAX_INSTANCES=${MAX_INSTANCES:=1024}
# Set priority of un-startable daemons to 'no' and substitute 'yes' to '0'
convert_daemon_prios
-diff -Naupr frr-frr-7.2_orig/tools/frr-reload frr-frr-7.2/tools/frr-reload
---- frr-frr-7.2_orig/tools/frr-reload 2019-10-15 21:44:47.000000000 +0700
-+++ frr-frr-7.2/tools/frr-reload 2019-10-31 14:09:10.276736253 +0700
+diff -Naupr frr-frr-7.3_orig/tools/frr-reload frr-frr-7.3/tools/frr-reload
+--- frr-frr-7.3_orig/tools/frr-reload 2020-02-14 21:03:09.000000000 +0700
++++ frr-frr-7.3/tools/frr-reload 2020-02-26 09:05:46.084754077 +0700
@@ -1,7 +1,7 @@
#!/bin/sh