summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 86b342a53715..068ad1c73933 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = fsleyes-props
pkgdesc = The fsleyes-props project is an event programming framework, which includes the ability for automatic CLI generation and, optionally, automatic GUI generation (if wxPython is present). It is used by FSLeyes.
pkgver = 1.6.4
- pkgrel = 1
+ pkgrel = 2
url = https://fsl.fmrib.ox.ac.uk/fsl/fslwiki/FSLeyes
arch = any
license = Apache
@@ -11,7 +11,7 @@ pkgbase = fsleyes-props
makedepends = python-deprecation
makedepends = python-wxpython>=4.0.1-2
makedepends = fslpy>=1.11.1
- makedepends = fsleyes-widgets>=0.6.4
+ makedepends = fsleyes-widgets>=0.6.4-2
depends = python
source = fsleyes-props-1.6.4.tar.gz::https://git.fmrib.ox.ac.uk/fsl/fsleyes/props/repository/archive.tar.gz?ref=1.6.4
sha256sums = 96d8c448d6930213fe023e99bd4c8340dcbe722346615d7653d68a50fb204259
diff --git a/PKGBUILD b/PKGBUILD
index 79711c5bd63f..5227b802a512 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Tobias Bachmann <tobachmann@gmx.de>
pkgname=fsleyes-props
pkgver=1.6.4
-pkgrel=1
+pkgrel=2
pkgdesc="The fsleyes-props project is an event programming framework, which includes the ability for automatic CLI generation and, optionally, automatic GUI generation (if wxPython is present). It is used by FSLeyes."
arch=('any')
url="https://fsl.fmrib.ox.ac.uk/fsl/fslwiki/FSLeyes"
license=('Apache')
groups=()
depends=('python')
-makedepends=('python-six' 'python-numpy' 'python-matplotlib' 'python-deprecation' 'python-wxpython>=4.0.1-2' 'fslpy>=1.11.1' 'fsleyes-widgets>=0.6.4')
+makedepends=('python-six' 'python-numpy' 'python-matplotlib' 'python-deprecation' 'python-wxpython>=4.0.1-2' 'fslpy>=1.11.1' 'fsleyes-widgets>=0.6.4-2')
optdepends=()
provides=()
conflicts=()
@@ -20,5 +20,7 @@ package() {
cd "$srcdir/${pkgname#fsleyes-}-$pkgver-"*
# "Patching for deprecation 2.x support
sed -i 's/deprecation>=1\.\*,<=2\.\*/deprecation>=1\.\*/g' requirements.txt
+ # "Patching" for matplotlib>3 support
+ sed -i 's/matplotlib>=1\.5,<3/matplotlib>=1.5.1/g' requirements.txt
python setup.py install --root="$pkgdir/" --optimize=1
}