summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
-rw-r--r--fslint-2.44_fix-multiselect-regression_r291.patch31
-rw-r--r--fslint-2.44_gtk-init-graceful_r292.patch24
4 files changed, 10 insertions, 86 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 902717e22ed4..fe75bde5ae1c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,16 @@
+# Generated by mksrcinfo v8
+# Fri Feb 3 13:30:48 UTC 2017
pkgbase = fslint
pkgdesc = A utility to find and clean various forms of lint on a filesystem
- pkgver = 2.44
- pkgrel = 2
+ pkgver = 2.46
+ pkgrel = 1
url = http://www.pixelbeat.org/fslint/
arch = any
license = GPL
depends = pygtk
depends = python2
- source = http://www.pixelbeat.org/fslint/fslint-2.44.tar.gz
- source = fslint-2.44_fix-multiselect-regression_r291.patch
- source = fslint-2.44_gtk-init-graceful_r292.patch
- sha256sums = 8491a9cd76725e652ac8fe07288ba1f896d9331e30593c0ff3ab9e82e863f0ae
- sha256sums = f8786f1c564678e01cd2b52674a48e61858661f5337f5332a7635de5f082c239
- sha256sums = 4a87d8bbe6699f0932af2c06d38ba6547bd8905e4db51404b3db4c3e3d36c9a9
+ source = http://www.pixelbeat.org/fslint/fslint-2.46.tar.xz
+ sha256sums = f15daebfecfd2eea0d3b48a0193e25974b71dcf1e4b4a33d5a3dcfb7bb9c90cc
pkgname = fslint
diff --git a/PKGBUILD b/PKGBUILD
index 77d938b05077..ae4f7f51f4ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,20 @@
# Maintainer: Steven Honeyman <stevenhoneyman at gmail com>
# Contributor: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
-# Patches taken from upstream svn to fix specific problems that
-# Arch Linux users were having (see AUR comments) - 2014-06-09
-
pkgname=fslint
-pkgver=2.44
-pkgrel=2
+pkgver=2.46
+pkgrel=1
pkgdesc="A utility to find and clean various forms of lint on a filesystem"
arch=('any')
url="http://www.pixelbeat.org/fslint/"
license=('GPL')
depends=('pygtk' 'python2')
-source=(http://www.pixelbeat.org/$pkgname/$pkgname-$pkgver.tar.gz
- fslint-2.44_fix-multiselect-regression_r291.patch
- fslint-2.44_gtk-init-graceful_r292.patch)
-sha256sums=('8491a9cd76725e652ac8fe07288ba1f896d9331e30593c0ff3ab9e82e863f0ae'
- 'f8786f1c564678e01cd2b52674a48e61858661f5337f5332a7635de5f082c239'
- '4a87d8bbe6699f0932af2c06d38ba6547bd8905e4db51404b3db4c3e3d36c9a9')
+source=(http://www.pixelbeat.org/$pkgname/$pkgname-$pkgver.tar.xz)
+sha256sums=('f15daebfecfd2eea0d3b48a0193e25974b71dcf1e4b4a33d5a3dcfb7bb9c90cc')
prepare() {
cd "${srcdir}"/$pkgname-$pkgver
sed -i -e s_^liblocation=.*_liblocation=\'/usr/share/fslint\'_ fslint-gui
-
- # fixes a regression with multiple select in duplicate file finder
- patch -p2 -i ../fslint-2.44_fix-multiselect-regression_r291.patch
-
- # handle gtk init problem gracefully
- patch -p2 -i ../fslint-2.44_gtk-init-graceful_r292.patch
-
- sed -i 's/env python/&2/' fslint-gui \
- fslint/fstool/dupwaste \
- fslint/supprt/rmlint/fixdup \
- fslint/supprt/rmlint/merge_hardlinks
- sed -i 's/bin.python/&2/' fslint/supprt/md5sum_approx
}
package() {
diff --git a/fslint-2.44_fix-multiselect-regression_r291.patch b/fslint-2.44_fix-multiselect-regression_r291.patch
deleted file mode 100644
index d8cd95c1ebe1..000000000000
--- a/fslint-2.44_fix-multiselect-regression_r291.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- a/fslint-2.44/fslint-gui
-+++ b/fslint-2.44/fslint-gui
-@@ -782,8 +782,8 @@
- if row == clist.rows-1 and not get_selectable(row-1, row_data):
- clist.remove(row)
- row_data.pop(row)
-- elif not (get_selectable(row-1, row_data) or
-- get_selectable(row+1, row_data)):
-+ elif not ((row!=0 and get_selectable(row-1, row_data)) or
-+ (row!=clist.rows-1 and get_selectable(row+1, row_data))):
- clist.remove(row)
- row_data.pop(row)
-
-@@ -1599,7 +1599,7 @@
- if row!=0 or not get_selectable(row, row_data):
- row += 1 #for all except first row in clist_sn
- unselect_row = -1 # avoid rh bug 726252 (mtimes for group = -1?)
-- while get_selectable(row, row_data) and row < clist.rows:
-+ while row < clist.rows and get_selectable(row, row_data):
- mtime = clist.get_row_data(row)
- if comp(mtime,unselect_mtime):
- unselect_mtime = mtime
-@@ -1638,7 +1638,7 @@
- def group_all_selected(clist, row):
- if row!=0 or not get_selectable(row, row_data): #for first sn row
- row += 1
-- while get_selectable(row, row_data) and row < clist.rows:
-+ while row < clist.rows and get_selectable(row, row_data):
- if not row in selected:
- return False
- row += 1
diff --git a/fslint-2.44_gtk-init-graceful_r292.patch b/fslint-2.44_gtk-init-graceful_r292.patch
deleted file mode 100644
index caecdea5d8b6..000000000000
--- a/fslint-2.44_gtk-init-graceful_r292.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- a/fslint-2.44/fslint-gui
-+++ b/fslint-2.44/fslint-gui
-@@ -22,12 +22,19 @@
- which is available at www.gnu.org
- """
-
-+import types, os, sys, pipes, time, stat, tempfile, errno
-+
- import gettext
- import locale
--import gtk
--import gtk.glade
-
--import types, os, sys, pipes, time, stat, tempfile, errno
-+try:
-+ import gtk
-+except RuntimeError:
-+ etype, emsg, etb = sys.exc_info()
-+ sys.stderr.write(str(emsg)+'\n')
-+ sys.exit(1)
-+
-+import gtk.glade
-
- time_commands=False #print sub commands timing on status line