summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO39
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD59
-rw-r--r--commandline.txt7
-rw-r--r--fteqw-gl.desktop9
-rw-r--r--fteqw-mingl.desktop9
-rw-r--r--fteqw-sv.desktop9
-rw-r--r--fteqw-vk.desktop9
-rw-r--r--fteqw.pngbin0 -> 165238 bytes
9 files changed, 145 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..69769f949bbf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,39 @@
+pkgbase = ftequake
+ pkgdesc = FTE QuakeWorld. Engine for Quake 1,2,3 and Hexen 2
+ pkgver = r5026
+ pkgrel = 1
+ url = http://fte.triptohell.info
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = ecasound
+ makedepends = libjpeg-turbo
+ makedepends = libogg
+ makedepends = libpng
+ makedepends = libvorbis
+ makedepends = vulkan-validation-layers
+ makedepends = zlib
+ makedepends = mesa
+ makedepends = subversion
+ depends = libpng
+ depends = sdl2
+ depends = vulkan-validation-layers
+ provides = ftequake
+ conflicts = ftequake-svn
+ source = svn+http://svn.code.sf.net/p/fteqw/code/trunk#revision=r5026
+ source = fteqw-gl.desktop
+ source = fteqw-mingl.desktop
+ source = fteqw-sv.desktop
+ source = fteqw-vk.desktop
+ source = commandline.txt
+ source = fteqw.png
+ md5sums = SKIP
+ md5sums = a52ba6f48f20168d89f5f374f57c4176
+ md5sums = dde36db22cb52b3b805677907c286e11
+ md5sums = b5157c36cc9c0231c6cbac0e566d8784
+ md5sums = c6cc686b4df148f2d77ee315a267faf8
+ md5sums = 8dd76f7027810a6d20fa1db654151e9a
+ md5sums = 0c1246661ff0e3c27ed0f31ae65bb6ea
+
+pkgname = ftequake
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b0903b91d43f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer : Michael DeGuzis <mdeguzis@gmail.com>
+
+pkgname=ftequake
+_svndir=trunk
+pkgver=r5026
+pkgrel=1
+pkgdesc="FTE QuakeWorld. Engine for Quake 1,2,3 and Hexen 2"
+arch=('i686' 'x86_64')
+url="http://fte.triptohell.info"
+license=('GPL')
+makedepends=('ecasound' 'libjpeg-turbo' 'libogg' 'libpng'
+ 'libvorbis' 'vulkan-validation-layers' 'zlib' 'mesa'
+ 'subversion')
+depends=('libpng' 'sdl2' 'vulkan-validation-layers')
+conflicts=('ftequake-svn')
+provides=('ftequake')
+source=("svn+http://svn.code.sf.net/p/fteqw/code/trunk#revision=$pkgver"
+ 'fteqw-gl.desktop'
+ 'fteqw-mingl.desktop'
+ 'fteqw-sv.desktop'
+ 'fteqw-vk.desktop'
+ 'commandline.txt'
+ 'fteqw.png')
+md5sums=('SKIP'
+ 'a52ba6f48f20168d89f5f374f57c4176'
+ 'dde36db22cb52b3b805677907c286e11'
+ 'b5157c36cc9c0231c6cbac0e566d8784'
+ 'c6cc686b4df148f2d77ee315a267faf8'
+ '8dd76f7027810a6d20fa1db654151e9a'
+ '0c1246661ff0e3c27ed0f31ae65bb6ea')
+
+build() {
+
+ cd $_svndir
+
+ make -C engine sv-rel gl-rel mingl-rel qcc-rel vk-rel
+
+}
+
+package() {
+
+ cd $srcdir/$_svndir/engine/release
+
+ install -Dm755 fteqcc "$pkgdir"/usr/bin/fteqcc
+ install -Dm755 fteqw-gl "$pkgdir"/usr/bin/fteqw-gl
+ install -Dm755 fteqw-mingl "$pkgdir"/usr/bin/fteqw-mingl
+ install -Dm755 fteqw-sv "$pkgdir"/usr/bin/fteqw-sv
+ install -Dm755 fteqw-vk "$pkgdir"/usr/bin/fteqw-vk
+
+ install -Dm644 $startdir/fteqw-gl.desktop "$pkgdir"/usr/share/applications/fteqw-gl.desktop
+ install -Dm644 $startdir/fteqw-mingl.desktop "$pkgdir"/usr/share/applications/fteqw-mingl.desktop
+ install -Dm644 $startdir/fteqw-sv.desktop "$pkgdir"/usr/share/applications/fteqw-sv.desktop
+ install -Dm644 $startdir/fteqw-vk.desktop "$pkgdir"/usr/share/applications/fteqw-vk.desktop
+
+ install -Dm644 $startdir/fteqw.png $pkgdir/usr/share/pixmaps/fteqw.png
+ install -Dm644 $startdir/commandline.txt "$pkgdir"/usr/share/games/fteqw
+
+}
+
diff --git a/commandline.txt b/commandline.txt
new file mode 100644
index 000000000000..3da93f3070fc
--- /dev/null
+++ b/commandline.txt
@@ -0,0 +1,7 @@
+gl-* = OpenGL & Dedicated Server
+mingl-* = Minimalistic OpenGL
+d3d-* = Direct3D (only available on Windows machines)
+m-* = Merged (Direct3D, OpenGL & Dedicated Server)
+sv-* = Dedicated Server
+
+note * is rel or dbg or profile. rel = release, dbg = debug, profile = profiling (release with profiling support).
diff --git a/fteqw-gl.desktop b/fteqw-gl.desktop
new file mode 100644
index 000000000000..d06d8d27b480
--- /dev/null
+++ b/fteqw-gl.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=FTE Quake (OpenGL)
+Comment=FTE Quake OpenGL
+Exec=/usr/bin/fteqw-gl
+Icon=/usr/share/pixmaps/fteqw.png
+Terminal=false
+Type=Application
+Categories=Game;
+MimeType=x-scheme-handler/steam;
diff --git a/fteqw-mingl.desktop b/fteqw-mingl.desktop
new file mode 100644
index 000000000000..fd575bfedcd5
--- /dev/null
+++ b/fteqw-mingl.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=FTE Quake (Minimal OpenGL)
+Comment=FTE Quake OpenGL, minimalistic OpenGL
+Exec=/usr/bin/fteqw-mingl
+Icon=/usr/share/pixmaps/fteqw.png
+Terminal=false
+Type=Application
+Categories=Game;
+MimeType=x-scheme-handler/steam;
diff --git a/fteqw-sv.desktop b/fteqw-sv.desktop
new file mode 100644
index 000000000000..e45cff9c416a
--- /dev/null
+++ b/fteqw-sv.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=FTE Quake (Server)
+Comment=FTE Quake OpenGL Dedicated Server
+Exec=/usr/bin/fteqw-sv
+Icon=/usr/share/pixmaps/fteqw.png
+Terminal=false
+Type=Application
+Categories=Game;
+MimeType=x-scheme-handler/steam;
diff --git a/fteqw-vk.desktop b/fteqw-vk.desktop
new file mode 100644
index 000000000000..25d9251d864a
--- /dev/null
+++ b/fteqw-vk.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=FTE Quake (Vulkan)
+Comment=FTE Quake OpenGL using the Vulkan API
+Exec=/usr/bin/fteqw-vk
+Icon=/usr/share/pixmaps/fteqw.png
+Terminal=false
+Type=Application
+Categories=Game;
+MimeType=x-scheme-handler/steam;
diff --git a/fteqw.png b/fteqw.png
new file mode 100644
index 000000000000..6f824c33eb1c
--- /dev/null
+++ b/fteqw.png
Binary files differ