summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
-rw-r--r--ftwin-make.patch5
3 files changed, 31 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c622445300d9..0b1ef205667b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,23 @@
pkgbase = ftwin
- pkgdesc = A tool useful to find duplicate files according to their content on your file system.
- pkgver = 0.8.5
+ pkgdesc = A tool useful to find duplicate files according to their content on your file system
+ pkgver = 0.8.9
pkgrel = 1
url = http://freecode.com/projects/ftwin
arch = i686
arch = x86_64
license = APACHE
+ makedepends = git
+ makedepends = autoconf
+ makedepends = patch
depends = apr-util
depends = check
depends = libpuzzle
optdepends = doxygen: generating docs
optdepends = graphviz: generating graphs
- source = ftp://ftp.freebsd.org/pub/FreeBSD/ports/distfiles/ftwin-0.8.5.tar.bz2
- sha256sums = 03dec36503b3c781f287b4427e99d9d1ccc704f1d9e11eadcd630e4c29dea0ce
+ source = git://github.com/fpesce/ftwin.git
+ source = ftwin-make.patch
+ md5sums = SKIP
+ md5sums = ca766ceb9060a98005273e5473b5cfdd
pkgname = ftwin
diff --git a/PKGBUILD b/PKGBUILD
index b08e8414de18..93e9113eb8a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,37 @@
# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
pkgname=ftwin
-pkgver=0.8.5
+pkgver=0.8.9
pkgrel=1
-pkgdesc="A tool useful to find duplicate files according to their content on your file system."
+pkgdesc="A tool useful to find duplicate files according to their content on your file system"
arch=('i686' 'x86_64')
url="http://freecode.com/projects/ftwin"
license=('APACHE')
depends=('apr-util' 'check' 'libpuzzle')
+makedepends=('git' 'autoconf' 'patch')
optdepends=('doxygen: generating docs'
'graphviz: generating graphs')
-source=(ftp://ftp.freebsd.org/pub/FreeBSD/ports/distfiles/$pkgname-$pkgver.tar.bz2)
-sha256sums=('03dec36503b3c781f287b4427e99d9d1ccc704f1d9e11eadcd630e4c29dea0ce')
+source=(git://github.com/fpesce/ftwin.git
+ ftwin-make.patch)
+md5sums=('SKIP'
+ 'ca766ceb9060a98005273e5473b5cfdd')
+
+prepare() {
+ cd "${srcdir}"/$pkgname
+
+ patch -Np0 -i "${srcdir}"/ftwin-make.patch
+}
build() {
- cd ${srcdir}/$pkgname-$pkgver
+ cd "${srcdir}"/$pkgname
+ autoreconf -isf
./configure --prefix=/usr
make
}
package() {
- cd ${srcdir}/$pkgname-$pkgver
+ cd "${srcdir}"/$pkgname
- make DESTDIR=${pkgdir} install
+ make DESTDIR="${pkgdir}" install
}
diff --git a/ftwin-make.patch b/ftwin-make.patch
new file mode 100644
index 000000000000..82931f62462f
--- /dev/null
+++ b/ftwin-make.patch
@@ -0,0 +1,5 @@
+--- Makefile.am 2013-12-25 03:48:59.000000000 +0100
++++ Makefile.am 2015-01-24 14:09:14.876881244 +0100
+@@ -52 +52 @@
+-ftwin_CFLAGS = @APR_CFLAGS@ @PCRE_CFLAGS@ -Wall -Werror -g -ggdb -I$(top_srcdir)/src -O0
++ftwin_CFLAGS = @APR_CFLAGS@ @PCRE_CFLAGS@ -Wall -I$(top_srcdir)/src -O3 -funroll-loops -fomit-frame-pointer -pipe -ffast-math