summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b576eaf4b462
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Mon Dec 21 22:31:25 UTC 2015
+pkgbase = fu-git
+ pkgdesc = A simple python2 tool for querying commandlinefu.com
+ pkgver = r35.47c0867
+ pkgrel = 1
+ url = https://github.com/samirahmed/fu
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = python2-setuptools
+ depends = python2
+ source = fu::git+https://github.com/samirahmed/fu.git
+ sha256sums = SKIP
+
+pkgname = fu-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c3dd4c8b2477
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Christos Nouskas <nous at archlinux.us>
+
+pkgname=fu-git
+pkgver=r35.47c0867
+pkgrel=1
+pkgdesc="A simple python2 tool for querying commandlinefu.com"
+url="https://github.com/samirahmed/fu"
+arch=(any)
+license=('MIT')
+depends=('python2')
+makedepends=('git' 'python2-setuptools')
+_gitroot="git+https://github.com/samirahmed"
+_gitname="fu"
+source=(${_gitname}::${_gitroot}/${_gitname}.git)
+sha256sums=(SKIP)
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${_gitname}"
+ python2 setup.py -q install --root="${pkgdir}" --optimize=1
+}