summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD7
-rw-r--r--fulcrum.conf106
3 files changed, 114 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a7eb390b400..dfe8389c0355 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fulcrum
pkgdesc = A fast & nimble SPV server for Bitcoin Cash
- pkgver = 1.9.8
+ pkgver = 1.10.0
pkgrel = 1
url = https://codeberg.org/Flowee/fulcrum
install = fulcrum.install
@@ -12,9 +12,9 @@ pkgbase = fulcrum
optdepends = jemalloc: reduce memory fragmentation
provides = fulcrum
backup = etc/fulcrum.conf
- source = https://codeberg.org/Flowee/fulcrum/archive/v1.9.8.tar.gz
+ source = https://codeberg.org/Flowee/fulcrum/archive/v1.10.0.tar.gz
source = fulcrum.conf
- sha256sums = 22acaec5ae0923fd444103ef43e3ecff8fabbc09fc2838ea651a3eeb787d05b9
- sha256sums = 7af8de6df023a2c06575e675de72af71abc1bdc74be6629c08aded63bf55ac1a
+ sha256sums = fa12472dfe9411ace9fdc8cd2dad97ed601e5b866b8011b26585399bc936273b
+ sha256sums = 39c732e08ffa4d5b566b49f1e3a6929c8d0a12590e1616ccad1d6d4d8987e3a6
pkgname = fulcrum
diff --git a/PKGBUILD b/PKGBUILD
index b29ba64ce593..c21531ae2525 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Tom Zander
+# Maintainer: Calvin McAnarney <calvin@mcanarney.org>
pkgname=fulcrum
pkgdesc='A fast & nimble SPV server for Bitcoin Cash'
-pkgver=1.9.8
+pkgver=1.10.0
pkgrel=1
url='https://codeberg.org/Flowee/fulcrum'
arch=('x86_64')
@@ -20,8 +21,8 @@ source=(
"https://codeberg.org/Flowee/fulcrum/archive/v$pkgver.tar.gz"
"fulcrum.conf"
)
-sha256sums=('22acaec5ae0923fd444103ef43e3ecff8fabbc09fc2838ea651a3eeb787d05b9'
- '7af8de6df023a2c06575e675de72af71abc1bdc74be6629c08aded63bf55ac1a'
+sha256sums=('fa12472dfe9411ace9fdc8cd2dad97ed601e5b866b8011b26585399bc936273b'
+ '39c732e08ffa4d5b566b49f1e3a6929c8d0a12590e1616ccad1d6d4d8987e3a6'
)
prepare() {
diff --git a/fulcrum.conf b/fulcrum.conf
index f99b30370c56..11dd0a09da60 100644
--- a/fulcrum.conf
+++ b/fulcrum.conf
@@ -330,6 +330,14 @@ rpcpassword = hunter1
#banner = /path/to/banner.txt
+# Anonymize Client IP addresses and TxIDs in logs - 'anon_logs' - DEFAULT: false
+#
+# If true, client IP addresses and transaction IDs will be hidden from the
+# "normal" log level. The "debug" or "trace" log levels may still contain this
+# information in some cases.
+#
+#anon_logs = false
+
#-------------------------------------------------------------------------------
# PEER DISCOVERY AND PUBLIC SERVER OPTIONS
@@ -619,6 +627,22 @@ rpcpassword = hunter1
#bitcoind-tls = false
+# Daemon RPC Passthrough - 'daemon_passthrough_subnets' - DEFAULT: (None)
+#
+# Specify a comma-delimited list of subnets for which to allow the RPC method
+# "daemon.passthrough". This RPC method is potentially dangerous for public
+# servers and should only be used for private or trusted networks. It allows
+# clients to directly issue RPC commands to the bitcoin daemon.
+#
+# Clients connecting from one of the subnets specified by this paremeter will
+# be allowed to access this RPC method. The default is that no clients are
+# allowed.
+#
+# Examples: 10.10.2.0/24, 128.0.0.0/8, 123.45./16, 99.74.0.0/16
+#
+#daemon_passthrough_subnets =
+
+
# Keep RocksDB Log Files - 'db_keep_log_file_num' - DEFAULT: 5
#
# The maximum number of database log files to keep around on disk, per database.
@@ -980,3 +1004,85 @@ rpcpassword = hunter1
# higher than the number of cores on the system.
#
#worker_threads = 0 # <--- autodetect to number of cores on the system.
+
+
+# PID file - 'pidfile' - DEFAULT: None
+#
+# If specified, Fulcrum will write its process ID to this file on startup (and
+# the file will be auto-deleted on app-shutdown). Enabling a PID file may be
+# useful for admins wishing to integrate Fulcrum with monitoring software.
+#
+#pidfile = /path/to/fulcrum.pid
+
+
+
+#-------------------------------------------------------------------------------
+# Reusable Payment Address (RPA) Options
+#-------------------------------------------------------------------------------
+
+# Enable RPA indexing - `rpa` - DEFAULT: 1 for BCH, 0 for all other coins
+#
+# Whether or not to enable the BCH-specific "RPA" index.
+#
+# See: https://github.com/imaginaryusername/Reusable_specs/blob/master/reusable_addresses.md
+#
+# This index takes ~42M of space currently on mainnet (but may grow to >3GB as
+# the blockchain advances over time). If this index is enabled, the
+# `blockchain.rpa.*` and/or the `blockchain.reusable.*` RPC methods will be
+# available to clients, and the `server.features` map will contain an "rpa"
+# key to indicate that the server supports RPA.
+#
+# If unspecified, then the RPA index and associated RPCs will only be enabled
+# for BCH, and will be disabled for all coins.
+#
+#rpa = 1
+
+
+# RPA starting block height - `rpa_start_height` - DEFAULT: 825000 for mainnet
+# 0 all other nets
+#
+# Limit the RPA index to start at this block height. Blocks before this height
+# will not have their data indexed by the RPA index. The default for mainnet is
+# to save space and cycles since before a certain block height, no RPA wallets
+# were in existence anyway since RPA had not yet been invented.
+#
+#rpa_start_height = 825000
+
+
+# RPA history scan block limit - `rpa_history_blocks` - DEFAULT: 60
+#
+# For the `blockchain.rpa.get_history` and/or `blockchain.reusable.get_history`
+# RPC methods, limit the number of blocks that client can request to scan for RPA
+# transactions in a single RPC call to this number of blocks. In other words,
+# results will be truncated if the client requests a wider height range in their
+# request than this number. The reason for this limit is that clients should be
+# making many frequent fast calls to the server so as to maximize the server's
+# ability to multiplex requests (many small requests is better than a few larger
+# ones when it comes to perceived server responsiveness). Specifying this to be
+# a large value (say, >1000) is a potential DoS vector.
+#
+#rpa_history_blocks = 60
+
+
+# RPA maximum history results limit - `rpa_max_history` - DEFAULT: `max_history`
+#
+# This is similar to the configuration option `max_history` (search for it above),
+# but it can be independently specified for the RPA subsystem to be larger or
+# smaller than the app-level `max_history`. If unspecified, this option will
+# inherit whatever the app-level `max_history` setting is.
+#
+#rpa_max_history = 125000
+
+
+# RPA prefix bits minimum - `rpa_prefix_bits_min` - DEFAULT: 8
+#
+# Affects the minimum "prefix" value that is accepted by the
+# `blockchain.rpa.get_history` RPC method, in terms of number of bits. Specify
+# a value in the range: [4, 16]. This is a low-level configuration variable and
+# the default of 8 should be good for all extant RPA clients. 4 offers a larger
+# anonymity set to clients when they perform queries (as they will get more
+# haystack to their 1 needled they are looking for), but it comes with a
+# performance penalty on the server-side, which is why we set the default
+# minimum to 8 in Fulcrum.
+#
+#rpa_prefix_bits_min = 8