summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD15
2 files changed, 8 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ecadb6d76cd..6d745a0d28c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fulcrum-git
pkgdesc = A fast & nimble SPV server for Bitcoin Cash
- pkgver = 1.1.1.r0.g2bc06f1
+ pkgver = 1.2.9.r22.g22d3d8f
pkgrel = 1
url = https://github.com/cculianu/Fulcrum
arch = any
@@ -8,6 +8,7 @@ pkgbase = fulcrum-git
depends = qt5-base
depends = rocksdb
depends = python
+ optdepends = jemalloc: reduce memory fragmentation (recommended)
provides = fulcrum
conflicts = fulcrum
source = fulcrum-git::git+https://github.com/cculianu/Fulcrum.git
diff --git a/PKGBUILD b/PKGBUILD
index 693e7e7dcfdc..0133be6461dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,20 @@
pkgname=fulcrum-git
_pkgname=${pkgname/-git/}
pkgdesc='A fast & nimble SPV server for Bitcoin Cash'
-pkgver=1.1.1.r0.g2bc06f1
+pkgver=1.2.9.r22.g22d3d8f
pkgrel=1
url='https://github.com/cculianu/Fulcrum'
arch=('any')
license=('GPL3')
-depends=(
- 'qt5-base'
- 'rocksdb'
- 'python'
-)
+depends=('qt5-base'
+ 'rocksdb'
+ 'python')
+optdepends=('jemalloc: reduce memory fragmentation (recommended)')
provides=("$_pkgname")
conflicts=("$_pkgname")
source=("$pkgname::git+https://github.com/cculianu/Fulcrum.git")
sha256sums=('SKIP')
-_qmake_args="CONFIG+=release"
-
pkgver() {
cd "$pkgname"
git describe --long --tags | sed 's/v\(.*\)/\1/;s/\([^-]*-g\)/r\1/;s/-/./g'
@@ -26,7 +23,7 @@ pkgver() {
prepare() {
cd "$pkgname"
- qmake -makefile features= Fulcrum.pro
+ qmake -makefile CONFIG+=recheck CONFIG+=release Fulcrum.pro
}
build() {