summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD46
-rw-r--r--fullprof-bin4
-rw-r--r--fullprof-suite.install9
-rw-r--r--fullprof-suite.sh6
5 files changed, 31 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c4ee0111cea..0ee85655b38e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,19 @@
pkgbase = fullprof-suite
pkgdesc = Crystallographic tools for Rietveld, profile matching & integrated intensity refinements of X-Ray and/or neutron data.
- pkgver = 2017.07
- pkgrel = 2
+ pkgver = 2019.10.21
+ pkgrel = 1
url = https://www.ill.eu/sites/fullprof
- install = fullprof-suite.install
arch = x86_64
groups = science
license = custom
depends = gcc-libs
depends = libpng12
- optdepends = xterm: Needed to launch some programs from GUI
provides = fullprof
conflicts = fullprof
- noextract = FullProf_Suite_July2017_Linux64.tgz
- source = file://FullProf_Suite_July2017_Linux64.tgz
- source = fullprof-bin
- md5sums = 2042ff640d1c47958809ef3a19d6725c
- md5sums = e91280ece6411983c74b3a8071402eb9
+ source = file://FullProf_Suite_October2019_Linux64.tgz
+ source = fullprof-suite.sh
+ md5sums = 75203ccd14a79954c61c6bf9178954cc
+ md5sums = fe1d636103b65f8e6455fa82ff96cc64
pkgname = fullprof-suite
diff --git a/PKGBUILD b/PKGBUILD
index f2b02aa4d6ca..dd46c5fb5831 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,51 +1,43 @@
# Maintainer: Dan McCurry <dan.mc at protonmail dot com>
+_version=October2019
pkgname=fullprof-suite
-pkgver=2017.07
-pkgrel=2
+pkgver=2019.10.21
+pkgrel=1
pkgdesc="Crystallographic tools for Rietveld, profile matching & integrated intensity refinements of X-Ray and/or neutron data."
arch=('x86_64')
url="https://www.ill.eu/sites/fullprof"
license=('custom')
groups=('science')
depends=('gcc-libs' 'libpng12')
-optdepends=('xterm: Needed to launch some programs from GUI')
+# optdepends=('xterm: Needed to launch some programs from GUI')
provides=('fullprof')
conflicts=('fullprof')
-install=${pkgname}.install
+#install=${pkgname}.install
# You will need to download the .tgz file from the webpage directly:
# https://www.ill.eu/sites/fullprof/php/downloads.html
-source=("file://FullProf_Suite_July2017_Linux64.tgz"
- "fullprof-bin")
-noextract=("${source##*/}")
-md5sums=('2042ff640d1c47958809ef3a19d6725c'
- 'e91280ece6411983c74b3a8071402eb9')
+source=("file://FullProf_Suite_${_version}_Linux64.tgz"
+ "fullprof-suite.sh")
+md5sums=('75203ccd14a79954c61c6bf9178954cc'
+ 'fe1d636103b65f8e6455fa82ff96cc64')
PKGEXT=.pkg.tar
prepare() {
- mkdir -p ${srcdir}/${pkgname}
- mkdir -p ${srcdir}/bin
+ mkdir -p "${srcdir}/${pkgname}"
- tar -xzvf ${srcdir}/FullProf_Suite_*.tgz -C ${srcdir}/${pkgname}/
-
- for i in $(find ${srcdir}/${pkgname}/. \
- -maxdepth 1 -executable -type f -printf "%P "); do
- sed -e "s/\(exec.*\)/\1$i \"\$\@\"/" \
- ${srcdir}/fullprof-bin > ${srcdir}/bin/fullprof-$i
- done
+ msg2 "Extracting FullProf Suite..."
+ tar -xzf "${srcdir}/FullProf_Suite_${_version}_Linux64.tgz" -C "${srcdir}/${pkgname}/"
}
package() {
- mkdir -p ${pkgdir}/opt/${pkgname}
- mkdir -p ${pkgdir}/usr/share/licenses/${pkgname}
+ mkdir -p "${pkgdir}/opt/${pkgname}"
+ mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
+ mkdir -p "${pkgdir}/etc/profile.d"
- cp -R ${srcdir}/${pkgname}/. ${pkgdir}/opt/${pkgname}/
- ln -s /opt/${pkgname}/Docs/Readme_Fp_Suite.txt \
- ${pkgdir}/usr/share/licenses/${pkgname}/README
+ cp -R "${srcdir}/${pkgname}/." "${pkgdir}/opt/${pkgname}/"
+ ln -s "/opt/${pkgname}/Docs/Readme_Fp_Suite.txt" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/README"
- cd ${srcdir}/bin
- for i in *; do
- install -Dm755 $i ${pkgdir}/usr/bin/$i
- done
+ install -Dm755 "${srcdir}/${pkgname}.sh" "${pkgdir}/etc/profile.d/${pkgname}.sh"
}
diff --git a/fullprof-bin b/fullprof-bin
deleted file mode 100644
index 441920f2667c..000000000000
--- a/fullprof-bin
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/bin/sh
-export FULLPROF=/opt/fullprof-suite
-export PATH=$FULLPROF:$PATH
-exec /opt/fullprof-suite/
diff --git a/fullprof-suite.install b/fullprof-suite.install
deleted file mode 100644
index 337e2fd72a2f..000000000000
--- a/fullprof-suite.install
+++ /dev/null
@@ -1,9 +0,0 @@
-post_install() {
- echo " Programs can be launched by executing fullprof-[PROGRAM], where"
- echo " [PROGRAM] is substituted by the desired executable (e.g."
- echo " fullprof-tfp, fullprof-wfp2k, fullprof-winplotr-2006, etc.)"
-}
-
-post_upgrade() {
- post_install
-}
diff --git a/fullprof-suite.sh b/fullprof-suite.sh
new file mode 100644
index 000000000000..57ef5852ddd5
--- /dev/null
+++ b/fullprof-suite.sh
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+FULLPROF=/opt/fullprof-suite
+PATH=$FULLPROF:$PATH
+
+export FULLPROF PATH