summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD63
-rw-r--r--fullprof-bin4
-rw-r--r--fullprof-suite.install9
4 files changed, 102 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0d48c299a6ff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = fullprof-suite
+ pkgdesc = Crystallographic tools for Rietveld, profile matching & integrated intensity refinements of X-Ray and/or neutron data.
+ pkgver = 2016.07
+ pkgrel = 1
+ url = https://www.ill.eu/sites/fullprof
+ install = fullprof-suite.install
+ arch = i686
+ arch = x86_64
+ groups = science
+ license = custom
+ depends = gcc-libs
+ depends = openmotif
+ optdepends = xterm: Needed to launch some programs from GUI
+ provides = fullprof
+ conflicts = fullprof
+ noextract = FullProf_Suite_Oct2013_Lin.tgz
+ noextract = FullProf_Suite_July2016_Linux64.tgz
+ source = fullprof-bin
+ md5sums = 0382c4e999d14ce61e9c1ca8571c86da
+ source_i686 = https://www.ill.eu/sites/fullprof/downloads/FullProf_Suite_Oct2013_Lin.tgz
+ md5sums_i686 = db32eb6d3e9e7ef67dacbf42bd3b65d3
+ source_x86_64 = https://www.ill.eu/sites/fullprof/downloads/FullProf_Suite_July2016_Linux64.tgz
+ md5sums_x86_64 = d112d2c9ffac37b07a26fd4c3f300671
+
+pkgname = fullprof-suite
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..68651763e380
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# Maintainer: Dan McCurry <dan.mccurry at linux dot com>
+pkgname=fullprof-suite
+pkgver=2016.07
+pkgrel=1
+pkgdesc="Crystallographic tools for Rietveld, profile matching & integrated intensity refinements of X-Ray and/or neutron data."
+arch=('i686' 'x86_64')
+url="https://www.ill.eu/sites/fullprof"
+license=('custom')
+groups=('science')
+depends=('gcc-libs'
+ 'openmotif')
+optdepends=('xterm: Needed to launch some programs from GUI')
+provides=('fullprof')
+conflicts=('fullprof')
+install=${pkgname}.install
+source_i686=("https://www.ill.eu/sites/fullprof/downloads/FullProf_Suite_Oct2013_Lin.tgz")
+source_x86_64=("https://www.ill.eu/sites/fullprof/downloads/FullProf_Suite_July2016_Linux64.tgz")
+source=("fullprof-bin")
+noextract=("${source_i686[@]##*/}"
+ "${source_x86_64[@]##*/}")
+md5sums=('0382c4e999d14ce61e9c1ca8571c86da')
+md5sums_i686=('db32eb6d3e9e7ef67dacbf42bd3b65d3')
+md5sums_x86_64=('d112d2c9ffac37b07a26fd4c3f300671')
+PKGEXT=.pkg.tar
+
+pkgver() {
+ case $CARCH in
+ i686) echo 2013.10;
+ ;;
+ x86_64) echo 2016.07;
+ ;;
+ *) error "Unsupported architecture.";
+ ;;
+ esac
+}
+
+prepare() {
+ mkdir -p ${srcdir}/${pkgname}
+ mkdir -p ${srcdir}/bin
+
+ tar -xzvf ${srcdir}/FullProf_Suite_*.tgz -C ${srcdir}/${pkgname}/
+
+ for i in $(find ${srcdir}/${pkgname}/. \
+ -maxdepth 1 -executable -type f -printf "%P "); do
+ sed -e "s/\(exec.*\)/\1$i/" \
+ ${srcdir}/fullprof-bin > ${srcdir}/bin/fullprof-$i
+ done
+}
+
+
+package() {
+ mkdir -p ${pkgdir}/opt/${pkgname}
+ mkdir -p ${pkgdir}/usr/share/licenses/${pkgname}
+
+ cp -R ${srcdir}/${pkgname}/. ${pkgdir}/opt/${pkgname}/
+ ln -s /opt/${pkgname}/Docs/Readme_Fp_Suite.txt \
+ ${pkgdir}/usr/share/licenses/${pkgname}/README
+
+ cd ${srcdir}/bin
+ for i in *; do
+ install -Dm755 $i ${pkgdir}/usr/bin/$i
+ done
+}
diff --git a/fullprof-bin b/fullprof-bin
new file mode 100644
index 000000000000..3f10b3602172
--- /dev/null
+++ b/fullprof-bin
@@ -0,0 +1,4 @@
+#!/bin/sh
+export FULLPROF=/opt/fullprof-suite
+export PATH=/opt/fullprof-suite:$PATH
+exec /opt/fullprof-suite/
diff --git a/fullprof-suite.install b/fullprof-suite.install
new file mode 100644
index 000000000000..1146a49a97bb
--- /dev/null
+++ b/fullprof-suite.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo "Programs can be launched by executing fullprof-[PROGRAM], where"
+ echo "[PROGRAM] is substituted by the desired executable (e.g."
+ echo "fullprof-tfp, fullprof-wfp2k, fullprof-winplotr-2006, etc.)"
+}
+
+post_upgrade() {
+ post_install
+}