summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD27
-rw-r--r--apache-funkwhale.conf45
-rw-r--r--funkwhale.install2
4 files changed, 62 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a6ccfc2eac51..881a33daa1ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = funkwhale
pkgdesc = A self-hosted, modern free and open-source music server, heavily inspired by Grooveshark.
- pkgver = 0.18
+ pkgver = 0.19.0
pkgrel = 1
url = https://funkwhale.audio/
install = funkwhale.install
@@ -19,8 +19,9 @@ pkgbase = funkwhale
depends = python-django-allauth
depends = python-psycopg2
depends = python-pytz
- depends = python-redis
depends = python-django-redis
+ depends = python-redis
+ depends = python-kombu
depends = python-celery
depends = python-django-cors-headers
depends = python-musicbrainzngs
@@ -29,17 +30,14 @@ pkgbase = funkwhale
depends = python-pendulum
depends = python-persisting-theory
depends = python-django-versatile-imagefield
- depends = python-django-filter1.1
+ depends = python-django-filter
depends = python-django-rest-auth
- depends = python-beautifulsoup4
- depends = python-markdown
depends = python-mutagen
depends = python-django-taggit
depends = python-pymemoize
depends = python-django-dynamic-preferences
depends = python-raven
depends = python-magic-git
- depends = python-ffmpeg
depends = python-django-channels
depends = python-django-channels-redis
depends = python-daphne
@@ -50,27 +48,34 @@ pkgbase = funkwhale
depends = python-django-auth-ldap
depends = python-service-identity
depends = python-pydub
+ depends = python-pyld>=1.0.4
+ depends = python-aiohttp
+ depends = python-autobahn
+ depends = python-django-oauth-toolkit
+ depends = python-django-storages
+ depends = python-boto3
+ depends = python-unicode-slugify-git
optdepends = apache: to use the Apache web server
optdepends = certbot-apache: for the server to be accessible from outside
optdepends = nginx: to use nginx web server
- source = funkwhale-0.18-api.zip::https://code.eliotberriot.com/funkwhale/funkwhale/builds/artifacts/0.18/download?job=build_api
- source = funkwhale-0.18-front.zip::https://code.eliotberriot.com/funkwhale/funkwhale/builds/artifacts/0.18/download?job=build_front
- source = https://code.eliotberriot.com/funkwhale/funkwhale/raw/0.18/deploy/funkwhale_proxy.conf
- source = https://code.eliotberriot.com/funkwhale/funkwhale/raw/0.18/deploy/nginx.template
+ source = funkwhale-0.19.0-api.zip::https://dev.funkwhale.audio/funkwhale/funkwhale/-/jobs/artifacts/0.19.0/download?job=build_api
+ source = funkwhale-0.19.0-front.zip::https://dev.funkwhale.audio/funkwhale/funkwhale/-/jobs/artifacts/0.19.0/download?job=build_front
+ source = https://dev.funkwhale.audio/funkwhale/funkwhale/raw/0.19.0/deploy/funkwhale_proxy.conf
+ source = https://dev.funkwhale.audio/funkwhale/funkwhale/raw/0.19.0/deploy/nginx.template
source = funkwhale-beat.service
source = funkwhale-worker.service
source = funkwhale-server.service
source = apache-funkwhale.conf
source = env-template
source = funkwhale.service
- sha256sums = bd39230b27e22d1a41cd058979f67cc1727b5ea845ce32b29e8de99bf6d364f3
- sha256sums = 20faddbf6a74722826eb889df4ebd4fc18810ff80d3741608b1d86d17e4f408a
+ sha256sums = 8838f83c1c658a758ef283d22f682820b4866f33d83d7832eb52fa04b4f729c8
+ sha256sums = 2a664eb81f46c1f7c9d52d472a2a9958356eb409fed36bb2acba7bde87c7d7c6
sha256sums = 2906a075b41dcd2375c601482cb5a00e42cb87c613012b176c570d77918afbf2
sha256sums = ee571b8a30b968849fcf5c7b2588f298a3046609fe9792dd0b59024899dfea3a
sha256sums = a964a7802252d20a3319e2131c27ec307ad4f454921c2db31971c080150d7c9b
sha256sums = 0e6d7c96b7c1ec63794214decb1f2e7dd112a22b02e55555cf98c2a573014af6
sha256sums = 4a28ddf6a6ba8ec28c10a164f82e3d5e5904d6dfe68ae8852428a589cee210c5
- sha256sums = dcc7a76ff136db29a830f9228a88b2ab64639d44ef2d8db363315fe5828efec9
+ sha256sums = ee895ecaf5faaa794f161e9df038177497cb5c49510acd3aef088f75eb8b02f1
sha256sums = c2ee8160e2f4f87a2d4fe46136ffb8ea14422dc599db3eca4341e48db26d72ad
sha256sums = 01104122e3df765735b1062aa15e7a73c7949f2d9b7332c0e02e02db66345349
diff --git a/PKGBUILD b/PKGBUILD
index c05631b85b96..333f658ced64 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: getzze <getzze at gmail dot com>
pkgname=funkwhale
-pkgver=0.18
+pkgver=0.19.0
pkgrel=1
pkgdesc="A self-hosted, modern free and open-source music server, heavily inspired by Grooveshark."
arch=(any)
@@ -19,8 +19,9 @@ depends=('ffmpeg' 'libjpeg' 'postgresql' 'python'
'python-django-allauth'
'python-psycopg2'
'python-pytz'
- 'python-redis'
'python-django-redis'
+ 'python-redis'
+ 'python-kombu'
'python-celery'
'python-django-cors-headers'
'python-musicbrainzngs'
@@ -29,17 +30,14 @@ depends=('ffmpeg' 'libjpeg' 'postgresql' 'python'
'python-pendulum'
'python-persisting-theory'
'python-django-versatile-imagefield'
- 'python-django-filter1.1'
+ 'python-django-filter'
'python-django-rest-auth'
- 'python-beautifulsoup4'
- 'python-markdown'
'python-mutagen'
'python-django-taggit'
'python-pymemoize'
'python-django-dynamic-preferences'
'python-raven'
'python-magic-git'
- 'python-ffmpeg'
'python-django-channels'
'python-django-channels-redis'
'python-daphne'
@@ -50,10 +48,17 @@ depends=('ffmpeg' 'libjpeg' 'postgresql' 'python'
'python-django-auth-ldap'
'python-service-identity'
'python-pydub'
+ 'python-pyld>=1.0.4'
+ 'python-aiohttp'
+ 'python-autobahn'
+ 'python-django-oauth-toolkit'
+ 'python-django-storages'
+ 'python-boto3'
+ 'python-unicode-slugify-git'
)
makedepends=(git)
-_source_api="https://code.eliotberriot.com/funkwhale/funkwhale/builds/artifacts/${pkgver}/download?job="
-_source_env="https://code.eliotberriot.com/funkwhale/funkwhale/raw/${pkgver}/deploy/"
+_source_api="https://dev.funkwhale.audio/funkwhale/funkwhale/-/jobs/artifacts/${pkgver}/download?job="
+_source_env="https://dev.funkwhale.audio/funkwhale/funkwhale/raw/${pkgver}/deploy/"
source=("${pkgname}-${pkgver}-api.zip::${_source_api}build_api"
"${pkgname}-${pkgver}-front.zip::${_source_api}build_front"
"${_source_env}funkwhale_proxy.conf"
@@ -65,14 +70,14 @@ source=("${pkgname}-${pkgver}-api.zip::${_source_api}build_api"
"env-template"
"funkwhale.service"
)
-sha256sums=('bd39230b27e22d1a41cd058979f67cc1727b5ea845ce32b29e8de99bf6d364f3'
- '20faddbf6a74722826eb889df4ebd4fc18810ff80d3741608b1d86d17e4f408a'
+sha256sums=('8838f83c1c658a758ef283d22f682820b4866f33d83d7832eb52fa04b4f729c8'
+ '2a664eb81f46c1f7c9d52d472a2a9958356eb409fed36bb2acba7bde87c7d7c6'
'2906a075b41dcd2375c601482cb5a00e42cb87c613012b176c570d77918afbf2'
'ee571b8a30b968849fcf5c7b2588f298a3046609fe9792dd0b59024899dfea3a'
'a964a7802252d20a3319e2131c27ec307ad4f454921c2db31971c080150d7c9b'
'0e6d7c96b7c1ec63794214decb1f2e7dd112a22b02e55555cf98c2a573014af6'
'4a28ddf6a6ba8ec28c10a164f82e3d5e5904d6dfe68ae8852428a589cee210c5'
- 'dcc7a76ff136db29a830f9228a88b2ab64639d44ef2d8db363315fe5828efec9'
+ 'ee895ecaf5faaa794f161e9df038177497cb5c49510acd3aef088f75eb8b02f1'
'c2ee8160e2f4f87a2d4fe46136ffb8ea14422dc599db3eca4341e48db26d72ad'
'01104122e3df765735b1062aa15e7a73c7949f2d9b7332c0e02e02db66345349')
install=${pkgname}.install
diff --git a/apache-funkwhale.conf b/apache-funkwhale.conf
index a0af46d970f2..9c98ffd063ec 100644
--- a/apache-funkwhale.conf
+++ b/apache-funkwhale.conf
@@ -6,7 +6,8 @@ Define funkwhale-sn funkwhale.local
Define funkwhale-api http://localhost:5000
Define funkwhale-api-ws ws://localhost:5000
Define FUNKWHALE_FRONTEND_PATH /usr/share/webapps/funkwhale/front/dist
-Define MUSIC_DIRECTORY_PATH /srv/funkwhale/data/music
+Define FUNKWHALE_DATA_PATH /srv/funkwhale/data
+Define MUSIC_DIRECTORY_PATH ${FUNKWHALE_DATA_PATH}/music
<IfModule mod_alias.c>
Alias /funkwhale ${FUNKWHALE_FRONTEND_PATH}
@@ -35,8 +36,8 @@ Define MUSIC_DIRECTORY_PATH /srv/funkwhale/data/music
ServerName ${funkwhale-sn}
# Path to ErrorLog and access log
- ErrorLog /var/log/httpd/funkwhale/error.log
- CustomLog /var/log/httpd/funkwhale/access.log combined
+ ErrorLog ${APACHE_LOG_DIR}/funkwhale/error.log
+ CustomLog ${APACHE_LOG_DIR}/funkwhale/access.log combined
# TLS
# Feel free to use your own configuration for SSL here or simply remove the
@@ -55,10 +56,6 @@ Define MUSIC_DIRECTORY_PATH /srv/funkwhale/data/music
# Tell the api that the client is using https
RequestHeader set X-Forwarded-Proto "https"
- DocumentRoot ${FUNKWHALE_FRONTEND_PATH}
-
- FallbackResource /index.html
-
# Configure Proxy settings
# ProxyPreserveHost pass the original Host header to the backend server
ProxyVia On
@@ -77,15 +74,12 @@ Define MUSIC_DIRECTORY_PATH /srv/funkwhale/data/music
Allow from all
</Proxy>
- # Activating WebSockets
- ProxyPass "/api/v1/activity" ${funkwhale-api-ws}/api/v1/activity
-
- <Location "/api">
+ <Location "/">
# similar to nginx 'client_max_body_size 100M;'
LimitRequestBody 104857600
- ProxyPass ${funkwhale-api}/api
- ProxyPassReverse ${funkwhale-api}/api
+ ProxyPass ${funkwhale-api}/
+ ProxyPassReverse ${funkwhale-api}/
</Location>
<Location "/federation">
ProxyPass ${funkwhale-api}/federation
@@ -103,13 +97,28 @@ Define MUSIC_DIRECTORY_PATH /srv/funkwhale/data/music
ProxyPassReverse ${funkwhale-api}/.well-known/
</Location>
- Alias /media /srv/funkwhale/data/media
+ <Location "/front">
+ ProxyPass "!"
+ </Location>
Alias /front ${FUNKWHALE_FRONTEND_PATH}
- Alias /staticfiles /srv/funkwhale/data/static
+ <Location "/media">
+ ProxyPass "!"
+ </Location>
+ Alias /media ${FUNKWHALE_DATA_PATH}/media
+
+ <Location "/staticfiles">
+ ProxyPass "!"
+ </Location>
+ Alias /staticfiles ${FUNKWHALE_DATA_PATH}/static
+
+ # Activating WebSockets
+ <Location "/api/v1/activity">
+ ProxyPass ${funkwhale-api-ws}/api/v1/activity
+ </Location>
# Setting appropriate access levels to serve frontend
- <Directory "/srv/funkwhale/data/static">
+ <Directory ${FUNKWHALE_DATA_PATH}/static>
Options FollowSymLinks
AllowOverride None
Require all granted
@@ -121,7 +130,7 @@ Define MUSIC_DIRECTORY_PATH /srv/funkwhale/data/music
Require all granted
</Directory>
- <Directory /srv/funkwhale/data/media>
+ <Directory ${FUNKWHALE_DATA_PATH}/media>
Options FollowSymLinks
AllowOverride None
Require all granted
@@ -134,7 +143,7 @@ Define MUSIC_DIRECTORY_PATH /srv/funkwhale/data/music
LoadModule xsendfile_module modules/mod_xsendfile.so
<IfModule mod_xsendfile.c>
XSendFile On
- XSendFilePath /srv/funkwhale/data/media
+ XSendFilePath ${FUNKWHALE_DATA_PATH}/media
XSendFilePath ${MUSIC_DIRECTORY_PATH}
SetEnv MOD_X_SENDFILE_ENABLED 1
</IfModule>
diff --git a/funkwhale.install b/funkwhale.install
index 09e22f94898f..7a5d94c62d57 100644
--- a/funkwhale.install
+++ b/funkwhale.install
@@ -5,6 +5,6 @@ post_install() {
post_upgrade() {
echo "Follow instructions on the upstream page or on the Arch Wiki for updating"
- echo "If updating from v0.17, the default ip has been changed to 127.0.0.1 and the env file has been moved to /srv/funkwhale/config/env"
+ echo "If updating from v0.18, the apache and nginx configuration files have been changed, make sure to update them from the templates."
}