summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3803e600ba78..11d5314d0112 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = fuse3-p7zip-git
pkgdesc = fuse3 file system that uses the p7zip library to mount archives
- pkgver = 1.2.0
- pkgrel = 2
+ pkgver = 1.2.1
+ pkgrel = 1
url = https://github.com/andrew-grechkin/fuse3-p7zip
arch = x86_64
license = GPL
@@ -10,7 +10,7 @@ pkgbase = fuse3-p7zip-git
makedepends = go-md2man
depends = fuse3
depends = p7zip
- source = git+https://github.com/andrew-grechkin/fuse3-p7zip#commit=1c7b2b4bac09f1c55add310874a624194fda2d58
+ source = git+https://github.com/andrew-grechkin/fuse3-p7zip#commit=c7893da7fde1e610b09191586ee3ebbc2a4ff36b
sha256sums = SKIP
pkgname = fuse3-p7zip-git
diff --git a/PKGBUILD b/PKGBUILD
index 5c48cb1cec32..5906315483d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,29 @@
# Maintainer: Andrew Grechkin <andrew.grechkin@gmail.com>
_name=fuse3-p7zip
pkgname="$_name-git"
-pkgver=1.2.0
-pkgrel=2
+pkgver=1.2.1
+pkgrel=1
pkgdesc="fuse3 file system that uses the p7zip library to mount archives"
arch=('x86_64')
url="https://github.com/andrew-grechkin/fuse3-p7zip"
license=('GPL')
depends=('fuse3' 'p7zip')
makedepends=('cmake' 'git' 'go-md2man')
-source=("git+https://github.com/andrew-grechkin/fuse3-p7zip#commit=1c7b2b4bac09f1c55add310874a624194fda2d58")
+source=("git+https://github.com/andrew-grechkin/fuse3-p7zip#commit=c7893da7fde1e610b09191586ee3ebbc2a4ff36b")
sha256sums=('SKIP')
prepare() {
- cd "$_name" || exit
+ cd "$_name"
git submodule update --init
}
pkgver() {
- cd "$_name" || exit
+ cd "$_name"
git describe --tags | sed 's/-/+/g'
}
build() {
- cd "$_name" || exit
+ cd "$_name"
cmake \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
@@ -33,7 +33,7 @@ build() {
}
package() {
- cd "$_name" || exit
+ cd "$_name"
make DESTDIR="$pkgdir" install -C "build-release"
install -Dm644 "${_name}.1" "$pkgdir/usr/share/man/man1/${_name}.1"
}