summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD46
-rw-r--r--fusion-icon-git.install26
4 files changed, 101 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..395541101172
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by mksrcinfo v8
+# Sat Jun 18 19:28:45 UTC 2016
+pkgbase = fusion-icon-git
+ pkgdesc = Simple tray icon for Compiz 0.8
+ pkgver = 0.2.2.r10.gb6fb51a
+ pkgrel = 1
+ epoch = 1
+ url = http://www.compiz.org/
+ install = fusion-icon-git.install
+ arch = any
+ license = GPL
+ depends = compizconfig-python
+ depends = hicolor-icon-theme
+ depends = xorg-utils
+ depends = mesa-demos
+ optdepends = python-pyqt5: For the Qt Interface
+ optdepends = python-gobject: For the GTK+ Interface
+ optdepends = libappindicator-gtk3: For the GTK+ Interface
+ provides = fusion-icon
+ conflicts = fusion-icon0.9
+ conflicts = fusion-icon
+ source = git+https://github.com/compiz-reloaded/fusion-icon
+ sha256sums = SKIP
+
+pkgname = fusion-icon-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a5401c5d685d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..275b8795ef65
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Sapphira Armageddos <shadowkyogre.public@gmail.com>
+# Contributor: Charles Bos <charlesbos1 AT gmail>
+# Contributor: Pantelis Panayiotou <p.panayiotou@gmail.com>
+# Contributor: Ronald van Haren <ronald.archlinux.org>
+# Contributor: nesl247 <nesl247@gmail.com>
+# Contributor: JJDaNiMoTh <jjdanimoth@gmail.com>
+
+_upstream=fusion-icon
+
+pkgname=fusion-icon-git
+epoch=1
+pkgver=0.2.2.r10.gb6fb51a
+pkgrel=1
+pkgdesc="Simple tray icon for Compiz 0.8"
+arch=('any')
+url="http://www.compiz.org/"
+license=('GPL')
+conflicts=('fusion-icon0.9' 'fusion-icon')
+provides=('fusion-icon')
+depends=('compizconfig-python' 'hicolor-icon-theme' 'xorg-utils' 'mesa-demos')
+
+# Note to anyone who builds this: Make sure you install the appropriate
+# dependencies for the user interfaces you want to use! Otherwise, it'll appear
+# like it's not working!
+optdepends=(
+ 'python-pyqt5: For the Qt Interface'
+ 'python-gobject: For the GTK+ Interface'
+ 'libappindicator-gtk3: For the GTK+ Interface'
+)
+
+install="$pkgname.install"
+source=("git+https://github.com/compiz-reloaded/${_upstream}")
+
+pkgver() {
+ cd "${srcdir}/${_upstream}"
+ git describe --long --tags|sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "${srcdir}/${_upstream}"
+ # Workaround until upstream autofills out main.py for each interface
+ make PREFIX=/usr
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}
+
+sha256sums=('SKIP')
diff --git a/fusion-icon-git.install b/fusion-icon-git.install
new file mode 100644
index 000000000000..fe5baf3250da
--- /dev/null
+++ b/fusion-icon-git.install
@@ -0,0 +1,26 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ cat <<EOF
+Before you run this, make sure to install the listed optional dependencies
+depending on the interface you want to use. After you've installed the
+appropriate dependencies for the interfaces you want to use, take note of the
+following below.
+
+If you want to use the Qt Interface, use:
+ fusion-icon -i qt
+
+If you want to use the GTK+ Interface, use:
+ fusion-icon -i gtk
+
+Otherwise, fusion-icon will attempt to use the first interface it can find,
+with GTK+ taking higher priority.
+EOF
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}