summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--CHANGELOG.md73
-rw-r--r--PKGBUILD25
3 files changed, 123 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2ced02071e2c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = fuzzel
+ pkgdesc = Application launcher for wlroots based Wayland compositors
+ pkgver = 1.5.1
+ pkgrel = 1
+ url = https://codeberg.org/dnkl/fuzzel
+ changelog = CHANGELOG.md
+ arch = x86_64
+ arch = aarch64
+ license = mit
+ makedepends = meson
+ makedepends = ninja
+ makedepends = scdoc
+ makedepends = tllist>=1.0.1
+ depends = libxkbcommon
+ depends = wayland
+ depends = pixman
+ depends = cairo
+ depends = librsvg
+ depends = libpng
+ depends = fcft>=2.0.0
+ source = https://codeberg.org/dnkl/fuzzel/archive/1.5.1.tar.gz
+ sha256sums = 8a7394a32664638c91e865d63cf5d5a34d8caf4594854ed4867afae1a6f38eb7
+
+pkgname = fuzzel
+
diff --git a/CHANGELOG.md b/CHANGELOG.md
new file mode 100644
index 000000000000..fc0cf366df95
--- /dev/null
+++ b/CHANGELOG.md
@@ -0,0 +1,73 @@
+# Changelog
+
+* [1.5.1](#1-5-1)
+* [1.5.0](#1-5-0)
+* [1.4.2](#1-4-2)
+* [1.4.1](#1-4-1)
+
+
+## 1.5.1
+
+### Fixed
+
+* Regression: border not being rendered when `--border-radius=0`, or
+ if fuzzel was built without cairo
+ (https://codeberg.org/dnkl/fuzzel/issues/15).
+
+
+## 1.5.0
+
+### Added
+
+* meson option `-Denable-svg=[auto|enabled|disabled]`. When disabled,
+ _librsvg_ is no longer a dependency and SVG icons are
+ disabled. Default: `auto`.
+* meson option `-Denable-png=[auto|enabled|disabled]`. When disabled,
+ _libpng_ is no longer a dependency and PNG icons are
+ disabled. Default: `auto`.
+* meson option `-Denable-cairo=[auto|enabled|disabled]`. When
+ disabled, fuzzel will not be able to draw rounded corners, nor
+ support SVGs (regardless of what `-Denable-svg` is set to)
+ (https://codeberg.org/dnkl/fuzzel/issues/10).
+* `-I,--no-icons` command line option; disables all icons
+ (https://codeberg.org/dnkl/fuzzel/issues/12)
+* FreeBSD port.
+* `-x,--horizontal-pad` and `-y,--vertical-pad` command line options
+ (https://codeberg.org/dnkl/fuzzel/issues/12).
+* `--line-height` and `-letter-spacing` command line options
+ (https://codeberg.org/dnkl/fuzzel/issues/12).
+
+
+### Changed
+
+* PNGs are now loaded and rendered with _libpng_ instead of _cairo_.
+
+
+### Fixed
+
+* Wrong colors when not fully opaque.
+* Rendering of SVGs containing multiple icons.
+* Font being incorrectly scaled on rotated monitors.
+* PPI being calculated incorrectly.
+* Crash on keyboard input when repeat rate was zero (i.e. no repeat).
+
+
+### Contributors
+
+* [magenbluten](https://codeberg.org/magenbluten)
+* jbeich
+
+
+## 1.4.2
+
+### Fixed
+
+* Subpixel antialiasing was not applied correctly on opaque
+ backgrounds.
+
+
+## 1.4.1
+
+### Fixed
+
+* Incorrect extension for man pages.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..21622613a859
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Daniel Eklöf <daniel at ekloef dot se>
+pkgname=fuzzel
+pkgver=1.5.1
+pkgrel=1
+pkgdesc="Application launcher for wlroots based Wayland compositors"
+arch=('x86_64' 'aarch64')
+url=https://codeberg.org/dnkl/fuzzel
+license=(mit)
+makedepends=('meson' 'ninja' 'scdoc' 'tllist>=1.0.1')
+depends=('libxkbcommon' 'wayland' 'pixman' 'cairo' 'librsvg' 'libpng' 'fcft>=2.0.0')
+changelog=CHANGELOG.md
+source=(https://codeberg.org/dnkl/${pkgname}/archive/${pkgver}.tar.gz)
+sha256sums=('8a7394a32664638c91e865d63cf5d5a34d8caf4594854ed4867afae1a6f38eb7')
+
+build() {
+ cd ${pkgname}
+
+ meson --prefix=/usr --buildtype=release . build
+ ninja -C build
+}
+
+package() {
+ cd ${pkgname}
+ DESTDIR="${pkgdir}/" ninja -C build install
+}