summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fa368fe4fc47..d2d3fd10fc34 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Jan 23 23:04:33 UTC 2017
+# Thu Jan 26 01:59:32 UTC 2017
pkgbase = g810-led-git
pkgdesc = Linux led controller for Logitech G410, G610, G810 and G910 Keyboards
pkgver = 0.0.1
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/MatMoul/g810-led
install = g810-led-git.install
arch = i686
@@ -13,7 +13,7 @@ pkgbase = g810-led-git
makedepends = gcc
makedepends = make
depends = hidapi
- optdepends = libusb: slower, old implementation, use only if you have problem with hidapi
+ optdepends = libusb: old implementation, use only if you have problem with hidapi
provides = g410-led=0.0.1
provides = g610-led=0.0.1
provides = g810-led=0.0.1
diff --git a/PKGBUILD b/PKGBUILD
index 66f4b17e96f9..215021acf229 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@ pkgname=g810-led-git
_appname=g810-led
_gitname=g810-led
pkgver=0.0.1
-pkgrel=3
+pkgrel=4
pkgdesc="Linux led controller for Logitech G410, G610, G810 and G910 Keyboards"
arch=('i686' 'x86_64')
url="https://github.com/MatMoul/g810-led"
license=('GPL3')
depends=('hidapi')
makedepends=('git' 'gcc' 'make')
-optdepends=('libusb: slower, old implementation, use only if you have problem with hidapi')
+optdepends=('libusb: old implementation, use only if you have problem with hidapi')
conflicts=('g810-led')
install=${pkgname}.install
provides=("g410-led=${pkgver}" "g610-led=${pkgver}" "g810-led=${pkgver}" "g910-led=${pkgver}")
@@ -33,6 +33,8 @@ build() {
package() {
cd ${_gitname}
make DESTDIR="${pkgdir}" setup
+ mkdir -p ${pkgdir}/usr/share/licenses/${pkgname}
+ cp LICENSE ${pkgdir}/usr/share/licenses/${pkgname}
cp ${pkgdir}/etc/${_appname}/samples/group_keys ${pkgdir}/etc/${_appname}/profile
cp ${pkgdir}/etc/${_appname}/samples/all_off ${pkgdir}/etc/${_appname}/reboot
chmod -R 755 ${pkgdir}/etc
@@ -40,4 +42,6 @@ package() {
chmod -R 644 ${pkgdir}/etc/${_appname}/*
chmod 644 ${pkgdir}/etc/udev/rules.d/${_appname}.rules
chmod 644 ${pkgdir}/usr/lib/systemd/system/*
+ chmod 755 ${pkgdir}/usr/share/licenses/${pkgname}
+ chmod 644 ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
}