summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--CHANGELOG.md94
-rw-r--r--PKGBUILD6
3 files changed, 91 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f24d1eddff9..a91964e98b49 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gaiasky
pkgdesc = Interactive 3D Universe software focused on ESA's Gaia mission
- pkgver = 3.0.1.2318179ff
+ pkgver = 3.0.2.9bd17f001
pkgrel = 1
epoch = 2
url = https://zah.uni-heidelberg.de/gaia/outreach/gaiasky
@@ -10,9 +10,9 @@ pkgbase = gaiasky
license = MPL
depends = jre11-openjdk
depends = xorg-xrandr
- source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/3.0.1.2318179ff/gaiasky-3.0.1.2318179ff.tar.gz
- md5sums = 13d30f0e1dc71f3652623a59e7325a2d
- sha256sums = 3f2e70eb8c416092897150a40e2d85190e30d5ae22d2c752d18418c561d13f00
+ source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/3.0.2.9bd17f001/gaiasky-3.0.2.9bd17f001.tar.gz
+ md5sums = 325bb8d20b624425d4adae8cd6f39ab7
+ sha256sums = 4907dcb0c55dcfb257b60b972350f7b64a11d8712a796702e8be70468d4b69c2
pkgname = gaiasky
diff --git a/CHANGELOG.md b/CHANGELOG.md
index f6a03c3361cd..6c30eb604f8b 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,7 +1,81 @@
-<a name="unreleased"></a>
-## [Unreleased](https://gitlab.com/langurmonkey/gaiasky/tree/master)
-[Full changelog](https://gitlab.com/langurmonkey/gaiasky/compare/3.0.1...HEAD)
+<a name="3.0.2"></a>
+## [3.0.2](https://gitlab.com/langurmonkey/gaiasky/tree/3.0.1) (2021-01-21)
+[Full changelog](https://gitlab.com/langurmonkey/gaiasky/compare/3.0.1...3.0.2)
+### Bug Fixes
+- stuttering updating counts top-down in large octrees, now the counts are updated locally, bottom-up, when octants are loaded/unloaded
+- RAM units in crash report, add indentation
+- default proper motion factor and length values
+- 'App not responding' message on win10 - fix by upgrading to gdx-controllers 2.0.0, plus some other goodies
+- remove useless network checker thread, fix thumbnail URL crash on win10
+- minimizing screen crashes Gaia Sky on Win10. Fixes [#333](https://gitlab.com/langurmonkey/gaiasky/issues/333), [#345](https://gitlab.com/langurmonkey/gaiasky/issues/345) [#333](https://gitlab.com/langurmonkey/gaiasky/issues/333)
+- VR init failure actually prompts right error message
+- properties files' encodings set to UTF-8. Fixes [#344](https://gitlab.com/langurmonkey/gaiasky/issues/344) [#344](https://gitlab.com/langurmonkey/gaiasky/issues/344)
+- VR mode now accepts any window resize, backbuffer size used for everything internally
+- BREAKING CHANGE API landOnObjectLocation() -> landAtObjectLocation()
+- octreegen additional split accepts now coma and spaces
+- use different sprite batch for VR UI with backbuffer size
+- pan scaled with fov factor
+- red-night theme disabled styles
+- proper 'disabled' textures for buttons
+- labels occlude objects behind, buffer writes disabled.
+- download speed moving cancel button in dataset manager
+- safemode flag used correctly, fix raymarching not being setup in safe mode
+
+### Build System
+- auto-update offered through install4j, backup solution in-app still available when not launched using install4j
+- remove sdl2gdx in favor of gdx-controllers:2.0.0
+- exclude old `gdx-controllers` library
+- add --parallelism parameter to
+- fix script so that geodistances file is additional data instead of special argument
+- fix helper script args
+- update release instructions with flatpak, fix build script
+
+### Code Refactoring
+- interface particle record to allow for multiple implementations
+- binary providers are versioned, fix binary version 0/1 loading
+- increase number of maps for octree gen
+- modify default bloom settings (default intensity, passes, amount)
+
+### Documentation
+- fix javadocs for binary format (1/n)
+
+### Features
+- add warning when selecting more than one star catalog
+- add white core to star shaders
+- add T_eff to STIL-loaded catalogs
+- add color conversion by Harre and Heller
+- add output format version argument to octree generator
+- support for in catalog selector
+- add versioning to binary catalog format. Create new, more compact version
+- improve information of version line in welcome and loading screens
+- add GL info to welcome screen
+- new connection to wikipedia REST api to show content in a window
+- add unsharp mask post-processing filter
+- new checkbox textures, adjust window visuals
+- add projection lines to star groups
+- dataset selection dialog uses same structure as dataset manager
+- time warp slider instead of buttons
+- new fractional UI scaling from x0.7 to x2.0
+- add regexp to some column names for STIL loader, add invalid names array
+- add regexp to some column names for STIL loader, add invalid names array
+- case-insensitive columns in STIL loader, enable FITS loading
+
+### Performance Improvements
+- arrays of size not dependent on maxPart for octreegen
+- remove boundingBox from octant, reduce memory token duplication
+- replace extra attributes hashmap with objectdoublemap for RAM compactness
+- do not write star name strings if they are the same as ID, velocity vectors represented with single-precision floats
+- reduce main memory usage of stars by adjusting data types
+- switch to unordered gdx Arrays when possible to minimize copy operations
+- replace `java.util.ArrayList`s with Libgdx's `Array`s to minimize allocations
+- index lists are of base types, use dst2 for distance sorting
+- improve memory usage of extra star attributes and fix render system unnecessary `setUniform` calls
+- reduce memory usage in particle groups -> no metadata array
+
+### Style
+- fix missing coma in night-red theme json file
+- update thread names, fix monitor objects, increase sg update time interval
<a name="3.0.1"></a>
## [3.0.1](https://gitlab.com/langurmonkey/gaiasky/tree/3.0.0) (2020-12-10)
@@ -11,18 +85,18 @@
- show information dialog in case of OpenGL or java version problems
- disposing bookmarks manager without it being initialized
- update default screen size
-- remove idle FPS and backbuffer config
-- file chooser allows selection when entering directories if in DIRECTORIES mode
+- remove idle FPS and backbuffer configuration
+- file chooser allows selection when entering directories if in 'DIRECTORIES' mode
- update default max number of stars
- increase max heap space from 4 to 8 GB in all configurations
- 24-bit depth buffer, 8-bit stencil
-- JSON pointer from dr2 to edr3
+- JSON pointer from DR2 to eDR3
### Build System
-- update bundled jre version to 11.0.9+11
+- update bundled JRE version to 11.0.9+11
### Code Refactoring
-- all startup messages to i18n bundle, fix swing themes
+- all startup messages to I18N bundle, fix swing themes
### Documentation
- update pointers to documentation
@@ -30,12 +104,12 @@
### Features
- saner error reporting with new dialog
- add error dialog that works with OpenGL 2.0 and informs the user of insufficient OpenGL or Java versions
-- add safe graphics mode CLI argument '--safemode'
+- add safe graphics mode CLI argument `--safemode`
- dynamic resolution scaling - first implementation, deactivated
- add safe graphics mode, which does not use float buffers at all. It is activated by default if the context creation for 4.1 fails. It uses OpenGL 3.1.
- download manager is capable of resuming downloads
- special flag to enable OpenGL debug output
-- enable GPU debug info with --debug flag
+- enable GPU debug info with `--debug` flag
<a name="3.0.0"></a>
## [3.0.0](https://gitlab.com/langurmonkey/gaiasky/tree/2.3.1) (2020-12-02)
diff --git a/PKGBUILD b/PKGBUILD
index 64f26eb21453..ab31739940d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
#Maintainer: Toni Sagrista Selles <tsagrista@ari.uni-heidelberg.de>
pkgname=gaiasky
-pkgver=3.0.1.2318179ff
+pkgver=3.0.2.9bd17f001
pkgrel=1
epoch=2
pkgdesc="Interactive 3D Universe software focused on ESA's Gaia mission"
@@ -21,8 +21,8 @@ install=gaiasky.install
changelog=CHANGELOG.md
source=("http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/${pkgver//_/-}/$pkgname-${pkgver//_/-}.tar.gz")
noextract=()
-md5sums=("13d30f0e1dc71f3652623a59e7325a2d")
-sha256sums=("3f2e70eb8c416092897150a40e2d85190e30d5ae22d2c752d18418c561d13f00")
+md5sums=("325bb8d20b624425d4adae8cd6f39ab7")
+sha256sums=("4907dcb0c55dcfb257b60b972350f7b64a11d8712a796702e8be70468d4b69c2")
validpgpkeys=()
prepare() {