summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--CHANGELOG.md53
-rw-r--r--PKGBUILD11
3 files changed, 59 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e3df4343f5b2..1321aa2b9226 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,7 @@
pkgbase = gaiasky
pkgdesc = Interactive 3D Universe software focused on ESA's Gaia mission
- pkgver = 2.2.4_1.a169540c8
- pkgrel = 2
- epoch = 1
+ pkgver = 2.2.5.af37ad3be
+ pkgrel = 1
url = https://zah.uni-heidelberg.de/gaia/outreach/gaiasky
install = gaiasky.install
changelog = CHANGELOG.md
@@ -10,8 +9,8 @@ pkgbase = gaiasky
license = MPL
depends = jre11-openjdk
depends = xorg-xrandr
- source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/2.2.4-1.a169540c8/gaiasky-2.2.4-1.a169540c8.tar.gz
- md5sums = d22daeebd184ca29d46951044cd9737f
+ source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/2.2.5.af37ad3be/gaiasky-2.2.5.af37ad3be.tar.gz
+ md5sums = a73e7690bce7a7c5891098737a053a90
pkgname = gaiasky
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 475adf424619..ea72f2358bba 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,6 +1,53 @@
-<a name="unreleased"></a>
-## [Unreleased](https://gitlab.com/langurmonkey/gaiasky/tree/master)
-[Full changelog](https://gitlab.com/langurmonkey/gaiasky/compare/2.2.4-1...HEAD)
+<a name="2.2.5"></a>
+## [2.2.5](https://gitlab.com/langurmonkey/gaiasky/tree/2.2.4-1) (2020-03-04)
+[Full changelog](https://gitlab.com/langurmonkey/gaiasky/compare/2.2.4-1...2.2.5)
+
+### Bug Fixes
+- some API calls crash when using double[]
+- prevent orbit overlapping by rescaling period
+- macos system detection
+- land at location crash due to trim() applied to invisible name
+- add flush frames to postRunnable() actions in scripting implementation
+- proper extension checking for ATI vram info
+- proper fix for VMemInfo crash on arcolinux+ATI graphics
+- VRAM profiling crash for AMDGPUs [#326](https://gitlab.com/langurmonkey/gaiasky/issues/326)
+- adapt star brightness in cubemap modes [#318](https://gitlab.com/langurmonkey/gaiasky/issues/318)
+- reload default configuration file crash
+
+### Build System
+- fix versions of sdl2gdx and jsamp, refactor VMemInfo
+- update compress, jcommander and jsamp versions, replace gdx-controllers with sdl2glx for better compatibility
+- update stil library jar
+- get jsamp from repository
+- substitute underscore by hyphen in pkgver
+
+### Code Refactoring
+- add color array to all API calls that need a color, for consistency. Fixi some calls' documentation.
+- cubemap-related properties organised and cleaned-up
+- improve error handling of OpenGL 4.x incapable video cards
+
+### Documentation
+- clean up punctuation in API docs
+- improve API description of some calls
+
+### Features
+- dataset options when loaded through SAMP
+- improve UI elements
+- proper implementation of FXAA
+- load datasets as particles or stars
+- add script to test color map highlighting
+- implement planetarium deviation angle in shader [#328](https://gitlab.com/langurmonkey/gaiasky/issues/328)
+- update controller list live in preferences window, fix connection/disconnection events
+- add extra attributes, colormaps for highlighting
+- load all attributes from VOTables
+- STIL provider works with multiple names
+- support for multiple star names in octree gen
+- add support for multiple names per object
+
+### BREAKING CHANGE
+
+API call setStarSize() now gets the star point size in
+pixels instead of a normalized value between 0 and 100.
<a name="2.2.4-1"></a>
diff --git a/PKGBUILD b/PKGBUILD
index 891b1b12a70e..5e522bca745e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,8 @@
-
#Maintainer: Toni Sagrista Selles <tsagrista@ari.uni-heidelberg.de>
pkgname=gaiasky
-pkgver=2.2.4_1.a169540c8
-pkgrel=2
-epoch=1
+pkgver=2.2.5.af37ad3be
+pkgrel=1
+epoch=
pkgdesc="Interactive 3D Universe software focused on ESA's Gaia mission"
arch=(x86_64)
url="https://zah.uni-heidelberg.de/gaia/outreach/gaiasky"
@@ -20,9 +19,9 @@ backup=()
options=()
install=gaiasky.install
changelog=CHANGELOG.md
-source=("http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/2.2.4-1.a169540c8/$pkgname-${pkgver//_/-}.tar.gz")
+source=("http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/${pkgver//_/-}/$pkgname-${pkgver//_/-}.tar.gz")
noextract=()
-md5sums=("d22daeebd184ca29d46951044cd9737f")
+md5sums=("a73e7690bce7a7c5891098737a053a90")
validpgpkeys=()
prepare() {