summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0bcc1efec859..916541088151 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = gallery-dl
pkgdesc = Command-line program to download image-galleries and collections from several image hosting sites
pkgver = 1.17.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/mikf/gallery-dl
arch = any
license = GPL2
+ checkdepends = python-nose
makedepends = python-setuptools
makedepends = git
depends = python
diff --git a/PKGBUILD b/PKGBUILD
index 942473c1f6d0..dd3efa3a14f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,14 @@
pkgname=gallery-dl
pkgver=1.17.1
-pkgrel=1
+pkgrel=2
pkgdesc='Command-line program to download image-galleries and collections from several image hosting sites'
arch=(any)
url=https://github.com/mikf/gallery-dl
license=(GPL2)
depends=(python python-requests)
makedepends=(python-setuptools git)
+checkdepends=(python-nose)
optdepends=('ffmpeg: Convert Pixiv Ugoira to WebM'
'youtube-dl: Download videos'
'python-pysocks: SOCKS support')
@@ -23,6 +24,10 @@ build() {
python setup.py build
}
+check() {
+ make -C ${pkgname} test
+}
+
package() {
cd ${pkgname}
python setup.py install --root="$pkgdir" --optimize=1 --skip-build