summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore10
-rw-r--r--PKGBUILD26
3 files changed, 22 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9869572e3323..0835cbaab5ce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gallery-dl-bin
pkgdesc = Command-line program to download image-galleries and collections from several image hosting sites (bin)
- pkgver = 1.18.1
+ pkgver = 1.18.2
pkgrel = 1
url = https://github.com/mikf/gallery-dl
arch = x86_64
@@ -9,8 +9,8 @@ pkgbase = gallery-dl-bin
provides = gallery-dl
conflicts = gallery-dl
conflicts = gallery-dl-git
- source = https://github.com/mikf/gallery-dl/releases/download/v1.18.1/gallery-dl.bin
- source = https://github.com/mikf/gallery-dl/releases/download/v1.18.1/gallery-dl.bin.sig
+ source = https://github.com/mikf/gallery-dl/releases/download/v1.18.2/gallery-dl.bin
+ source = https://github.com/mikf/gallery-dl/releases/download/v1.18.2/gallery-dl.bin.sig
source = https://api.github.com/repos/mikf/gallery-dl/releases/latest
validpgpkeys = 3E09F5908333DD83DBDCE7375680CA389D365A88
sha256sums = SKIP
diff --git a/.gitignore b/.gitignore
index c743e1c98daa..209eaaefe67f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,4 @@
-src/*
-pkg/*
-*.zst
-*.sig
-*.bin
-latest
+/*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index f3e366d9e6d3..1a80eec2c5ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,30 +4,34 @@
# https://github.com/mikf/gallery-dl/issues/1117
# This binary release pushes this burden of dependency version resolution to the creator
+# shellcheck disable=2034,2148,2154
+
pkgname=gallery-dl-bin
-pkgver=1.18.1
+_pkgname=gallery-dl
+pkgver=1.18.2
pkgrel=1
url='https://github.com/mikf/gallery-dl'
pkgdesc='Command-line program to download image-galleries and collections from several image hosting sites (bin)'
arch=('x86_64')
depends=('zlib')
-provides=('gallery-dl')
-conflicts=('gallery-dl' 'gallery-dl-git')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}" "${_pkgname}-git")
license=(GPL2)
source=("${url}"/releases/download/v"${pkgver}"/gallery-dl.bin{,.sig}
- https://api.github.com/repos/mikf/gallery-dl/releases/latest)
+ "https://api.github.com/repos/mikf/${_pkgname}/releases/latest")
validpgpkeys=('3E09F5908333DD83DBDCE7375680CA389D365A88')
-sha256sums=('SKIP' 'SKIP' 'SKIP')
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
pkgver() {
- cd "${srcdir}"
- chmod +x gallery-dl.bin
- grep -oP 'https://.*gallery-dl.bin' latest |
+ cd "${srcdir}" || exit
+ grep -oP "https://.*${_pkgname}.bin" latest |
head -n1 |
- sed -re 's|.*/v(.*)/gallery-dl.bin|\1|g'
+ sed -re "s|.*/v(.*)/${_pkgname}.bin|\1|g"
}
package() {
- cd "${srcdir}"
- install -Dm0775 gallery-dl.bin "${pkgdir}"/usr/bin/gallery-dl
+ cd "${srcdir}" || exit
+ install -Dm0755 "${_pkgname}.bin" "${pkgdir}/usr/bin/${_pkgname}"
}