summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD15
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 25a515b716f0..7250c79e7199 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
pkgbase = galois
pkgdesc = A falling blocks game with blocks of various shapes and sizes
pkgver = 0.7
- pkgrel = 1
+ pkgrel = 2
url = https://www.nongnu.org/galois
arch = x86_64
+ arch = aarch64
license = GPL3
depends = gtkmm3
depends = libxml++
diff --git a/PKGBUILD b/PKGBUILD
index 8e14d35200fd..454aae7254f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
-# Maintainer:
+# Maintainer: <reg-archlinux AT klein DOT tuxli DOT ch>
# Contributor: Michael Straube <michael.straubej@gmail.com>
# Contributor: Frederic Bezies <fredbezies at gmail dot com>
# Contributor: kusakata <shohei atmark kusakata period com>
pkgname=galois
pkgver=0.7
-pkgrel=1
+pkgrel=2
pkgdesc='A falling blocks game with blocks of various shapes and sizes'
-arch=('x86_64')
+arch=('x86_64' 'aarch64')
url="https://www.nongnu.org/galois"
license=('GPL3')
depends=('gtkmm3' 'libxml++')
@@ -21,19 +21,20 @@ sha512sums=('8d480b9e5746dfe00c4684ae179697e82d5c259ae092bb18c29733e69752175e584
'b8ca1a9dd34f9e74b377bd413837d438515f65a205795307e09f462df2c7241dc1ea46e518b6225792618f35313c43712964a65ef5ab469de5f99a0512cd3aa3')
prepare() {
- cd $pkgname-$pkgver
+ cd "${pkgname}-${pkgver}"
patch -Np1 -i ../galois-0.7-install-path.patch
patch -Np1 -i ../galois-0.7-full-relro.patch
patch -Np1 -i ../galois-0.7-libxml++3.0.patch
}
build() {
- cd $pkgname-$pkgver
+ cd "${pkgname}-${pkgver}"
./configure --prefix=/usr
make
}
package() {
- cd $pkgname-$pkgver
- make DESTDIR="$pkgdir" install
+ cd "${pkgname}-${pkgver}"
+ install -Dm644 "COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ make DESTDIR="${pkgdir}" install
}