summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e15a85dfefaa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = galois
+ pkgdesc = A computer game of the "falling blocks" type, but with unique features
+ pkgver = 0.3
+ pkgrel = 2
+ url = http://www.nongnu.org/galois/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = gtkmm
+ depends = libxml++
+ source = http://download.savannah.gnu.org/releases/galois/source/galois-0.3.tar.gz
+ md5sums = 379b33ac28b1c5140c59aefae0b69964
+
+pkgname = galois
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb1a09abf39c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer : Frederic Bezies <fredbezies at gmail dot com>
+# Contributor: kusakata <shohei atmark kusakata period com>
+
+pkgname=galois
+pkgver=0.3
+pkgrel=2
+pkgdesc='A computer game of the "falling blocks" type, but with unique features'
+arch=('i686' 'x86_64')
+url="http://www.nongnu.org/galois/"
+license=('GPL3')
+depends=('gtkmm' 'libxml++')
+source=("http://download.savannah.gnu.org/releases/galois/source/galois-${pkgver}.tar.gz")
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="$pkgdir" install
+ cd "${pkgdir}/usr"
+ mv games bin
+}
+
+md5sums=('379b33ac28b1c5140c59aefae0b69964')