summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--client_secrets.patch89
3 files changed, 2 insertions, 91 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 933028dfb134..b5c121ac6b73 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gam
pkgdesc = Command-line tool for Google GSuite admins to manage settings quickly and easily.
pkgver = 4.70
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/jay0lee/GAM
arch = any
license = Apache
diff --git a/PKGBUILD b/PKGBUILD
index 459b2beb35f9..c750ff11fdb5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=gam
pkgver=4.70
-pkgrel=1
+pkgrel=2
pkgdesc="Command-line tool for Google GSuite admins to manage settings quickly and easily."
arch=('any')
url="https://github.com/jay0lee/GAM"
diff --git a/client_secrets.patch b/client_secrets.patch
deleted file mode 100644
index 12d58c53c0a7..000000000000
--- a/client_secrets.patch
+++ /dev/null
@@ -1,89 +0,0 @@
---- old-gam.py 2015-08-18 23:04:39.852955746 +0200
-+++ gam.py 2015-08-18 23:05:42.805013976 +0200
-@@ -319,7 +319,7 @@
- global customerId
- oauth2file = getGamPath()+u'oauth2.txt'
- try:
-- oauth2file = getGamPath()+os.environ[u'OAUTHFILE']
-+ oauth2file = os.environ[u'OAUTHFILE']
- except KeyError:
- pass
- storage = oauth2client.file.Storage(oauth2file)
-@@ -526,7 +526,7 @@
- global domain, customerId, extra_args
- oauth2file = getGamPath()+u'oauth2.txt'
- try:
-- oauth2file = getGamPath()+os.environ[u'OAUTHFILE']
-+ oauth2file = os.environ[u'OAUTHFILE']
- except KeyError:
- pass
- storage = oauth2client.file.Storage(oauth2file)
-@@ -543,6 +543,10 @@
- cache = None
- if not os.path.isfile(getGamPath()+u'nocache.txt'):
- cache = u'%sgamcache' % getGamPath()
-+ try:
-+ cache = os.environ[u'GAMCACHE']
-+ except KeyError:
-+ pass
- http = httplib2.Http(ca_certs=getGamPath()+u'cacert.pem', disable_ssl_certificate_validation=disable_ssl_certificate_validation, cache=cache)
- if os.path.isfile(getGamPath()+u'debug.gam'):
- httplib2.debuglevel = 4
-@@ -589,7 +593,7 @@
- global extra_args
- oauth2servicefile = getGamPath()+u'oauth2service'
- try:
-- oauth2servicefile = getGamPath()+os.environ[u'OAUTHSERVICEFILE']
-+ oauth2servicefile = os.environ[u'OAUTHSERVICEFILE']
- except KeyError:
- pass
- oauth2servicefilejson = u'%s.json' % oauth2servicefile
-@@ -627,6 +631,10 @@
- cache = None
- if not os.path.isfile(getGamPath()+u'nocache.txt'):
- cache = '%sgamcache' % getGamPath()
-+ try:
-+ cache = os.environ[u'GAMCACHE']
-+ except KeyError:
-+ pass
- http = httplib2.Http(ca_certs=getGamPath()+u'cacert.pem', disable_ssl_certificate_validation=disable_ssl_certificate_validation, cache=cache)
- if os.path.isfile(getGamPath()+u'debug.gam'):
- httplib2.debuglevel = 4
-@@ -5520,7 +5528,7 @@
- except IndexError:
- oauth2file = getGamPath()+u'oauth2.txt'
- try:
-- oauth2file = getGamPath()+os.environ[u'OAUTHFILE']
-+ oauth2file = os.environ[u'OAUTHFILE']
- except KeyError:
- pass
- storage = oauth2client.file.Storage(oauth2file)
-@@ -7898,7 +7906,7 @@
- except IndexError:
- oauth2file = getGamPath()+u'oauth2.txt'
- try:
-- oauth2file = getGamPath()+os.environ[u'OAUTHFILE']
-+ oauth2file = os.environ[u'OAUTHFILE']
- except KeyError:
- pass
- storage = oauth2client.file.Storage(oauth2file)
-@@ -7941,7 +7949,7 @@
- def doDeleteOAuth():
- oauth2file = getGamPath()+u'oauth2.txt'
- try:
-- oauth2file = getGamPath()+os.environ[u'OAUTHFILE']
-+ oauth2file = os.environ[u'OAUTHFILE']
- except KeyError:
- pass
- storage = oauth2client.file.Storage(oauth2file)
-@@ -7981,6 +7989,10 @@
-
- def doRequestOAuth(incremental_auth=False):
- CLIENT_SECRETS = getGamPath()+u'client_secrets.json'
-+ try:
-+ CLIENT_SECRETS = os.environ[u'CLIENTSECRETS']
-+ except KeyError:
-+ pass
- MISSING_CLIENT_SECRETS_MESSAGE = u"""
- WARNING: Please configure OAuth 2.0
-