summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD22
-rw-r--r--xdg_config_dirs.patch84
3 files changed, 67 insertions, 63 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ef2afbe8c57..7f7a7f9ceea8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,22 @@
pkgbase = gam
pkgdesc = Command-line tool for Google GSuite admins to manage settings quickly and easily.
- pkgver = 4.72
+ pkgver = 4.82
pkgrel = 1
url = https://github.com/jay0lee/GAM
arch = any
license = Apache
- depends = python2
- depends = python2-gdata
- depends = python2-google-api-python-client
- depends = python2-google-auth
- depends = python2-google-auth-httplib2
- depends = python2-httplib2
- depends = python2-oauth2client
- depends = python2-passlib
- depends = python2-simplejson
- source = gam-4.72.tar.gz::https://github.com/jay0lee/GAM/archive/v4.72.tar.gz
+ depends = python-dateutil
+ depends = python-dnspython
+ depends = python-google-api-python-client
+ depends = python-google-auth
+ depends = python-google-auth-httplib2
+ depends = python-oauth2client
+ depends = python-passlib
+ source = gam-4.82.tar.gz::https://github.com/jay0lee/GAM/archive/v4.82.tar.gz
source = xdg_config_dirs.patch
source = gam.sh
- sha256sums = 04a4c6d3c942beef50d7c5932060b0172d4dd13d943f0f1642e05420617f665e
- sha256sums = 2879cbdcde779fa9cc6bafeadf657369377e5c317e9564c5e144c29ba9daa383
+ sha256sums = 82238f0a17896cce84d0d03acd0186672511b0ceb6aa8d1367507bdd7a45a697
+ sha256sums = 202e3566d837c37526174fb6311232c06d90e3786578668aa58ef3eb0648054a
sha256sums = d93809852ef9eefeb99f3fc1b955305264f93f2552db14b4d9d6fe7c2b08345b
pkgname = gam
diff --git a/PKGBUILD b/PKGBUILD
index 60411db72a7f..fec0ae117c12 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,20 @@
# Contributor: Ethan Schoonover
pkgname=gam
-pkgver=4.72
+pkgver=4.82
pkgrel=1
pkgdesc="Command-line tool for Google GSuite admins to manage settings quickly and easily."
arch=('any')
url="https://github.com/jay0lee/GAM"
license=('Apache')
depends=(
- 'python2'
- 'python2-gdata'
- 'python2-google-api-python-client'
- 'python2-google-auth'
- 'python2-google-auth-httplib2'
- 'python2-httplib2'
- 'python2-oauth2client'
- 'python2-passlib'
- 'python2-simplejson'
+ 'python-dateutil'
+ 'python-dnspython'
+ 'python-google-api-python-client'
+ 'python-google-auth'
+ 'python-google-auth-httplib2'
+ 'python-oauth2client'
+ 'python-passlib'
)
source=(
@@ -26,8 +24,8 @@ source=(
"gam.sh"
)
-sha256sums=('04a4c6d3c942beef50d7c5932060b0172d4dd13d943f0f1642e05420617f665e'
- '2879cbdcde779fa9cc6bafeadf657369377e5c317e9564c5e144c29ba9daa383'
+sha256sums=('82238f0a17896cce84d0d03acd0186672511b0ceb6aa8d1367507bdd7a45a697'
+ '202e3566d837c37526174fb6311232c06d90e3786578668aa58ef3eb0648054a'
'd93809852ef9eefeb99f3fc1b955305264f93f2552db14b4d9d6fe7c2b08345b')
prepare() {
diff --git a/xdg_config_dirs.patch b/xdg_config_dirs.patch
index d1e2ef5a82b8..efeb12c9046e 100644
--- a/xdg_config_dirs.patch
+++ b/xdg_config_dirs.patch
@@ -1,56 +1,64 @@
---- src/var.py 2018-08-03 14:30:31.000000000 -0600
-+++ src/var.py 2018-08-11 12:02:27.184546770 -0600
-@@ -20,6 +20,18 @@
- GAM_LATEST_RELEASE = GAM_ALL_RELEASES+u'/latest'
- GAM_PROJECT_APIS = u'https://raw.githubusercontent.com/jay0lee/GAM/master/src/project-apis.txt'
+--- src/var.py 2019-05-01 22:06:05.334383160 -0600
++++ src/var.py 2019-05-01 22:09:01.646756561 -0600
+@@ -20,6 +20,19 @@
+ GAM_LATEST_RELEASE = GAM_ALL_RELEASES+'/latest'
+ GAM_PROJECT_APIS = 'https://raw.githubusercontent.com/jay0lee/GAM/master/src/project-apis.txt'
+try:
-+ XDG_CONFIG_DIR = os.environ['XDG_CONFIG_HOME']
++ XDG_CONFIG_DIR = os.environ['XDG_CONFIG_HOME']
+except KeyError:
-+ XDG_CONFIG_DIR = os.path.expanduser("~") + '/.config/'
-+CONFIG_DIR = unicode(XDG_CONFIG_DIR) + u'gam/'
++ XDG_CONFIG_DIR = os.path.expanduser("~") + '/.config/'
++CONFIG_DIR = XDG_CONFIG_DIR + 'gam/'
+
+try:
-+ os.makedirs(CONFIG_DIR, mode=0700)
++ os.makedirs(CONFIG_DIR, mode=700)
+except OSError:
-+ if not os.path.isdir(CONFIG_DIR):
-+ raise
++ if not os.path.isdir(CONFIG_DIR):
++ raise
+
- TRUE = u'true'
- FALSE = u'false'
- true_values = [u'on', u'yes', u'enabled', u'true', u'1']
-@@ -36,11 +48,11 @@
- ONE_KILO_BYTES = 1000
- ONE_MEGA_BYTES = 1000000
- ONE_GIGA_BYTES = 1000000000
--FN_CLIENT_SECRETS_JSON = u'client_secrets.json'
--FN_EXTRA_ARGS_TXT = u'extra-args.txt'
--FN_LAST_UPDATE_CHECK_TXT = u'lastupdatecheck.txt'
--FN_OAUTH2SERVICE_JSON = u'oauth2service.json'
--FN_OAUTH2_TXT = u'oauth2.txt'
-+FN_CLIENT_SECRETS_JSON = CONFIG_DIR + u'client_secrets.json'
-+FN_EXTRA_ARGS_TXT = CONFIG_DIR + u'extra-args.txt'
-+FN_LAST_UPDATE_CHECK_TXT = CONFIG_DIR + u'lastupdatecheck.txt'
-+FN_OAUTH2SERVICE_JSON = CONFIG_DIR + u'oauth2service.json'
-+FN_OAUTH2_TXT = CONFIG_DIR + u'oauth2.txt'
- MY_CUSTOMER = u'my_customer'
- SKUS = {
- u'1010010001': {
-@@ -653,7 +665,7 @@
++
+ true_values = ['on', 'yes', 'enabled', 'true', '1']
+ false_values = ['off', 'no', 'disabled', 'false', '0']
+ usergroup_types = ['user', 'users',
+@@ -32,8 +45,8 @@
+ WARNING_PREFIX = 'WARNING: '
+ UTF8 = 'utf-8'
+ UTF8_SIG = 'utf-8-sig'
+-FN_EXTRA_ARGS_TXT = 'extra-args.txt'
+-FN_LAST_UPDATE_CHECK_TXT = 'lastupdatecheck.txt'
++FN_EXTRA_ARGS_TXT = CONFIG_DIR + 'extra-args.txt'
++FN_LAST_UPDATE_CHECK_TXT = CONFIG_DIR + 'lastupdatecheck.txt'
+ MY_CUSTOMER = 'my_customer'
+ # See https://support.google.com/drive/answer/37603
+ MAX_GOOGLE_SHEET_CELLS = 5000000
+@@ -640,9 +653,9 @@
+
+ #
+ _DEFAULT_CHARSET = UTF8
+-_FN_CLIENT_SECRETS_JSON = 'client_secrets.json'
+-_FN_OAUTH2SERVICE_JSON = 'oauth2service.json'
+-_FN_OAUTH2_TXT = 'oauth2.txt'
++_FN_CLIENT_SECRETS_JSON = CONFIG_DIR + 'client_secrets.json'
++_FN_OAUTH2SERVICE_JSON = CONFIG_DIR + 'oauth2service.json'
++_FN_OAUTH2_TXT = CONFIG_DIR + 'oauth2.txt'
+ #
+ GM_Globals = {
+ GM_SYSEXITRC: 0,
+@@ -685,7 +698,7 @@
# Path to client_secrets.json
- GC_CLIENT_SECRETS_JSON = u'client_secrets_json'
+ GC_CLIENT_SECRETS_JSON = 'client_secrets_json'
# GAM config directory containing client_secrets.json, oauth2.txt, oauth2service.json, extra_args.txt
--GC_CONFIG_DIR = u'config_dir'
+-GC_CONFIG_DIR = 'config_dir'
+GC_CONFIG_DIR = CONFIG_DIR
# custmerId from gam.cfg or retrieved from Google
- GC_CUSTOMER_ID = u'customer_id'
+ GC_CUSTOMER_ID = 'customer_id'
# If debug_level > 0: extra_args[u'prettyPrint'] = True, httplib2.debuglevel = gam_debug_level, appsObj.debug = True
-@@ -712,7 +724,7 @@
+@@ -752,7 +765,7 @@
GC_MEMBER_MAX_RESULTS: 200,
GC_NO_BROWSER: False,
GC_NO_CACHE: False,
- GC_NO_UPDATE_CHECK: False,
+ GC_NO_UPDATE_CHECK: True,
- GC_NO_VERIFY_SSL: False,
GC_NUM_THREADS: 25,
- GC_OAUTH2_TXT: FN_OAUTH2_TXT,
+ GC_OAUTH2_TXT: _FN_OAUTH2_TXT,
+ GC_OAUTH2SERVICE_JSON: _FN_OAUTH2SERVICE_JSON,