summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD15
-rw-r--r--python2.patch6
-rw-r--r--xdg_config_dirs.patch35
4 files changed, 50 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8fd3aae10ed3..50a0fa32e69d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon May 21 23:52:29 UTC 2018
+# Sun Aug 12 02:27:56 UTC 2018
pkgbase = gam
pkgdesc = Command line tool for Google G Suite Administrators to manage domain and user settings quickly and easily.
- pkgver = 4.40
- pkgrel = 3
+ pkgver = 4.60
+ pkgrel = 1
url = https://github.com/jay0lee/GAM
arch = any
license = Apache
@@ -15,11 +15,11 @@ pkgbase = gam
depends = python2-gdata
depends = python2-google-auth
depends = perl-mozilla-ca
- source = https://github.com/jay0lee/GAM/archive/v4.40.tar.gz
- source = python2.patch
+ source = https://github.com/jay0lee/GAM/archive/v4.60.tar.gz
+ source = xdg_config_dirs.patch
source = gam.sh
- sha256sums = 01ce48e0ac79f35ba6c891e54156c67af232f210e98dea2b3178186659064ee0
- sha256sums = 417f05ee7da33763f56b7b148f46564859133ececbd5a847cd3396a9802d5944
+ sha256sums = f8274b2aff987a41344bb3ddcd6f43cbda27d5fc8de830a5f961764662cee959
+ sha256sums = e85568f0f0e038e01c88a5b2b4e30f057faf737f6e8dac1c41463ec20825118a
sha256sums = d93809852ef9eefeb99f3fc1b955305264f93f2552db14b4d9d6fe7c2b08345b
pkgname = gam
diff --git a/PKGBUILD b/PKGBUILD
index 0ae94d93c116..85a9754fcae5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Ethan Schoonover
pkgname=gam
-pkgver=4.40
-pkgrel=3
+pkgver=4.60
+pkgrel=1
pkgdesc="Command line tool for Google G Suite Administrators to manage domain and user settings quickly and easily."
arch=('any')
url="https://github.com/jay0lee/GAM"
@@ -20,15 +20,16 @@ depends=(
)
source=(
"https://github.com/jay0lee/GAM/archive/v${pkgver}.tar.gz"
- "python2.patch"
+ "xdg_config_dirs.patch"
"gam.sh"
)
-sha256sums=('01ce48e0ac79f35ba6c891e54156c67af232f210e98dea2b3178186659064ee0'
- '417f05ee7da33763f56b7b148f46564859133ececbd5a847cd3396a9802d5944'
+sha256sums=('f8274b2aff987a41344bb3ddcd6f43cbda27d5fc8de830a5f961764662cee959'
+ 'e85568f0f0e038e01c88a5b2b4e30f057faf737f6e8dac1c41463ec20825118a'
'd93809852ef9eefeb99f3fc1b955305264f93f2552db14b4d9d6fe7c2b08345b')
-prepare(){
- patch -i "$srcdir/python2.patch" -d "$srcdir/GAM-$pkgver/src/"
+prepare() {
+ cd "$srcdir/GAM-$pkgver"
+ patch -p0 < ../xdg_config_dirs.patch
}
package() {
diff --git a/python2.patch b/python2.patch
deleted file mode 100644
index 9a1af47edbcd..000000000000
--- a/python2.patch
+++ /dev/null
@@ -1,6 +0,0 @@
---- gam.py 2014-08-18 05:15:29.429612735 -0400
-+++ gam.py 2014-08-18 05:15:23.403373373 -0400
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python2
- # -*- coding: utf-8 -*-
diff --git a/xdg_config_dirs.patch b/xdg_config_dirs.patch
new file mode 100644
index 000000000000..e799bf715220
--- /dev/null
+++ b/xdg_config_dirs.patch
@@ -0,0 +1,35 @@
+--- src/var.py 2018-08-10 23:05:08.294626452 -0600
++++ src/var.py 2018-08-11 12:02:27.184546770 -0600
+@@ -23,11 +23,11 @@
+ try:
+ XDG_CONFIG_DIR = os.environ['XDG_CONFIG_HOME']
+ except KeyError:
+- XDG_CONFIG_DIR = unicode(os.path.expanduser("~") + '/.config/')
+-CONFIG_DIR = XDG_CONFIG_DIR + 'gam/'
++ XDG_CONFIG_DIR = os.path.expanduser("~") + '/.config/'
++CONFIG_DIR = unicode(XDG_CONFIG_DIR) + u'gam/'
+
+ try:
+- os.makedirs(CONFIG_DIR)
++ os.makedirs(CONFIG_DIR, mode=0700)
+ except OSError:
+ if not os.path.isdir(CONFIG_DIR):
+ raise
+@@ -665,7 +665,7 @@
+ # Path to client_secrets.json
+ GC_CLIENT_SECRETS_JSON = u'client_secrets_json'
+ # GAM config directory containing client_secrets.json, oauth2.txt, oauth2service.json, extra_args.txt
+-GC_CONFIG_DIR = u'config_dir'
++GC_CONFIG_DIR = CONFIG_DIR
+ # custmerId from gam.cfg or retrieved from Google
+ GC_CUSTOMER_ID = u'customer_id'
+ # If debug_level > 0: extra_args[u'prettyPrint'] = True, httplib2.debuglevel = gam_debug_level, appsObj.debug = True
+@@ -724,7 +724,7 @@
+ GC_MEMBER_MAX_RESULTS: 200,
+ GC_NO_BROWSER: False,
+ GC_NO_CACHE: False,
+- GC_NO_UPDATE_CHECK: False,
++ GC_NO_UPDATE_CHECK: True,
+ GC_NO_VERIFY_SSL: False,
+ GC_NUM_THREADS: 25,
+ GC_OAUTH2_TXT: FN_OAUTH2_TXT,