summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD38
-rw-r--r--ludecomp.diff13
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c39b73ac2cda
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Tue May 10 17:00:37 UTC 2016
+pkgbase = gambit
+ pkgdesc = Tools for doing computation in game theory - git version
+ pkgver = 14.1.0
+ pkgrel = 1
+ url = http://www.gambit-project.org
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = wxgtk
+ provides = gambit
+ conflicts = gambit
+ options = !makeflags
+ source = https://github.com/gambitproject/gambit/archive/v14.1.0.tar.gz
+ source = ludecomp.diff
+ md5sums = 06a8f4b4e5d990f443de900b2b95aef0
+ md5sums = 4086c9c74892440e00c9be7f8ace4bce
+
+pkgname = gambit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..691c2b5cb218
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=gambit
+pkgver=14.1.0
+pkgrel=1
+pkgdesc="Tools for doing computation in game theory - git version"
+arch=('i686' 'x86_64')
+url="http://www.gambit-project.org"
+license=('GPL')
+depends=('wxgtk')
+makedepends=('git')
+provides=('gambit')
+conflicts=('gambit')
+source=(https://github.com/gambitproject/gambit/archive/v$pkgver.tar.gz ludecomp.diff)
+md5sums=('06a8f4b4e5d990f443de900b2b95aef0'
+ '4086c9c74892440e00c9be7f8ace4bce')
+options=('!makeflags')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch -p1 < "$srcdir"/ludecomp.diff
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ aclocal
+ libtoolize
+ automake --add-missing
+ autoconf
+ [[ $CARCH == "X86_64" ]] && CXXFLAGS+=" -std=c++03" ./configure --prefix=/usr --disable-enumpoly
+ [[ $CARCH == "i686" ]] && CXXFLAGS+=" -std=c++03" ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/ludecomp.diff b/ludecomp.diff
new file mode 100644
index 000000000000..c83f948552aa
--- /dev/null
+++ b/ludecomp.diff
@@ -0,0 +1,13 @@
+diff --git a/src/liblinear/ludecomp.imp b/src/liblinear/ludecomp.imp
+index 2648c9d..8e8fc57 100644
+--- a/src/liblinear/ludecomp.imp
++++ b/src/liblinear/ludecomp.imp
+@@ -25,7 +25,7 @@
+ #include "ludecomp.h"
+ #include "tableau.h"
+
+-inline double abs(double x) { return fabs(x); }
++// inline double abs(double x) { return fabs(x); }
+
+ // ---------------------------------------------------------------------------
+ // Class EtaMatrix