summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD36
-rwxr-xr-xgammy.desktop8
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..70d8fa1f0a60
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = gammy-git
+ pkgdesc = Automatic screen brightness tool.
+ pkgver = 0.9.42.r18.1c7b3b6
+ pkgrel = 1
+ url = https://getgammy.com
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = mesa
+ depends = qt5-base
+ provides = gammy
+ conflicts = gammy
+ source = git+https://github.com/Fushko/gammy.git
+ source = gammy.desktop
+ sha256sums = SKIP
+ sha256sums = 32bdd9ae6e2eac460bbcc02c4f6cba6428d557e2c471fc67727d9c6a231f6764
+
+pkgname = gammy-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cef3fa85fdd8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Mark Wagie <yochanan dot marqos at gmail dot com>
+pkgname=gammy-git
+pkgver=0.9.42.r18.1c7b3b6
+pkgrel=1
+pkgdesc="Automatic screen brightness tool."
+arch=('x86_64')
+url="https://getgammy.com"
+license=('GPL3')
+depends=('mesa' 'qt5-base')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('git+https://github.com/Fushko/gammy.git'
+ "${pkgname%-git}.desktop")
+sha256sums=('SKIP'
+ '32bdd9ae6e2eac460bbcc02c4f6cba6428d557e2c471fc67727d9c6a231f6764')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ qmake Gammy.pro
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ make INSTALL_ROOT="$pkgdir/" install
+ install -d "$pkgdir/usr/bin"
+ ln -s /opt/Gammy/bin/Gammy "$pkgdir/usr/bin/gammy"
+ install -Dm644 "$srcdir/${pkgname%-git}.desktop" \
+ "$pkgdir/usr/share/applications/${pkgname%-git}.desktop"
+}
diff --git a/gammy.desktop b/gammy.desktop
new file mode 100755
index 000000000000..40f52ac5ae74
--- /dev/null
+++ b/gammy.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Gammy
+Exec=/opt/Gammy/bin/Gammy
+Icon=gammy
+Type=Application
+Terminal=false
+Hidden=false
+Categories=Utility