summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD35
2 files changed, 24 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 303a2aa93452..322d062a8a8a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = gams
- pkgdesc = The General Algebraic Modeling System (GAMS) is a high-level modeling system for mathematical optimization.
- pkgver = 27.1.0
- pkgrel = 1
- url = http://www.gams.com/
+ pkgdesc = A high-level modeling system for mathematical optimization
+ pkgver = 45.6.0
+ pkgrel = 0
+ url = https://gams.com/
arch = x86_64
license = custom
+ depends = glibc
options = !strip
- source = https://d37drm4t2jghv5.cloudfront.net/distributions/27.1.0/linux/linux_x64_64_sfx.exe
+ source = gams-45.6.0.exe::https://d37drm4t2jghv5.cloudfront.net/distributions/45.6.0/linux/linux_x64_64_sfx.exe
source = gams-studio.desktop
- sha256sums = bf51c6c1a35a7376b5ec1f568584b2d66e9c95581bd25f32d7774716df94a5b1
+ sha256sums = 291198031dd0980a5150819eda3f87fdee6ab029648827522b0d12efa94457d7
sha256sums = 5349929ad07ea8de5e6f1e5d03f264b2fd5afc161b4204981d30fc2ff8faed7e
pkgname = gams
-
diff --git a/PKGBUILD b/PKGBUILD
index f3bd3b31c62e..ca7aee3182ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,25 @@
-# Maintainer: gaelic < gaelic at luchmhor dot net>
-# Maintainer: Peter Reschenhofer < peterreschenhofer at gmail dot com >
+# Maintainer: Marco Rodolfi <marco dot rodolfi at tuta dot io>
+# Contributor: gaelic < gaelic at luchmhor dot net>
+# Contributor: Peter Reschenhofer < peterreschenhofer at gmail dot com >
+
pkgname=gams
-pkgver=27.1.0
-pkgrel=1
-pkgdesc="The General Algebraic Modeling System (GAMS) is a high-level modeling system for mathematical optimization."
+pkgver=45.6.0
+pkgrel=0
+pkgdesc='A high-level modeling system for mathematical optimization'
arch=('x86_64')
license=('custom')
-url="http://www.gams.com/"
-depends=()
-conflicts=()
+url='https://gams.com/'
+depends=('glibc')
options=('!strip')
-
-source=("https://d37drm4t2jghv5.cloudfront.net/distributions/${pkgver}/linux/linux_x64_64_sfx.exe"
+source=("$pkgname-$pkgver.exe::https://d37drm4t2jghv5.cloudfront.net/distributions/$pkgver/linux/linux_x64_64_sfx.exe"
"gams-studio.desktop")
-
-sha256sums=("bf51c6c1a35a7376b5ec1f568584b2d66e9c95581bd25f32d7774716df94a5b1"
- "5349929ad07ea8de5e6f1e5d03f264b2fd5afc161b4204981d30fc2ff8faed7e")
+sha256sums=('291198031dd0980a5150819eda3f87fdee6ab029648827522b0d12efa94457d7'
+ '5349929ad07ea8de5e6f1e5d03f264b2fd5afc161b4204981d30fc2ff8faed7e')
package() {
- install -d ${pkgdir}/{opt/gams,usr/bin}
- cp -r ${srcdir}/gams*_linux_x64_64_sfx/* ${pkgdir}/opt/gams/
- install -Dm644 gams-studio.desktop ${pkgdir}/usr/share/applications/gams-studio.desktop
- ln -s "/opt/gams/gams" "$pkgdir/usr/bin/gams"
- ln -s "/opt/gams/studio/studio.AppImage" "$pkgdir/usr/bin/gams-studio"
+ install -d "$pkgdir/opt/gams" "$pkgdir/usr/bin"
+ cp -a --no-preserve=ownership "gams${pkgver::4}_linux_x64_64_sfx/"* "$pkgdir/opt/gams/"
+ install -Dvm644 gams-studio.desktop -t "$pkgdir/usr/share/applications/"
+ ln -sv "/opt/gams/gams" "$pkgdir/usr/bin/gams"
+ ln -sv "/opt/gams/studio/studio.AppImage" "$pkgdir/usr/bin/gams-studio"
}