summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD34
-rw-r--r--gams-studio.desktop11
3 files changed, 40 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 51239948924e..322d062a8a8a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,15 @@
pkgbase = gams
- pkgdesc = The General Algebraic Modeling System (GAMS) is a high-level modeling system for mathematical optimization.
- pkgver = 26.1.0
- pkgrel = 1
- url = http://www.gams.com/
+ pkgdesc = A high-level modeling system for mathematical optimization
+ pkgver = 45.6.0
+ pkgrel = 0
+ url = https://gams.com/
arch = x86_64
license = custom
- source = https://d37drm4t2jghv5.cloudfront.net/distributions/26.1.0/linux/linux_x64_64_sfx.exe
- sha256sums = 1eb8d551ce3489cb10e062566f9b3da7e1e98079d75c692540ff41101c7c024c
+ depends = glibc
+ options = !strip
+ source = gams-45.6.0.exe::https://d37drm4t2jghv5.cloudfront.net/distributions/45.6.0/linux/linux_x64_64_sfx.exe
+ source = gams-studio.desktop
+ sha256sums = 291198031dd0980a5150819eda3f87fdee6ab029648827522b0d12efa94457d7
+ sha256sums = 5349929ad07ea8de5e6f1e5d03f264b2fd5afc161b4204981d30fc2ff8faed7e
pkgname = gams
-
diff --git a/PKGBUILD b/PKGBUILD
index 6adb45167629..ca7aee3182ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,25 @@
-# Maintainer: Peter Reschenhofer < peterreschenhofer at gmail dot com >
-# Maintainer: gaelic < gaelic at luchmhor dot net>
+# Maintainer: Marco Rodolfi <marco dot rodolfi at tuta dot io>
+# Contributor: gaelic < gaelic at luchmhor dot net>
+# Contributor: Peter Reschenhofer < peterreschenhofer at gmail dot com >
+
pkgname=gams
-pkgver=26.1.0
-pkgrel=1
-pkgdesc="The General Algebraic Modeling System (GAMS) is a high-level modeling system for mathematical optimization."
+pkgver=45.6.0
+pkgrel=0
+pkgdesc='A high-level modeling system for mathematical optimization'
arch=('x86_64')
license=('custom')
-url="http://www.gams.com/"
-depends=()
-conflicts=()
-
-source=("https://d37drm4t2jghv5.cloudfront.net/distributions/${pkgver}/linux/linux_x64_64_sfx.exe")
-
-sha256sums=("1eb8d551ce3489cb10e062566f9b3da7e1e98079d75c692540ff41101c7c024c")
+url='https://gams.com/'
+depends=('glibc')
+options=('!strip')
+source=("$pkgname-$pkgver.exe::https://d37drm4t2jghv5.cloudfront.net/distributions/$pkgver/linux/linux_x64_64_sfx.exe"
+ "gams-studio.desktop")
+sha256sums=('291198031dd0980a5150819eda3f87fdee6ab029648827522b0d12efa94457d7'
+ '5349929ad07ea8de5e6f1e5d03f264b2fd5afc161b4204981d30fc2ff8faed7e')
package() {
- install -d ${pkgdir}/{opt/gams,usr/bin}
- cp -r ${srcdir}/gams*_linux_x64_64_sfx/* ${pkgdir}/opt/gams/
- ln -s "/opt/gams/gams" "$pkgdir/usr/bin/gams"
+ install -d "$pkgdir/opt/gams" "$pkgdir/usr/bin"
+ cp -a --no-preserve=ownership "gams${pkgver::4}_linux_x64_64_sfx/"* "$pkgdir/opt/gams/"
+ install -Dvm644 gams-studio.desktop -t "$pkgdir/usr/share/applications/"
+ ln -sv "/opt/gams/gams" "$pkgdir/usr/bin/gams"
+ ln -sv "/opt/gams/studio/studio.AppImage" "$pkgdir/usr/bin/gams-studio"
}
diff --git a/gams-studio.desktop b/gams-studio.desktop
new file mode 100644
index 000000000000..98af09cfdccb
--- /dev/null
+++ b/gams-studio.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Name=GAMS Studio
+Comment=Perform arithmetic, scientific or financial calculations
+Keywords=calculation;arithmetic;scientific;financial;
+Exec=gams-studio
+# Translators: Do NOT translate or transliterate this text (this is an icon file name)!
+Icon=android-studio
+Terminal=false
+Type=Application
+StartupNotify=true
+Categories=Programming;