summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD36
-rw-r--r--configuration.patch20
-rw-r--r--ganglia-web.install14
5 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5c3bc82b290b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = ganglia-web
+ pkgdesc = Web front-end to Ganglia (see ganglia package)
+ pkgver = 3.6.2
+ pkgrel = 2
+ url = http://ganglia.sourceforge.net/
+ install = ganglia-web.install
+ arch = any
+ license = BSD
+ depends = ganglia
+ options = !libtool
+ options = !strip
+ source = http://downloads.sourceforge.net/ganglia/ganglia-web-3.6.2.tar.gz
+ source = ganglia-web.install
+ source = configuration.patch
+ sha256sums = 5368dc424fadc0fe1cc47730a628f514f710d59f7f6a4c53848f1a8f1116932a
+ sha256sums = 5d750ce804626eb657758875dc006fe467d92c20d79e3b4a05d099360887ec5b
+ sha256sums = 99991e9a17975b97c1049e7f8d6c92afb8dab75f987b2a13cb8cdf1faf1b1918
+
+pkgname = ganglia-web
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f34a96c51ab9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b1e02f7eda89
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Tyler Langlois <ty |at| tjll |dot| net>
+
+pkgname=ganglia-web
+pkgver=3.6.2
+pkgrel=2
+pkgdesc="Web front-end to Ganglia (see ganglia package)"
+arch=('any')
+url="http://ganglia.sourceforge.net/"
+license=('BSD')
+depends=('ganglia')
+options=('!libtool' '!strip')
+install='ganglia-web.install'
+source=("http://downloads.sourceforge.net/ganglia/$pkgname-$pkgver.tar.gz"
+ 'ganglia-web.install'
+ 'configuration.patch')
+sha256sums=('5368dc424fadc0fe1cc47730a628f514f710d59f7f6a4c53848f1a8f1116932a'
+ '5d750ce804626eb657758875dc006fe467d92c20d79e3b4a05d099360887ec5b'
+ '99991e9a17975b97c1049e7f8d6c92afb8dab75f987b2a13cb8cdf1faf1b1918')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ for patch in $srcdir/*.patch; do
+ msg2 "Applying patch $(basename $patch)"
+ patch -Np1 -i $patch
+ done
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ mkdir -p "$pkgdir/usr/share/webapps"
+ cp -a . "$pkgdir/usr/share/webapps/ganglia"
+
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/${pkgname}/COPYING"
+}
diff --git a/configuration.patch b/configuration.patch
new file mode 100644
index 000000000000..0c6e9604adef
--- /dev/null
+++ b/configuration.patch
@@ -0,0 +1,20 @@
+--- a/conf_default.php
++++ b/conf_default.php
+@@ -10,7 +10,7 @@
+ # Gmetad-webfrontend version. Used to check for updates.
+ #
+ $conf['gweb_root'] = dirname(__FILE__);
+-$conf['gweb_confdir'] = "/var/lib/ganglia-web";
++$conf['gweb_confdir'] = "/var/lib/ganglia";
+
+ include_once $conf['gweb_root'] . "/version.php";
+
+@@ -326,7 +326,7 @@ $conf['external_location'] = "http://localhost/ganglia-2";
+ # From version 3.2, backwards compatibility will be disabled by default.
+ # default: true (for gmetad < 3.2)
+ # default: false (for gmetad >= 3.2)
+-$conf['case_sensitive_hostnames'] = true;
++$conf['case_sensitive_hostnames'] = false;
+
+ # The following property controls whether the graphs contained in metric
+ # groups are initially displayed or collapsed
diff --git a/ganglia-web.install b/ganglia-web.install
new file mode 100644
index 000000000000..a1c7c27aa9fb
--- /dev/null
+++ b/ganglia-web.install
@@ -0,0 +1,14 @@
+# Arg 1: the new package version
+post_install() {
+ install -d -o http -g http /var/lib/ganglia/{conf,dwoo{,/cache,/compiled}}
+ echo "Make sure that your php open_basedir includes /usr/share/webapps" \
+ "and /var/lib/ganglia."
+}
+
+# Arg 1: the old package version
+post_remove() {
+ echo "NOTE: Please remove /var/lib/ganglia/{conf,dwoo} manually if they" \
+ "are no longer required."
+}
+
+# vim:set ts=2 sw=2 et: