summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
-rw-r--r--garden.install11
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c17c460bb3ef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = garden
+ pkgdesc = Garden of coloured lights, a game by Linley Henzell, is a vertical shoot-em-up that is a piece of art
+ pkgver = 1.0.8
+ pkgrel = 4
+ url = http://garden.sourceforge.net
+ install = garden.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = allegro4
+ depends = hicolor-icon-theme
+ provides = garden
+ source = http://sourceforge.net/projects/garden/files/garden/1.0.8/garden-1.0.8.tar.gz
+ md5sums = 42966f2c457d71a3ff0dd30522801ade
+
+pkgname = garden
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..48a0d06da72c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Karol 'Kenji Takahashi' Woźniak <kenji.sx>
+# Contributor: Gadget3000 <gadget3000 at msn dot com>
+
+pkgname=garden
+pkgver=1.0.8
+pkgrel=4
+pkgdesc="Garden of coloured lights, a game by Linley Henzell, is a vertical shoot-em-up that is a piece of art"
+arch=('i686' 'x86_64')
+url="http://garden.sourceforge.net"
+license=('GPL3')
+depends=('allegro4' 'hicolor-icon-theme')
+provides=('garden')
+install=garden.install
+source=(http://sourceforge.net/projects/garden/files/garden/${pkgver}/garden-${pkgver}.tar.gz)
+md5sums=('42966f2c457d71a3ff0dd30522801ade')
+
+build() {
+ cd ${srcdir}/garden-${pkgver}
+ LIBS="$LIBS -lm" ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${srcdir}/garden-${pkgver}
+ make DESTDIR=${pkgdir} install
+}
+
+# vim:set ts=4 sw=4 et:
+
diff --git a/garden.install b/garden.install
new file mode 100644
index 000000000000..5596cd589f0f
--- /dev/null
+++ b/garden.install
@@ -0,0 +1,11 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}