summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index afe71177ab41..e7235b7d43a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -21,6 +21,7 @@ pkgbase = gargoyle
depends = libjpeg
depends = libpng
depends = zlib
+ depends = hicolor-icon-theme
optdepends = speech-dispatcher: Text-to-Speech
provides = gargoyle
conflicts = gargoyle-mod
diff --git a/PKGBUILD b/PKGBUILD
index 26b455be477d..d341a6913d1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@ pkgdesc="Interactive Fiction multi-interpreter that supports all major IF format
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
url="http://ccxvii.net/gargoyle/"
license=('GPL')
-depends=('sdl2_mixer' 'sdl2' 'freetype2' 'qt5-base' 'fontconfig' 'libjpeg' 'libpng' 'zlib')
+depends=('sdl2_mixer' 'sdl2' 'freetype2' 'qt5-base' 'fontconfig' 'libjpeg' 'libpng' 'zlib' 'hicolor-icon-theme')
makedepends=('cmake' 'pkgconfig' 'desktop-file-utils')
optdepends=('speech-dispatcher: Text-to-Speech')
provides=('gargoyle')
@@ -36,7 +36,9 @@ build() {
cd "${srcdir}/garglk-${pkgver}"
mkdir -p build
cd build
- cmake .. -DWITH_TTS=DYNAMIC -DCMAKE_INSTALL_PREFIX=/usr
+ # the Arch package guidelines say to use
+ # /usr/lib instead of /usr/libexec.
+ cmake .. -DWITH_TTS=DYNAMIC -DCMAKE_INSTALL_LIBEXECDIR=lib -DCMAKE_INSTALL_PREFIX=/usr
make
}