summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD27
2 files changed, 11 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 32134a687a6d..1585a9b94c87 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gargoyle-git
pkgdesc = Interactive Fiction multi-interpreter that supports all major IF formats (development version)
- pkgver = 2019.1.r514.g6914267
+ pkgver = 2022.1.r563.gbde657b4
pkgrel = 1
url = https://github.com/garglk/garglk
install = gargoyle-git.install
@@ -13,6 +13,7 @@ pkgbase = gargoyle-git
makedepends = pkgconfig
makedepends = desktop-file-utils
makedepends = git
+ makedepends = fmt
depends = sdl2_mixer
depends = sdl2
depends = freetype2
@@ -20,6 +21,7 @@ pkgbase = gargoyle-git
depends = fontconfig
depends = libjpeg
depends = libpng
+ optdepends = speech-dispatcher: text-to-speech support
provides = gargoyle-git
conflicts = gargoyle-mod
conflicts = gargoyle
diff --git a/PKGBUILD b/PKGBUILD
index b7d33e8b7a56..b564a7d434a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,20 +5,20 @@
# Marcin Skory <armitage at q84fh dot net>
# with Contribution of Eric Forgeot < http://ifiction.free.fr >
pkgname=gargoyle-git
-pkgver=2019.1.r514.g6914267
+pkgver=2022.1.r563.gbde657b4
pkgrel=1
pkgdesc="Interactive Fiction multi-interpreter that supports all major IF formats (development version)"
arch=('i686' 'x86_64' 'armv6h')
url="https://github.com/garglk/garglk"
license=('GPL')
depends=('sdl2_mixer' 'sdl2' 'freetype2' 'qt5-base' 'fontconfig' 'libjpeg' 'libpng')
-makedepends=('cmake' 'pkgconfig' 'desktop-file-utils' 'git')
+makedepends=('cmake' 'pkgconfig' 'desktop-file-utils' 'git' 'fmt')
+optdepends=('speech-dispatcher: text-to-speech support')
provides=('gargoyle-git')
conflicts=('gargoyle-mod' 'gargoyle')
replaces=('gargoyle-mod' 'gargoyle')
groups=(inform)
-source=("$pkgname::git+https://github.com/garglk/garglk.git" \
- "gargoyle-git.install")
+source=("$pkgname::git+https://github.com/garglk/garglk.git" "gargoyle-git.install")
install=${pkgname}.install
sha512sums=('SKIP'
'1fa602865745c1c9801178ee9b24be86215f2af4f9ee3f4f3b3c0606a87aba32a67c9c5343b481332c8fc97ff6c1a5e447f074d116c0cc5b255af35098096e6e')
@@ -29,23 +29,12 @@ pkgver() {
}
build() {
- cd "$pkgname"
- mkdir -p build
- cd build
- # Don't build with Text-to-Speech support.
- # TODO: Make this an optional package.
- cmake .. -DWITH_TTS=false -DCMAKE_INSTALL_PREFIX=/usr
- make
+ cmake -S "${pkgname}" -B "build" -DWITH_TTS=DYNAMIC -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr"
+ cmake --build "build"
}
package() {
- cd "$pkgname/build"
- make DESTDIR="$pkgdir/" install
-
- cd -
- local gsrcdir="$pkgname"
-
+ cmake --install "build"
# Install default config
- install -dm755 "$pkgdir/etc"
- install -m755 "$gsrcdir/garglk/garglk.ini" "$pkgdir/etc"
+ install -Dm755 "$srcdir/${pkgname}/garglk/garglk.ini" "$pkgdir/etc/garglk.ini"
}