summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
-rw-r--r--gaurodan.desktop9
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9af5eda4c43c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gaurodan
+ pkgdesc = A classic arcade shooter inspired by titles like Defender, Choplifter or Sky Kid.
+ pkgver = 1
+ pkgrel = 1
+ url = http://www.locomalito.com/gaurodan.php
+ arch = i686
+ arch = x86_64
+ license = unknown
+ source = http://www.locomalito.com/juegos/Gaurodan_linux.zip
+ source = gaurodan.desktop
+ md5sums = bf7995fc9b2b1f9c93385936adb9ade7
+ md5sums = 16b4f4da929a05b6a94079bd02771813
+
+pkgname = gaurodan
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4fd510bf8389
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Sebastian Wolf <fatmike303 at googlemail dot com>
+pkgname=gaurodan
+_orgname=Gaurodan
+pkgver=1
+pkgrel=1
+pkgdesc='A classic arcade shooter inspired by titles like Defender, Choplifter or Sky Kid.'
+arch=('i686' 'x86_64')
+url='http://www.locomalito.com/gaurodan.php'
+license=('unknown')
+if [ '$CARCH' = 'x86_64' ]; then
+ depends=('lib32-mesa' 'lib32-openal' 'lib32-openssl')
+elif [ '$CARCH' = 'i686' ]; then
+ depends=('mesa' 'openal' 'openssl')
+fi
+source=("http://www.locomalito.com/juegos/${_orgname}_linux.zip" "${pkgname}.desktop")
+md5sums=('bf7995fc9b2b1f9c93385936adb9ade7' '16b4f4da929a05b6a94079bd02771813')
+
+package() {
+ mkdir ${pkgdir}/opt/
+ cp ${srcdir}/${_orgname} ${pkgdir}/opt/${pkgname} -R
+ install -D -m644 ${pkgname}.desktop ${pkgdir}/usr/share/applications/${pkgname}.desktop
+}
diff --git a/gaurodan.desktop b/gaurodan.desktop
new file mode 100644
index 000000000000..1a90bb4194ef
--- /dev/null
+++ b/gaurodan.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Encoding=UTF-8
+Type=Application
+Name=Gaurodan
+Exec=/opt/gaurodan/runner
+Icon=/opt/gaurodan/assets/icon.png
+Terminal=false
+StartupNotify=false
+Categories=Game;