summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD42
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ebe098b63a30
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gawk-git
+ pkgdesc = GNU version of awk
+ pkgver = 4.1.4.r1635.g5557a45f
+ pkgrel = 1
+ url = https://www.gnu.org/software/gawk/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = glibc
+ depends = mpfr
+ provides = awk
+ conflicts = gawk
+ source = git+https://git.savannah.gnu.org/git/gawk.git
+ sha256sums = SKIP
+
+pkgname = gawk-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7555301a03a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=gawk-git
+pkgver=4.1.4.r1635.g5557a45f
+pkgrel=1
+pkgdesc="GNU version of awk"
+arch=('i686' 'x86_64')
+url="https://www.gnu.org/software/gawk/"
+license=('GPL3')
+depends=('glibc' 'mpfr')
+makedepends=('git')
+provides=('awk')
+conflicts=('gawk')
+source=("git+https://git.savannah.gnu.org/git/gawk.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "gawk"
+
+ git describe --long --tags | sed 's/^gawk-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "gawk"
+
+ ./bootstrap.sh
+ ./configure --prefix="/usr" --without-libsigsegv
+ make
+}
+
+check() {
+ cd "gawk"
+
+ make check
+}
+
+package() {
+ cd "gawk"
+
+ make DESTDIR="$pkgdir" install
+}