summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..946ebdbba7a3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Mon Sep 18 00:51:24 UTC 2017
+pkgbase = gawkextlib
+ pkgdesc = Library containing APIs used by various GAWK extensions
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://sourceforge.net/projects/gawkextlib/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ source = https://downloads.sourceforge.net/gawkextlib/gawkextlib-1.0.2.tar.gz
+ md5sums = 23affb4f0936e55c3fdb9b30c7c03039
+ sha256sums = e3959df018680dde196087120e5672cf1b98cc9c2b1c391c0957ee9f00558048
+
+pkgname = gawkextlib
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2b022307d03e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.tar.xz
+*.tar.gz
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..290b70a42849
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Patrick McCarty <pnorcks at gmail dot com>
+
+pkgname=gawkextlib
+_project=$pkgname
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="Library containing APIs used by various GAWK extensions"
+arch=('i686' 'x86_64')
+url="https://sourceforge.net/projects/gawkextlib/"
+license=('GPL')
+source=("https://downloads.sourceforge.net/$_project/$pkgname-$pkgver.tar.gz")
+md5sums=('23affb4f0936e55c3fdb9b30c7c03039')
+sha256sums=('e3959df018680dde196087120e5672cf1b98cc9c2b1c391c0957ee9f00558048')
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ make -k check
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}